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CHAPTER 1

Foreword

1.1 Background

In 2008 we launched the Gentle Introduction to GIS1, a completely free, open content resource
for people who want to learn about GIS without being overloaded with jargon and new termi-
nology. It was sponsored by the South African government and has been a phenomenal success,
with people all over the world writing to us to tell us how they are using the materials to run
University Training Courses, teach themselves GIS and so on. The Gentle Introduction is not a
software tutorial, but rather aims to be a generic text (although we used QGIS in all examples)
for someone learning about GIS. There is also the QGIS manual which provides a detailed
functional overview of the QGIS application. However, it is not structured as a tutorial, but
rather as a reference guide. At Linfiniti Consulting CC. we frequently run training courses and
have realised that a third resource is needed - one that leads the reader sequentially through
learning the key aspects of QGIS in a trainer-trainee format - which prompted us to produce
this work.

This training manual is intended to provide all the materials needed to run a 5 day course on
QGIS, PostgreSQL and PostGIS. The course is structured with content to suit novice, inter-
mediate and advanced users alike and has many exercises complete with annotated answers
throughout the text.

1.2 License

The Free Quantum GIS Training Manual by Linfiniti Consulting CC. is licensed un-
der a Creative Commons Attribution-NonCommercial-ShareAlike 3.0 Unported License.
Based on a work at https://github.com/qgis/QGIS-Training-Manual. Permissions be-
yond the scope of this license may be available at https://github.com/qgis/QGIS-Training-
Manual/blob/master/index.rst.

1http://linfiniti.com/dla

1
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https://github.com/qgis/QGIS-Training-Manual/blob/master/index.rst
https://github.com/qgis/QGIS-Training-Manual/blob/master/index.rst


Quantum GIS Training Manual, Release 1.0

We have published this QGIS training manual under a liberal license that allows you to freely
copy, modify and redistribute this work. A complete copy of the license is available at the end
of this document. In simple terms, the usage guidelines are as follows:

• You may not represent this work as your own work, or remove any authorship text or
credits from this work.

• You may not redistribute this work under more restrictive permissions than those under
which it was provided to you.

• If you add a substantitive portion to the work and contribute it back to the project (at
least one complete module) you may add your name to the end of the authors list for this
document (which will appear on the front page)

• If you contribute minor changes and corrections you may add yourself to the contributors
list below.

• If you translate this document in its entirety, you may add your name to the authors list
in the form “Translated by Joe Blogs”.

• If you sponsor a module or lesson, you may request the author to include an acknowl-
edgement in the beginning of each lesson contributed, e.g.:

Note: This lesson was sponsored by MegaCorp.

• If you are unsure about what you may do under this license, please contact us at of-
fice@linfiniti.com2 and we will advise you if what you intend doing is acceptable.

• If you publish this work under a self publishing site such as http:://lulu.com we request
that you donate the profits to the QGIS project.

• You may not commercialise this work, except with the expressed permission of the au-
thors. To be clear, by commercialisation we mean that you may not sell for profit, create
commercial derivative works (e.g. selling content for use as articles in a magazine). The
exception to this is if all the profits are given to the QGIS project. You may (and we
encourage you to do so) use this work as a text book when conducting training courses,
even if the course itself is commercial in nature. In other words, you are welcome to
make money by running a training course that uses this work as a text book, but you may
not profit off the sales of the book itself - all such profits should be contributed back to
QGIS.

1.3 Sponsoring Chapters

This work is by no means a complete treatise on all the things you can do with QGIS and we
encourage others to add new materials to fill any gaps. Linfiniti Consulting CC. can also create
additional materials for you as a commercial service, with the understanding that all such works
produced should become part of the core content and be published under the same license.

2office@linfiniti.com
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1.4 Authors

• Rüdiger Thiede (rudi@linfiniti.com3) - Rudi has written the QGIS instructional materials
and parts of the PostGIS materials.

• Tim Sutton (tim@linfiniti.com4) - Tim has overseen and guided the project and co-
authored the PostgreSQL and PostGIS parts. Tim also authored the custom sphinx theme
used for this manual.

• Horst Düster (horst.duester@kappasys.ch5 ) - Horst co-authored the PostgreSQL and
PostGIS parts

• Marcelle Sutton (marcelle@linfiniti.com6) - Marcelle provided proof reading and edito-
rial advice during the creation of this work.

1.5 Individual Contributors

Your name here!

1.6 Sponsors

• Cape Peninsula University of Technology

1.7 Data

The sample data that accompanies this resource is freely available and comes from the follow-
ing sources:

• Streets and Places datasets from OpenStreetMap (http://www.openstreetmap.org/)

• Property boundaries (urban and rural), water bodies from NGI (http://www.ngi.gov.za/)

• SRTM DEM from the CGIAR-CGI (http://srtm.csi.cgiar.org/)

1.8 Latest Version

You can always obtain the latest version of this document by visiting our home page7 which is
kindly hosted by http://readthedocs.org.

3rudi@linfiniti.com
4tim@linfiniti.com
5horst.duester@kappasys.ch
6marcelle@linfiniti.com
7http://readthedocs.org/builds/the-free-qgis-training-manual/
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Note: There are links to PDF and epub versions of the documentation in the lower right hand
corner of the above mentioned home page.

Tim Sutton, May 2012
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CHAPTER 2

Module: The Interface

2.1 Lesson: A Brief Introduction

Welcome to our course! Over the next few days, we’ll be showing you how to use QGIS easily
and efficiently. If you’re new to GIS, we’ll tell you what you need to get started. If you’re an
experienced user, you’ll see how QGIS fulfills all the functions you expect from a GIS program,
and more!

In this module we introduce the QGIS project itself, as well as explaining the user interface.

After completing this section, you will be able to correctly identify the main elements of the
screen in QGIS and know what each of them does, and load a shapefile into QGIS.

Warning: This course includes instructions on adding, deleting and altering GIS datasets.
We have provided training datasets for this purpose. Before using the techniques described
here on your own data, always ensure you have proper backups!

2.1.1 How to use this tutorial

Any text that looks like this refers to something on the screen that you can click on.

Text that looks → like → this directs you through menus.

This kind of text refers to something you can type, such as a command, path, or file
name.

2.1.2 Tiered course objectives

This course caters to different user experience levels. Depending on which category you con-
sider yourself to be in, you can expect a different set of course outcomes. Each category
contains information that is essential for the next one, so it’s important to do all exercises that
are at or below your level of experience.

5
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Basic

In this category, the course assumes that you have little or no prior experience with theoretical
GIS knowledge or the operation of a GIS program.

Limited theoretical background will be provided to explain the purpose of an action you will
be performing in the program, but the emphasis is on learning by doing.

When you complete the course, you will have a better concept of the possibilities of GIS, and
how to harness their power via QGIS.

Intermediate

In this category, it is assumed that you have working knowledge and experience of the everyday
uses of GIS.

Following the instructions for the beginner level will provide you with familiar ground, as well
as to make you aware of the cases where QGIS does things slightly differently from other
software you may be used to. You will also learn how to use analysis functions in QGIS.

When you complete the course, you should be comfortable with using QGIS for all of the
functions you usually need from a GIS for everyday use.

Advanced

In this category, the assumption is that you are experienced with GIS, have knowledge of and
experience with spatial databases, using data on a remote server, perhaps writing scripts for
analysis purposes, etc.

Following the instructions for the other two levels will familiarize you with the approach that
the QGIS interface follows, and will ensure that you know how to access the basic functions
that you need. You will also be shown how to make use of QGIS’ plugin system, database
access system, and so on.

When you complete the course, you should be well-acquainted with the everyday operation of
QGIS, as well as its more advanced functions.

2.1.3 Why QGIS?

As information becomes increasingly spatially aware, there is no shortage of tools able to fulfill
some or all commonly used GIS functions. Why should anyone be using QGIS over some other
GIS software package?

Here are only some of the reasons:

• It’s free, as in lunch. Installing and using the QGIS program costs you a grand total of
zero money. No initial fee, no recurring fee, nothing.

6 Chapter 2. Module: The Interface
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• It’s free, as in liberty. If you need extra functionality in QGIS, you can do more than
just hope it will be included in the next release. You can sponsor the development of a
feature, or add it yourself if you are familiar with programming.

• It’s constantly developing. Because anyone can add new features and improve on existing
ones, QGIS never stagnates. The development of a new tool can happen as quickly as
you need it to.

• Extensive help and documentation is available. If you’re stuck with anything, you can
turn to the extensive documentation, your fellow QGIS users, or even the developers.

• Cross-platform. QGIS can be installed on MacOS, Windows and Linux.

Now that you know why you want to use QGIS, we can show you how. The first lesson will
guide you in creating your first QGIS map.

2.2 Lesson: Adding your first layer

We will start the application, and create a basic map to use for examples and exercises.

The goal for this lesson: To get started with an example map.

Note: Before starting this exercise, QGIS must be installed on your computer.

Launch QGIS from its desktop shortcut, menu item, etc., depending on how you configured its
installation.

Note: The screenshots for this course were taken in QGIS 1.8 running on Ubuntu 11.10 and
Windows XP. Depending on your setup, the screens you encounter may well appear somewhat
different. However, all the same buttons will still be available, and the instructions will work
on any OS. You will need QGIS 1.8 (the latest version at time of writing) to use this course.

Let’s get started right away!

2.2.1 Follow along: Prepare a map

• Open QGIS. You will have a new, blank map.

• Look for the Add Vector Layer button:

• Click on it to open the following dialog:

2.2. Lesson: Adding your first layer 7
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• Click on the Browse button and navigate to the file exercise_data/streets.shp
(in your course directory). With this file selected, click Open. You will see the original
dialog, but with the file path filled in. Click Open here as well. The data you specified
will now load.

Congratulations! You now have a basic map. Now would be a good time to save your work.

• Click on the Save As button:

• Save the map under exercise_data/ and call it basic_map.qgs.

Check your results

2.2.2 In conclusion

You’ve learned how to add a layer and create a basic map!

2.2.3 What’s next?

Now you’re familiar with the function of the Add Vector Layer button, but what about all the
others? How does this interface work? Before we go on with the more involved stuff, let’s first
take a good look at the general layout of the QGIS interface. This is the topic of the next lesson.

2.3 Lesson: An Overview of the Interface

We will explore the QGIS user interface so that you are familiar with the menus, toolbars, map
canvas and layers list that form the basic structure of the interface.

8 Chapter 2. Module: The Interface
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The goal for this lesson: To understand the basics of the QGIS user interface.

2.3.1 Try yourself...: The Basics

The elements identified in the figure above are:

1. Layers list

2. Toolbars

3. Map canvas

4. Status bar

The Layers List

In the Layers list, you can see a list, at any time, of all the layers available to you.

Expanding collapsed items (by clicking the arrow or plus symbol beside them) will provide
you with more information on the layer’s current appearance.

2.3. Lesson: An Overview of the Interface 9
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Right-clicking on a layer will give you a menu with lots of extra options. You will be using
some of them before long, so take a look around!

Some versions of QGIS have a separate Control rendering order checkbox just underneath the
Layers list. Don’t worry if you can’t see it. If it is present, ensure that it’s checked for now.

Note: A vector layer is a dataset, usually of a specific kind of object, such as roads, trees, etc.
A vector layer can consist of either points, lines or polygons.

Toolbars

Your most oft-used sets of tools can be turned into toolbars for basic access. For example, the
File toolbar allows you to save, load, print, and start a new project. You can easily customize
the interface to see only the tools you use most often, adding or removing toolbars as necessary
via the View → Toolbars menu.

Even if they are not visible in a toolbar, all of your tools will remain accessible via the menus.
For example, if you remove the File toolbar (which contains the Save button), you can still save
your map by clicking on the File menu and then clicking on Save.

The Map Canvas

This is where the map itself is displayed.

The Status Bar

Shows you information about the current map. Also allows you to adjust the map scale and see
the mouse cursor’s coordinates on the map.

2.3.2 Try yourself... 1

Try to identify the four elements listed above on your own screen, without referring to the
diagram above. See if you can identify their names and functions. You will become more
familiar with these elements as you use them in the coming days.

Check your results

2.3.3 Try yourself... 2

Try to find each of these tools on your screen. What is their purpose?

10 Chapter 2. Module: The Interface
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1.

2.

3.

4.

5.

Hint: If any of these tools is not visible on the screen, try enabling some toolbars that are
currently hidden. Also keep in mind that if there isn’t enough space on the screen, a toolbar
may be shortened by hiding some of its tools. You can see the hidden tools by clicking on the
double right arrow button in any such collapsed toolbar. You can see a tooltip with the name of
any tool by holding your mouse over the tool for a while.

Check your results

2.3.4 What’s next?

Now you’ve seen how the QGIS interface works, you can use the tools available to you and
start improving on your map! This is the topic of the next lesson.

2.3. Lesson: An Overview of the Interface 11



Quantum GIS Training Manual, Release 1.0

12 Chapter 2. Module: The Interface



CHAPTER 3

Module: Creating a Basic Map

In this module, you will create a basic map which will be used later as a basis for further
demonstrations of QGIS’ functionality.

3.1 Lesson: Working with Vector Data

Vector data is arguably the most common kind of data you will find in the daily use of GIS. It
describes geographic data in terms of points, that may be connected into lines and polygons.
Every object in a vector dataset is called a feature, and is associated with data that describes
that feature.

The goal for this lesson: To learn about the structure of vector data, and how to load vector
datasets into a map.

3.1.1 Follow along: Viewing layer attributes

It’s important to know that the data you will be working with does not only represent where
objects are in space, but also tells you what those objects are.

From the previous exercise, you should have the streets layer loaded in your map. What you
can see right now is merely the position of the roads.

To see all the data available to you:

• Click on this button:

It will show you a table with more data about the streets layer. This extra data is called attribute
data. The lines that you can see on your map represent where the streets go; this is the spatial
data.

These definitions are commonly used in GIS, so it’s essential to remember them!

• You may now close the attribute table.

13
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Vector data represents features in terms of points, lines and polygons on a coordinate plane. It
is usually used to store discrete features, like roads and city blocks.

3.1.2 Follow along: Loading vector data from shapefiles

The Shapefile is a specific file format that allows you to store GIS data in an associated group of
files. Each layer consists of several files with the same name, but different file types. Shapefiles
are easy to send back and forth, and most GIS software can read them.

Refer back to the introductory exercise in the previous section for instructions on how to add
vector layers.

• Load the “places” dataset into your map following the same method.

Check your results

3.1.3 Follow along: Loading vector data from a database

Databases allow you to store a large volume of associated data in one file. You may already
be familiar with a database management system (DBMS) such as Microsoft Access. GIS ap-
plications can also make use of databases. GIS-specific DBMSes (such as PostGIS) have extra
functions, because they need to handle spatial data.

• Click on this icon:

(If you’re sure you can’t see it at all, check that the Manage Layers toolbar is enabled.)

It will give you a new dialog. In this dialog:

• Click the New button.

• In the same folder as the other data, you should find the file land_use.db. Select it and
click Open.

You will now see the first dialog again. Notice that the dropdown select above the three buttons
now reads “land_use.db@...”, followed by the path of the database file on your computer.

• Click the Connect button. You should see this in the previously empty box:

• Click on the first layer to select it, then use shift+click to select all of them at once.

• Click Add. This will add all three layers to the map at once.
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Note: Remember to save the map often! The map file doesn’t contain any of the data directly,
but it remembers which layers you loaded into your map.

Check your results

3.1.4 Follow along: Reordering the layers

The layers in your Layers list are drawn on the map in a certain order. The layer at the bottom
of the list is drawn first, and the layer at the top is drawn last. By changing the order that they
are shown on the list, you can change the order they are drawn in.

Note: Depending on the version of QGIS that you are using, you may have a checkbox beneath
your Layers list reading Control rendering order. This must be checked (switched on) so that
moving the layers up and down in the Layers list will bring them to the front or send them to
the back in the map. If your version of QGIS doesn’t have this option, then it is switched on by
default and you don’t need to worry about it.

The order in which the layers have been loaded into the map is probably not logical at this
stage. It’s possible that the road layer is completely hidden because other layers are on top of
it.

For example, this layer order...

... would result in roads and places being hidden as they run underneath urban areas.

To resolve this problem:

• Click and drag on a layer in the Layers list.

• Reorder them to look like this:
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3.1.5 In conclusion

Now you’ve added all the layers you need from several different sources.

3.1.6 What’s next?

Using the random palette automatically assigned when loading the layers, your current map
is probably not easy to read. It would be preferable to assign your own choice of colors and
symbols. This is what you’ll learn to do in the next lesson.

3.2 Lesson: Symbology

The symbology of a layer is its visual appearance on the map. The basic strength of GIS over
other ways of representing data with spatial aspects is that with GIS, you have a dynamic visual
representation of the data you’re working with.

Therefore, the visual appearance of the map (which depends on the symbology of the individual
layers) is very important. The end user of the maps you produce will need to be able to easily
see what the map represents. Equally as important, you need to be able to explore the data as
you’re working with it, and good symbology helps a lot.

In other words, having proper symbology is not a luxury or just nice to have. In fact, it’s
essential for you to use a GIS properly and produce maps and information that people will be
able to use.

The goal for this lesson: To be able to create any symbology you want for any vector layer.
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3.2.1 Follow along: Changing colors

To change a layer’s symbology, open its Layer Properties. Let’s begin by changing the color
of the urban layer.

• Right-click on the urban layer in the Layers list.

• Select the menu item Properties in the menu that appears.

Note: By default, you can also access a layer’s properties by double-clicking on the layer in
the Layers list.

In the Properties window:

• Select the Style tab at the extreme left:

• Click the Change button next to the Color label.
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A standard color dialog will appear.

• Choose a grey color and click OK.

• Click OK again in the Layer Properties window, and you will see the color change being
applied to the layer.

3.2.2 Try yourself...

Change the rural layer to a new color that you associate with rural farming areas.

Check your results

3.2.3 Follow along: Changing symbol structure

This is good stuff so far, but there’s more to a layer’s symbology than just its color. Next we
want to change the color of the farms (the rural layer), but we also want to eliminate the lines
between the different farms so as to make the map less visually cluttered.

• Open the Layer Properties window for the rural layer.
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Under the Style tab, you will see the same kind of dialog as before. This time, however, you’re
doing more than just quickly changing the color.

• Click on the Change... button below the color display:

The Symbol properties dialog will appear.

• Change the color inside the polygons in the layer by clicking the button next to the Color
label (if you haven’t done so already during the previous lesson).

• In the dialog that appears, choose a new color (that seems to suit a farm).

• Click OK, but only once.

Next, we want to get rid of the lines between all the farms.

• Click on the Border style dropdown. At the moment, it should be showing a short line
and the words Solid Line.

• Change this to No Pen.

3.2. Lesson: Symbology 19



Quantum GIS Training Manual, Release 1.0

• Click OK, and then OK again.

Now the rural layer won’t have any lines between farms.

3.2.4 Try yourself...

• Change the urban layer’s symbology so that it is gray and without outlines.

• Change the rural layer again so that it has dotted outlines which are just a bit darker than
the fill color for that layer.

Check your results

3.2.5 Follow along: Scale-based visibility

Sometimes you will find that a layer is not suitable for a given scale. For example, a dataset
of all the continents may have low detail, and not be very accurate at street level. When that
happens, you want to be able to hide the dataset at inappropriate scales.

In our case, we may decide to hide the streets from view at small scales. This map, for example
...

... is not very useful. The streets are just a blob at that scale.

To enable scale-based rendering:

• Open the Layer Properties dialog for the streets layer.

• Activate the General tab.
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• Enable scale-based rendering by clicking on the checkbox labeled Use scale dependent
rendering:

• Change the Maximum value to 100000.

• Click OK.

Test the effects of this by zooming in and out in your map, noting when the streets layer disap-
pears and reappears.

Note: You can use your mouse wheel to zoom in increments. Alternatively, use the zoom tools
to zoom to a window:
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3.2.6 Follow along: Adding symbol layers

Now that you know how to change simple symbology for layers, the next step is to create more
complex symbology. QGIS allows you to do this using symbol layers.

• Go back to the rural layer’s Symbol properties dialog as before.

In this example, the current symbol has no outline (i.e., it uses the No Pen border style).

Note the highlighted button.

• Click on it and the dialog will change to look somewhat like this:
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(It may appear somewhat different in color, for example, but you’re going to change that any-
way.)

Now there’s a second symbol layer. Being a solid color, it will of course completely hide the
previous kind of symbol. Plus, it has a Solid Line border style, which we don’t want. Clearly
this symbol has to be changed.

Note: It’s important not to get confused between a map layer and a symbol layer. A map layer
is a vector (or raster) that has been loaded into the map. A symbol layer is part of the symbol
used to represent a map layer. This course will usually refer to a map layer as just a layer, but
a symbol layer will always be called a symbol layer, to prevent confusion.

• Set the border style to No Pen, as before.

• Change the fill style to something other than Solid or No brush. For example:
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• Click OK in this dialog and Apply in the one after that. Now you can see your results and
tweak them as needed.

You can even add multiple extra symbol layers and create a kind of texture for your layer that
way.
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It’s fun! But it probably has too many colors to use in a real map...

3.2.7 Try yourself...

• Create a simple, but not distracting texture for the rural layer using the methods above.

Check your results

3.2.8 Follow along: Enabling symbol levels

When symbol layers are rendered, they are also rendered in a sequence, similar to how the
different map layers are rendered. This means that in some cases, having many symbol layers
in one symbol can cause unexpected results.

• Give the streets layer an extra symbol layer (using the methid for adding symbol layers
demonstrated above).

• Give the base line a thickness of 2.0.

• Give the top layer a thickness of 0.5.

You’ll notice that this happens:
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Well that’s not what we want at all!

To prevent this from happening, you can enable symbol levels, which will control the order in
which the different symbol layers are rendered.

• In the Layer Properties dialog, click on Advanced → Symbol levels:
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The Symbol Levels dialog will appear.

• Alter its values to match this example:
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• Click OK, then OK again.

The map will now look like this:
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When you’re done, remember to save the symbol itself so as not to lose your work if you
change the symbol again in the future. You can save your current symbol style by clicking the
Save Style ... button under the Style tab of the Layer Properties dialog. Save your style under
exercise_data/styles. You can load a previously saved style at any time by clicking
the Load Style ... button. Before you change a style, keep in mind that any unsaved style you
are replacing will be lost.

3.2.9 Try yourself...

• Change the appearance of the streets layer again.

The roads must be dark gray or black, with a thin yellow outline, and a dashed white line
running in the middle to make them resemble a real road.

Check your results

3.2.10 Try yourself...

Symbol levels also work for classified layers (i.e., layers having multiple symbols). Since we
haven’t covered classification yet, you will work with some rudimentary preclassified data.
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• Create a new map and add only the streets dataset.

• Apply the style advanced_levels_demo.qml provided in
exercise_data/styles.

• Zoom to the Swellendam area (the cluster of roads near the center of the layer).

• Using symbol layers, ensure that the outlines of layers flow into one another as per the
image below:

Check your results

3.2.11 Follow along: Symbol layer types

In addition to setting fill colors and using predefined patterns, you can use different symbol
layer types entirely. The only type we’ve been using up to now was the Simple Fill type. The
more advanced symbol layer types allow you to customize your symbols even further.

Each type of vector (point, line and polygon) has its own set of symbol layer types. First we
will look at the types available for points.

Point symbol layer types

• Change the symbol properties for the places layer:
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• You can access the various symbol layer types here:
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• Investigate the various options available to you, and choose a symbol layer type other
than the default Simple Marker.

• If in doubt, use an Ellipse Marker.

• Choose a white outline and black fill, with a symbol width of 2,00 and symbol height of
4,00.

Line symbol layer types

To see the various options available for line data:

• Change the symbol layer type for the street layer’s topmost symbol layer:

• Click on the Change button next to the Marker label.

• Change the symbol properties to match this dialog:
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• Change the interval to 2,00:

• Ensure that the symbol levels are correct before applying the style.
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Once you have applied the style, take a look at its results on the map. As you can see, these
symbols change direction along with the road but don’t always bend along with it. This is
useful for some purposes, but not for others. If you prefer, you can change the symbol layer in
question back to the way it was before.

Polygon symbol layer types

To see the various options available for polygon data:

• Change the symbol layer type for the urban layer, as before for the other layers.

• Investigate what the different options on the list can do.

• Choose one of them that you find suitable.

• If in doubt, use the Point pattern fill with the following options:

34 Chapter 3. Module: Creating a Basic Map



Quantum GIS Training Manual, Release 1.0

• Add a new symbol layer with a normal Simple fill.

• Make it gray with no outlines.

• Move it underneath the point pattern symbol layer with the Move down button:
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As a result, you have a textured symbol for the urban layer, with the added benefit that you can
change the size, shape and distance of the individual dots that make up the texture.

3.2.12 Follow along: Creating a custom SVG fill

Note: To do this exercise, you will need to have the free vector editing software Inkscape
installed.

• Start the Inkscape program.

You will see the following interface:

36 Chapter 3. Module: Creating a Basic Map



Quantum GIS Training Manual, Release 1.0

You should find this familiar if you have used other vector image editing programs, like Corel.

• Change the canvas to a size appropriate for a small texture.

• Click on the menu item File → Document Properties. This will give you the Document
Properties dialog.

• Change the Units to px.
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• Change the Width and Height to 100.

• Close the dialog when you are done.

• Click on the menu item View → Zoom → Page to see the page you are working with.

• Select the Circle tool:

• Click and drag on the page to draw an ellipse. To make the ellipse turn into a circle, hold
the ctrl button while you’re drawing it.

• Right-click on the circle you just created and open its Fill and Stroke:
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• Change the Stroke paint to green:
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• Change the Stroke style to a thicker line:
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• Draw a line using the Line tool:
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• Click once to start the line. Hold ctrl to make it snap to increments of 15 degrees.

• Click once to end the line segment, then right-click to finalize the line.

• Change its color and width as before and move it around as necessary, so that you end up
with a symbol like this one:

42 Chapter 3. Module: Creating a Basic Map



Quantum GIS Training Manual, Release 1.0

• Save it under the directory that the course is in, under exercise_data/symbols, as
an SVG file.

In QGIS:

• Open the Layer Properties for the rural layer.

• Change the symbol structure to the following:
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• Find your SVG image via the Browse button:
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• Change the settings as shown:
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Your rural layer should now have a texture like the one on this map:
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3.2.13 In conclusion

Changing the symbology for the different layers has transformed a collection of vector files
into a legible map. Not only can you see what’s happening, it’s even nice to look at!

3.2.14 Further reading

Examples of Beautiful Maps1

3.2.15 What’s next?

Changing symbols for whole layers is useful, but the information contained within each layer
is not yet available to someone reading these maps. What are the streets called? Which admin-
istrative regions do certain areas belong to? What are the relative surface areas of the farms?
All of this information is still hidden. The next lesson will explain how to represent this data
on your map.

Note: Did you remember to save your map recently?

1http://gis.stackexchange.com/questions/3083/examples-of-beautiful-maps
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Module: Classifying Vector Data

Classifying vector data allows you to assign different symbols to features (different objects in
the same layer), depending on their attributes. This allows someone who uses the map to easily
see the attributes of various features.

4.1 Lesson: Attribute Data

Up to now, none of the changes we have made to the map have been influenced by the objects
that are being shown. In other words, all the farms look alike, and all the roads look alike.
When looking at the map, the viewers don’t know anything about the roads they are seeing;
only that there is a road of a certain shape in a certain area.

But the whole strength of GIS is that all the objects that are visible on the map, also have
attributes. Maps in a GIS aren’t just pictures. They represent not only objects in locations, but
also information about those objects.

The goal of this lesson: To explore the attribute data of an object and understand what the
various data can be useful for.

4.1.1 Follow along: Attribute data

Open the attribute table for the places layer (refer back to the section “Working with Vector
Data” if necessary). Which field would be the most useful to represent in label form, and why?

Check your results

4.1.2 In conclusion

You now know how to use the attribute table to see what is actually in the data you’re using.
Any dataset will only be useful to you if it has the attributes that you care about. If you know
which attributes you need, you can quickly decide if you’re able to use a given dataset, or if
you need to look for another one that has the required attribute data.
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4.1.3 What’s next?

Different attributes are useful for different purposes. Some of them can be represented directly
as text for the map user to see. You’ll learn how to do this in the next lesson.

4.2 Lesson: The Label Tool

Labels can be added to a map to show any information about an object. Any vector layer can
have labels associated with it. These labels rely on the attribute data of a layer for their content.

Note: The Layer Properties dialog does have a Labels tab, but for this example we will not be
using it. It has too few options and may be difficult to work with, which is why it will probably
be taken out of new versions of QGIS (after 1.8). Instead, for this lesson we’ll use the separate
Label tool, which has more options and is more user-friendly.

The goal for this lesson: To apply useful and good-looking labels to a layer.

4.2.1 Follow along: Using labels

Before being able to access the Label tool, you will need to ensure that it has been activated.

• Go to the menu item View → Toolbars.

• Ensure that the Label item has a check mark next to it. If it doesn’t, click on the Label
item, and it will be activated.

• Click on the places layer in the Layers list, so that it is highlighted.

• Click on the following toolbar button:

This gives you the Layer labeling settings dialog.

• Check the box next to Label this layer with....
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You’ll need to choose which field in the attributes will be used for the labels. In the previous
lesson, you decided that the NAME field was the most suitable one for this purpose.

• Select NAME from the list:
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• Click OK.

The map should now have labels like this:
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4.2.2 Follow along: Changing label options

What we have so far is good, but as you can see, the labels are overlapping the points that they
are associated with. That doesn’t look very nice. The text is also a bit larger than it needs to
be. Let’s fix these problems!

• Open the Label tool again by clicking on its button as before.

• Click on the ellipsis (...) button to change the text properties:
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A standard text change dialog appears, similar to those in many other programs. Change the
font to Arial size 9. Your labels will now look like this:

That’s the font problem solved! Now let’s look at the problem of the labels overlapping the
points, but before we do that, let’s take a look at the Buffer option.
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• Open the Label tool dialog.

• Deactivate the label buffer by clicking on the checkbox next to the text that says Buffer.

• Click Apply.

Note the effects in the map:

Now you can see why we usually need label buffers!

• Reactivate the buffers by clicking in the same checkbox as before, and then clicking
Apply.

Back to the problem of the labels that overlap points.

• In the Label tool dialog, go to the Advanced tab.

• Change the value of Label distance to 2.
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• Click Apply.

This is the result:
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4.2.3 Follow along: Using labels instead of layer symbology

In many cases, the location of a point doesn’t need to be very specific. For example, most of
the points in the places layer refer to entire towns or suburbs, and the specific point associated
with such features is not that specific on a large scale. In fact, giving a point that is too specific
is often confusing for someone reading a map.

To name an example: on a map of the world, the point given for the European Union may
be somewhere in Poland, for instance. To someone reading the map, seeing a point labeled
European Union in Poland, it may seem that the capital of the European Union is therefore in
Poland.

So, to prevent this kind of misunderstanding, it’s often useful to deactivate the point symbols
and replace them completely with labels.

In QGIS, you can do this by changing the position of the labels to be rendered directly over the
points they refer to.

• Open the Layer labeling settings dialog for the places layer.

• Go to the Advanced tab.

• Click on the over point button.

• Hide the point symbols by editing the layer style as usual, and setting the size of points
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to 0:

• Click OK and you’ll see this result:
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As you can see, some of the labels are now missing to prevent overlap (at this scale). Sometimes
this is what you want when dealing with datasets that have many points, but at other times you
will lose useful information this way. There is another possibility for handling cases like this,
which we’ll cover in a later exercise in this lesson.

4.2.4 Try yourself... Customize the labels

• Return the label and symbol settings to the way they were before.

Check your results

• Set the map to the scale 1:50000. You can do this by typing it into the Scale box in the
Status Bar.

• Modify your labels to be suitable for viewing at this scale.

Check your results

4.2.5 Follow along: Labeling lines

Now that you know how labeling works, there’s an additional problem. Points and polygons
are easy to label, but what about lines? If you label them the same way as the points, your
results would look like this:
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This is not very useful! To make lines behave, we’ll need to edit some options.

• Hide the places layer so that it doesn’t distract you.

• Activate labels for the streets layer as before. (Remember to use the Label tool on the
toolbar, not the one in Label Properties!)

• Set the font Size to 9 so that you can see more labels.

• Zoom in on the Swellendam town area.

• In the Label tool dialog’s Advanced tab, choose the following settings:
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The map will look somewhat like this, depending on scale:
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It’s better than before, but still not ideal. For starters, some of the names appear more than
once, and that’s not always necessary. To prevent that from happening:

• Enable the option Merge connected lines to avoid duplicate labels (also under the Ad-
vanced tab - you may need to scroll down to see it).

Another useful function is to prevent labels being drawn for features too short to be of notice.

• Set the value of Suppress labeling of features smaller than ... to 5mm and note the results
when you click Apply.

Try out different Placement settings as well (also under the Advanced tab). As we’ve seen
before, the horizontal option is not a good idea in this case, so let’s try the curved option
instead!

• Select the curved option under the Advanced tab of the Layer labeling settings dialog.

Here’s the result:

As you can see, this hides a lot of the labels that were previously visible, because of the diffi-
culty of making some of them follow twisting street lines and still be legible. You can decide
which of these options to use, depending on what you think seems more useful or what looks
better.

4.2.6 Follow along: Data defined settings

• Deactivate labeling for the streets layer.
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• Reactivate labeling for the places layer.

• Open the attribute table for places.

It has two fields that are of interest to us now: ADDR_CITY and IN_SWD. ADDR_CITY is the
city that the feature is in. IN_SWD is derived from it, and tells you whether or not that feature
is in Swellendam (1 if it is, 0 if not). We can use this data to influence the label styles.

• Navigate to the Data defined settings tab.

• In the Italic dropdown, select IN_SWD and click Apply.

Notice its effects:

4.2.7 Try yourself... Using data defined settings

Note: We’re jumping ahead a bit here to demonstrate some advanced labeling settings. At the
advanced level, it’s assumed that you’ll know what the following means. If you don’t, feel free
to leave out this section and come back later when you’ve covered the requisite materials.

• Open the attribute table for places.

• Enter edit mode by clicking this button (at the lower edge of the attribute table):

• Add a new column:

• Configure it like this:
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• Use this to set custom font sizes for each different type of place (i.e., each key in the
PLACE field).

Check your results

4.2.8 Further possibilities with labeling

We can’t cover every option in this course, but be aware that the Label tool has many other
useful functions. You can set scale-based rendering, alter the rendering priority for labels in
a layer, and set every label option using layer attributes. You can even set the rotation, XY
position, and other properties of a label (if you have attribute fields allocated for the purpose),
then edit these properties using the tools adjacent to the main Label tool:

(These tools will be active if the required attribute fields exist and you are in edit mode.)

Feel free to explore more possibilities of the labeling system.

4.2.9 In conclusion

You’ve learned how to use layer attributes to create dynamic labels. This can make your map a
lot more informative and stylish!
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4.2.10 What’s next?

Now that you know how attributes can make a visual difference for your map, how about using
them to change the symbology of objects themselves? That’s the topic for the next lesson!

4.3 Lesson: Classification

Labels are a good way to communicate information such as the names of individual places, but
they can’t be used for everything. For example, let’s say that someone wants to know which
area the farms are in. Using labels, you’d get this:

Obviously this is not ideal, so we need another solution. That’s what this lesson is about!

The goal for this lesson: To learn how to classify vector data effectively.

4.3.1 Follow along: Classifying nominal data

• Open Layer Properties.

• Go to the Style tab.

• Click on the dropdown that says Single Symbol:
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• Change it to Categorized and the interface will change:
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• Change the Column to TOWN and the Color ramp to random:
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• Click the button labeled Classify and then click OK.

You’ll see something like this:
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• Click the arrow (or plus sign) next to rural in the Layer list, you’ll see the categories
explained:

So, this is useful! But it hurts your eyes to look at it, so let’s see what we can do about that.

• Open Layer Properties and go to the Style tab again.

• Change the symbol:
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• Get rid of the outline the same way you did before, and click OK. (If you need to, go
back to the lesson where we covered this to remember how it’s done.)

• Click the Delete all button:
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This gets rid of the ugly classes so you can try again.

• Click Classify again, and the new symbols will appear.

You’ll notice they don’t have outlines. This is because because you just removed the outlines!

• Change the color for each town by double-clicking on the colored block representing its
symbol:
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Use your own colors, but make sure they’re not too bright, so that the resulting map isn’t as
ugly as the old one. In the example, we’ll use these colors:
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This gives us a nice map:
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(Only rural and water are switched on here.)

By the way, there’s one category that’s empty:
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• Select the empty category.

• Click the Delete button.

This only gets rid of the symbol, not the data, so don’t worry about messing up; you’re not
actually deleting anything that you can’t recover.

Remember to save your map now so that you don’t lose all your hard-earned changes!

4.3.2 Try yourself... More classification

If you’re only following the basic-level content, use the knowledge you gained above to classify
the urban areas. Use darker colors to set them apart from the farms.

4.3.3 Follow along: Ratio classification

There are four types of classification: nominal, ordinal, interval and ratio.

4.3. Lesson: Classification 75



Quantum GIS Training Manual, Release 1.0

In nominal classification, the categories that objects are classified into are name-based; they
have no order. For example: town names, district codes, etc.

In ordinal classification, the categories are arranged in a certain order. For example, world
cities are given a rank depending on their importance for world trade, travel, culture, etc.

In interval classification, the numbers are on a scale with positive, negative and zero values. For
example: height above/below sea level, temperature above/below freezing (0 degrees Celsius),
etc.

In ratio classification, the numbers are on a scale with only positive and zero values. For ex-
ample: temparature above absolute zero (0 degrees Kelvin), distance from a point, the average
amount of traffic on a given street per month, etc.

In the example above, we used nominal classification to assign each farm to the town that it is
administered by. Now we will use ratio classification to classify the farms by area.

• Save your rural symbology (if you want to keep it) by clicking on the Save Style ... button
in the Style dialog.

We’re going to reclassify the layer, so existing classes will be lost if not saved.

• Close the Style dialog.

• Open the layer attributes for the rural layer.

We want to classify these farms by area, but there’s a problem: they don’t have an area field!
We’ll have to make one.

• Enter edit mode by clicking this button:

• Add a new column with this button:

• Set up the dialog that appears, like this:
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• Click OK.

The new field will be added (at the far right of the table; you may need to scroll horizontally to
see it). However, at the moment it is not populated, it just has a lot of NULL values.

To solve this problem, we’ll need to calculate the areas.

• Open the field calculator:

You’ll get this dialog:

4.3. Lesson: Classification 77



Quantum GIS Training Manual, Release 1.0

• Change the values at the top of the dialog to look like this:

• In the Function List, select Geometry → $area:
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• Double-click on it so that it appears in the Expression field.

• Click OK.

Now your AREA field is populated with values! Admire them, then close the attribute table.

Note: These areas are in degrees area. Later, we will compute them in square meters.

• Open the Layer properties dialog’s Style tab.

• Change the classification style from Classified to Graduated:
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• Change the Column to AREA:
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• Under Color ramp, choose the option New color ramp... to get this dialog:

• Choose Gradient (if it’s not selected already) and click OK. You’ll see this:
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You’ll be using this to denote area, with small areas as Color 1 and large areas as Color 2.

• Choose appropriate colors.

In the example, the result looks like this:
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• Click OK.

• Choose a suitable name for the new color ramp.

• Click OK after filling in the name.

Now you’ll have something like this:
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Leave everything as-is.

• Click Apply:
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4.3.4 Try yourself... Refine the classification

• Get rid of the lines between the classes.

• Change the values of Mode and Classes until you get a classification that makes sense.

Check your results

4.3.5 Follow along: Rule-based classification

It’s often useful to combine multiple criteria for a classification, but unfortunately normal clas-
sification only takes one attribute into account. That’s where rule-based classification comes in
handy.

• Open the Layer Properties dialog for the rural layer.

• Switch to the Style tab.

• Switch the classification style to Rule-based. You’ll get this:
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• Click the Add button.

• A new dialog that appears.

• Click the ellipsis ... button next to the Filter text area.

• Using the query builder that appears, enter the criterion AREA >= 0.00085 and
choose a dark color for it.

• Add the criterion AREA <= 0.00085 and choose a light color.

• Add the criterion TOWN != ’Swellendam Rural’ and assign it the color black,
with transparency at 85%.

• Click on the TOWN ... criterion in the list of rules, and then on Increase priority.

Your dialog should look like this:
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• Apply this symbology.

Your map will look like this:
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Now you have two area classes, with the farms in the Swellendam Rural area emphasized.

4.3.6 In conclusion

Symbology allows us to represent the attributes of a layer in an easy-to-read way. It allows us
as well as the map reader to understand the significance of features, using any relevat attributes
that we choose. Depending on the problems you face, you’ll apply different classification
techniques to solve them.

4.3.7 What’s next?

Now we have a nice-looking map, but how are we going to get it out of QGIS and into a format
we can print out, or make into an image or PDF? That’s the topic of the next lesson!
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CHAPTER 5

Module: Creating Maps

In this module, you’ll learn how to use the QGIS Map Composer to produce quality maps with
all the requisite map components.

5.1 Lesson: Using Map Composer

Now that you’ve got a map, you need to be able to print it or to export it to a document. The
reason is, a GIS map file is not an image! Rather, it saves the state of the GIS program, with
references to all the layers, their labels, colors, etc. So for someone who doesn’t have the data
or the same GIS program (such as QGIS), the map file will be useless. Luckily, QGIS can
export its map file to a format that anyone’s computer can read, as well as printing out the map
if you have a printer connected. Both exporting and printing is handled via the Map Composer.

The goal for this lesson: To use the QGIS Map Composer to create a basic map with all the
required settings.

5.1.1 Follow along: The Composer Manager

QGIS allows you to create multiple maps using the same map file. For this reason, it has a tool
called the Composer Manager.

• Click on the File → Composer Manager menu entry to open this tool. You’ll see a blank
Composer manager dialog appear.

• Click the Add button and a new composer will be added called Composer 1 (it may be
another number if you have tried using the Composer Manager before now).

• With your new composer selected, click on the Rename button and rename it to
Swellendam.

• Click OK.

• Click the Show button.

(You could also close the dialog and navigate to a composer via the File → Print Composers
menus, as in the image below.)
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Whichever route you take to get there, you will now see the Print Composer window.

5.1.2 Follow along: Basic Map Composition

In this example, the composition was already the way we wanted it. Ensure that yours is as
well.

• Check that the values under General → Composition → Paper and Quality are set to the
following:

• Size: A4 (210x297mm)

• Orientation: Landscape

• Quality: 300dpi

Now you’ve got the page layout the way you wanted it, but this page is still blank. It clearly
lacks a map. Let’s fix that!

• Click on the Add New Map button:

With this tool activated, you’ll be able to place a map on the page.

• Click and drag a box on the blank page:
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The map will appear on the page.

• Move the map by clicking and dragging it around:

• Resize it by clicking and dragging the boxes in the corners:
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Note: Your map may look a lot different, of course! This depends on how your own project is
set up. But not to worry! These instructions are general, so they will work the same regardless
of what the map itself looks like.

• Be sure to leave margins along the edges, and a space along the top for the title:

92 Chapter 5. Module: Creating Maps



Quantum GIS Training Manual, Release 1.0

• Zoom in and out on the page (but not the map!) by using these buttons:

• Zoom and pan the map in the main QGIS window. You can also pan the map using the
Move item content tool:

When zooming in, the map view will not refresh by itself. This is so that it doesn’t waste
your time redrawing the map while you’re zooming the page to where you want it, but it also
means that if you zoom in or out, the map will be at the wrong resolution and will look ugly or
unreadable.

• Force the map to refresh by clicking this button:

Remember that the size and position you’ve given the map doesn’t need to be final. You can
always come back and change it later if you’re not satisfied. For now, you need to ensure that
you’ve saved your work on this map. Because a Composer in QGIS is part of the main map
file, you’ll need to save your main project. Go to the main QGIS window (the one with the
Layers list and all the other familiar elements you were working with before), and save your
project from there as usual.
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5.1.3 Follow along: Adding a Title

Now your map is looking good on the page, but the reader is not being told what’s going on
yet. They need some context, which is what you’ll provide for them by adding map elements.
First, let’s add a title.

• Click on this button:

• Click on the page, and a label will appear:

• Resize it and place it in the top center of the page. It can be resized and moved in the
same way that you resized and moved the map.
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But if you tried it, you’ll see that it’s difficult to align the label to be completely centered to the
map! Luckily, there’s a tool for that.

• Click the map to select it.

• Hold in shift on your keyboard and click on the label.

• Look for this tool (but don’t click it yet):

• Click on the downwards arrow next to the button.

• Click Align center:
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To make sure that you don’t accidentally move these elements around now that you’ve aligned
them:

• Right-click on both the map and the label.

A small lock icon will appear in the corner to tell you that an element can’t be dragged right
now. You can always right-click on an element again to unlock it, though.

Now the label is centered to the map, but not the contents. To center the contents of the label:

• Select the label by clicking on it.

• Click on the Item tab in the side panel of the Composer window.

• Change the text of the label to “Swellendam”:
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• Use this interface to set the font and alignment options:

• Choose a large but sensible font (the example will use the default font with a size of 48),
and keep the color subdued.

In fact, it’s probably best to keep it black as per the default. The key is that the font should
not be distracting, otherwise people who see the page will be looking at the heading instead of
reading the map!

• Set the Horizontal Alignment to Center, so that the heading is properly centered within
the label.
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This is progressing nicely, but the label still has an unnecessary frame around it:

Let’s get rid of it.

• Click on the General options slider at the bottom of the Item tab. The Label slider will
slide away and you will see a new interface.
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• Click the Show frame checkbox to disable the frame:

Here is our page so far:
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5.1.4 Follow along: Adding a Legend

The map reader also needs to be able to see what various things on the map actually mean. In
some cases, like the place names, this is quite obvious. In other cases, it’s more difficult to
guess, like the colors of the farms. Let’s add a new legend.

• Click on this button:

• Click on the page to place the legend, and move it to where you want it:
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5.1.5 Follow along: Customizing Legend Items

Not everything on the legend is necessary, so let’s remove some unwanted items.

• In the Item tab, click on the Legend items slider.

• Select the places entry.

• Delete it from the legend by clicking the minus button:

You can also rename items.

• Select a layer from the same list.

• Click the Edit button:

• Rename the layers to Roads and Streets, Surface Water, Urban Areas,
and Farms.

• Click the down arrow next to any item with multiple classes to rename the classes (using
the same method as above).
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In the example, the Farms layer’s areas were computed in units that aren’t easy to convert
to land area directly. If your farms are classified by area or some other criteria, you should
rename those classes to something that would make sense to the map reader. In the example,
we renamed the smallest class small area and the largest one large area, with the one
in the middle moderate area and the rest blanked out.

This is the result:

5.1.6 Follow along: Exporting Your Map

Note: Did you remember to save your work often?

Finally the map is ready for export! You’ll see the export buttons near the top left corner of the
Composer window:

The button on the right is the Print button, which interfaces with a printer. Since the printer
options will differ depending on the model of printer that you’re working with, it’s probably
better to consult the printer manual or a general guide to printing for more information on this
topic.

The other three buttons allow you to export the map page to a file. There are three export
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formats to choose from:

• Export as Image

• Export as PDF

• Export as SVG

Exporting as an image will give you a selection of various common image formats to choose
from. This is probably the simplest option, but the image it creates is “dead” and difficult to
edit.

The other two options are more common.

If you’re sending the map to a cartographer (who may want to edit the map for publication),
it’s best to export as an SVG. SVG stands for “Scalable Vector Graphic”, and can be imported
to programs like Inkscape or other vector image editing software.

If you need to send the map to a client, it’s most common to use a PDF, because it’s easier to
set up printing options for a PDF. Some cartographers may prefer PDF as well, if they have a
program that allows them to import and edit this format.

For our purposes, we’re going to use PDF.

• Click the Export as PDF button:

• Choose a save location and a file name as usual.

• Click Save.

5.1.7 In conclusion

• Close the Composer window.

• Save your map.

• Find your exported PDF using your operating system’s file manager.

• Open it.

• Bask in its glory.

Congratulations on your first completed QGIS map project!

5.1.8 What’s next?

On the next page, you will be given an assignment to complete. This will allow you to practice
the techniques you have learned so far.
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5.2 Assignment 1

Open your existing map project and revise it thoroughly. If you have noticed small errors or
things you’d have liked to fix earlier, do so now.

If you are following this course at a Basic or Intermediate level, try to understand and imple-
ment techniques taught at a higher level.

While customizing your map, keep asking yourself questions. Is this map easy to read and
understand for someone who’s unfamiliar with the data? If I saw this map on the Internet, or
on a poster, or in a magazine, would it capture my attention? Would I want to read this map if
it wasn’t mine?

If you’re doing this course at a Basic or Intermediate level, read up on techniques
from the more advanced sections. If you see something you’d like to do in your map, why not
try to implement it?

If this course is being presented to you, the course presenter may require you to submit a final
version of your map, exported to PDF, for evaluation. If you’re doing this course by yourself,
it’s recommended that you evaluate your own map using the same criteria. Your map will be
evaluated on the overall appearance and symbology of the map itself, as well as the appearance
and layout of the map page and elements. Remember that the emphasis for evaluating the
appearance of maps will always be ease of use. The nicer the map is to look at and the easier it
is to understand at a glance, the better.

Happy customizing! :)

5.2.1 In conclusion

The first four modules have taught you how to create and style a vector map. In the next four
modules, you’ll learn how to use QGIS for a complete GIS analysis. This will include creating
and editing vector data; analyzing vector data; using and analyzing raster data; and using GIS
to solve a problem from start to finish, using both raster and vector data sources.
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CHAPTER 6

Module: Creating Vector Data

Creating maps using existing data is just the beginning. In this module, you’ll learn how to
modify existing vector data and create new datasets entirely.

6.1 Lesson: Creating a New Vector Dataset

The data that you use has to come from somewhere. For most common applications, the data
exists already; but the more particular and specialized the project, the less likely it is that the
data will already be available. In such cases, you’ll need to create your own new data.

The goal for this lesson: To create a new vector dataset.

6.1.1 Follow along: The Layer Creation Dialog

Before you can add new vector data, you need a vector dataset to add it to. In our case, you’ll
begin by creating new data entirely, rather than editing an existing dataset. Therefore, you’ll
need to define your own new dataset first.

You’ll need to open the New Vector Layer dialog that will allow you to define a new layer.

• Navigate to and click on the menu entry Layer → New → New Shapefile Layer.

You’ll be presented with the following dialog:
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It’s important to decide which kind of dataset you want at this stage. Each different vector layer
type is “built differently” in the background, so once you’ve created the layer, you can’t change
its type.

For the next exercise, we’re going to be creating new features which describe areas. For such
features, you’ll need to create a polygon dataset.

• Click on the Polygon radio button:
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This has no impact on the rest of the dialog, but it will cause the correct type of geometry to be
used when the vector dataset is created.

The next field allows you to specify the Coordinate Reference System, or CRS. A CRS specifies
how to describe a point on Earth in terms of coordinates, and because there are many different
ways to do this, there are many different CRSs. The CRS of this project is WGS84, so it’s
already correct by default:

Next there is a collection of fields grouped under New attribute. By default, a new layer has
only one attribute, the id field (which you should see in the Attributes list) below. However, in
order for the data you create to be useful, you actually need to say something about the features
you’ll be creating in this new layer! For our current purposes, it will be enough to add one field
called name.

• Replicate the setup below, then click the Add to attributes list button:

• Check that your dialog now looks like this:

6.1. Lesson: Creating a New Vector Dataset 107



Quantum GIS Training Manual, Release 1.0

• Click OK. A save dialog will appear.

• Navigate to the exercise_data directory.

• Save your new layer as school_property.shp.

The new layer should appear in your Layers list.
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6.1.2 Follow along: Data sources

When you create new data, it obviously has to be about objects that really exist on the ground.
Therefore, you’ll need to get your information from somewhere.

There are many different ways to obtain data about objects. For example, you could use a GPS
to capture points in the real world, then import the data into QGS afterwards. Or you could
survey points using a theodolite, and enter the coordinates manually to create new features. Or
you could use the digitizing process to trace objects off of remote sensing data, such as satellite
imagery or aerial photography.

For our example, you’ll be using the digitizing approach. Sample raster datasets are provided,
so you’ll need to import them as necessary.

• Click on the Add Raster Layer button:

• Navigate to exercise_data/raster/.

• Select the file 3420C_2010_327_RGB_LATLNG.tif.

• Click Open. An image will load into your map.

• Find the new image in the Layers list.

• Click and drag it to the bottom of the list so that you can still see your other layers.

• Find and zoom to this area:
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You’ll be digitizing these three fields:
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• Hide all the layers except the raster and the school_property layer.

In order to begin digitizing, you’ll need to enter edit mode. GIS software commonly requires
this to prevent you from accidentally editing or deleting important data. Edit mode is switched
on or off individually for each layer.

To enter edit mode for the school_property layer:

• Click on the layer in the Layer list to select it. (Make very sure that the correct layer is
selected, otherwise you’ll edit the wrong layer!)

• Click on the Toggle Editing button:

If you can’t find this button, check that the Digitizing toolbar is enabled. There should be a
check mark next to the View → Toolbars → Digitizing menu entry.

As soon as you are in edit mode, you’ll see the digitizing tools are now active:
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From left to right on the image above, they are:

• Toggle Edit: activates / deactivates edit mode.

• Save Edits: saves changes made to the layer.

• Add Feature: start digitizing a new feature.

• Move Feature(s): move an entire feature around.

• Node Tool: move only one part of a feature.

• Delete Selected: delete the selected feature (only active if a feature is selected).

• Cut Features: cut the selected feature (only active if a feature is selected).

• Copy Features: copy the selected feature (only active if a feature is selected).

• Paste Features: paste a cut or copied feature back into the map (only active if a feature
has been cut or copied).

You want to add a new feature.

• Click on the Add Feature button now to begin digitizing right away!

You’ll notice that your mouse cursor has become a crosshair. This allows you to more accu-
rately place the points you’ll be digitizing. Remember that even as you’re using the digitizing
tool, you can zoom in and out on your map by rolling the mouse wheel, and you can pan around
by holding down the mouse wheel and dragging around in the map.

The first feature you’ll be digitizing is the athletics field:
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• Start digitizing by clicking on a point somewhere along the edge of the field.

• Place more points by clicking further along the edge, until the shape you’re drawing
completely covers the field.

• To place your last point, right-click where you want it to be. This will finalize the feature
and show you the Attributes dialog.

• Fill in the values as below:
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• Click OK and you’ve created a new feature!

Remember, if you’ve made a mistake while digitizing a feature, you can always edit it after
you’re done creating it. If you’ve made a mistake, continue digitizing until you’re done creating
the feature as above. Then:

• Select the feature with the Select Single Feature tool:

You can use:
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• the Move Feature(s) tool to move the entire feature,

• the Node Tool to move only one point where you may have misclicked,

• Delete Selected to get rid of the feature entirely so you can try again, and

• the Edit → Undo menu item or the ctrl + z keyboard shortcut to undo mistakes.

6.1.3 Try yourself...

• Digitize the school itself and the upper field. Use this image to assist you:

Remember that each new feature needs to have a unique id value!

Note: When you’re done adding features to a layer, remember to save your edits and then exit
edit mode.
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6.1.4 Try yourself...

• Create a new line feature called river.shp with attributes id and type. (Use the
approach above to guide you.)

• Digitize the river that runs through town.

Start where the sandy riverbanks first become visible:

And stop when our river joins another river:
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It’s not always clear where the river runs. In such cases, use your better judgment and estimate
where the river goes. Remember that you’re capturing the river at a large scale, so try to follow
it in detail. Take some time, don’t let the line become too straight or make the corners too
sharp!

When creating the feature, give it the type attribute value of “stream”.

Check your results

6.1.5 In conclusion

Now you know how to create features! This course doesn’t cover adding point features, be-
cause that’s not really necessary once you’ve worked with more complicated features (lines
and polygons). It works exactly the same, except that you only click once where you want the
point to be, give it attributes as usual, and then the feature is created.

Knowing how to digitize is important because it’s a very common activity in GIS programs.
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6.1.6 What’s next?

Features in a GIS layer aren’t just pictures, but objects in space. For example, adjacent polygons
know where they are in relation to one another. This is called topology. In the next lesson you’ll
see an example of why this can be useful.

6.2 Lesson: Feature Topology

Topology is a useful aspect of vector data layers, because it minimizes errors such as overlap
or gaps.

For example: if two features share a border, and you edit the border using topology, then you
won’t need to edit first one feature, then another, and carefully line up the borders so that they
match. Instead, you can edit their shared border and both features will change at the same time.

The goal for this lesson: To understand topology using examples.

6.2.1 Follow along: Snapping

To make topological editing easier, it’s best if you enable snapping. This will allow your mouse
cursor to snap to other objects while you digitize. To set snapping options:

• Navigate to the menu entry Settings → Snapping Options....

• Set up your Snapping options dialog as shown:

• Ensure that the box in the Avoid Int. column is checked (set to true).

• Click OK to save your changes and leave the dialog.

• Enter edit mode with the rural layer selected.

• Check under View → Toolbars to make sure that your Advanced Digitizing toolbar is
enabled.

• Zoom to this area (enable layers and labels if necessary):
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• Digitize this new (fictional) farm:
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• When prompted, give it an id of 999, but feel free to leave the other values unchanged.

If you’re careful while digitizing and allow the cursor to snap to the vertices of adjoining farms,
you’ll notice that there won’t be any gaps between your new farm and the existing farms adja-
cent to it.

• Note the undo/redo tools in the Advanced Digitizing toolbar:

Those buttons will become your best friends...

6.2.2 Follow along: Closing the Gaps

You’ve probably noticed some large holes in the rural dataset:
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The white gaps among the farms, which are not filled by grey urban areas, represent missing
farms. Let’s say you want to close these gaps. If you were adding features normally, you’d
have to be very accurate to avoid gaps and overlap. In fact, even if you’re very accurate,
without vertex snapping (which you activated above), digitizing features without such errors is
impossible.

However, we have another tool to use for this situation. Since we already have topology en-
abled, it’s possible to very quickly close a hole without even worrying about accuracy, and the
topology will take care of the rest. For example, let’s say you want to digitize a new farm to
close up this gap:
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If you had to do this without help from the topology, you’d be digitizing that for a while. But
at the moment, as per the directions above, you have Avoid Int. (“Avoid Intersections”) enabled
for the rural layer. This tells QGIS to use the topology to prevent overlap. So you can digitize
even a very rough shape:
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(Use an id value of somewhere in the hundreds range to avoid a conflict with existing features.)

But when you select the feature ...
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... you’ll see that QGIS has automatically added all the detailed vertices and made sure that
there was no overlap!

• Try doing this now.

Note: The “Avoid Intersections” option only works to eliminate overlap (intersections). Ob-
viously, if you leave a gap, that will not be filled, because you might not actually want the gap
to be filled!

6.2.3 Try yourself...

• Close the remaining gaps using the approach above, but make sure not to create farms
over urban areas.

• Remember to save your edits, and if necessary, to exit edit mode.

Check your results
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6.2.4 Follow along: Correct topology errors

Topology errors aren’t always immediately visible. Let’s change the rural layer’s symbology
to see some of them.

• Set the symbology for the rural layer to a single (preferably dark) color.

• Set its Transparency slider to 50%.

• You should see results like these:

There are several things to notice here. First, the new farm you added is lighter than the others.
This is because in this dataset, there are several “levels” of farms: large farms and their sub-
divisions were digitized separately. So there is a large farm and its subdivisions resting on top
of each other, which makes the color darker because you’re seeing the lower one through the
upper one. That’s a feature of the dataset, not a problem.

But you can also notice a definite problem: one of the farms is going underneath another one!
Obviously this is a mistake, because in the real world farms don’t overlap, and two farms don’t
share the same subdivision.

Let’s correct this!

• Enter edit mode, if it isn’t active already.

• Select the Node Tool.

• Click on one of the corners of the problematic farm. This will select that farm for editing
and you’ll see all the nodes appear:
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• Click and drag the nodes until they snap into place.
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The topologically correct border looks like this:
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6.2.5 Follow along: Tool: Simplify Feature

This is the Simplify Feature tool:

• Click on it to activate it.

• Click on the new farm you created previously. You’ll be presented with this dialog:
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• Move the slider from side to side and watch what happens:

This allows you to recude the amount of nodes in complex features. However, notice what it
does to the topology! The simplified farm is now no longer touching the adjacent farms as it
should. That’s how you know that this tool is better suited to generalizing stand-alone features.
The advantage is that it provides you with a simple, intuitive interface for generalization, and
allows you to see what the effects would be before you even implement them.

Before you go on, get the farm back in its previous state. Either:

• cancel the Simplify Feature dialog, or

• if you already clicked OK, just undo the last change.
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6.2.6 Try yourself... Tool: Add Ring

This is the Add Ring tool:

It allows you to take a hole out of a feature, as long as the hole is bounded on all side by the
feature. For example, if you’ve digitized the outer boundaries of South Africa and you need to
add a hole for Lesotho, you’d use this tool.

• Try using this tool to create a gap in the middle of your farm.

• Undo the edit when you are done.

Check your results

6.2.7 Try yourself... Tool: Add Part

This is the Add Part tool:

It allows you to create an extra part of the feature, not directly connected to the main feature.
For example, if you’ve digitized the boundaries of mainland South Africa but you haven’t yet
added the Prince Edward Islands, you’d use this tool to create them.

• Try using this tool to add an outlying property to your farm.

• Undo the edit when you are done.

Check your results

6.2.8 Try yourself... Tools: Delete Ring and Delete Part

These are the Delete Ring and Delete Part tools, respectively:

Their functions should be obvious.

• Create new parts and rings as above and delete them to try see how these tools work.

• You need to click close to a node (corner) of a part or ring in order to delete it.
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6.2.9 Follow along: Tool: Reshape Features

This is the Reshape Features tool:

It can add a bump to an existing feature. With this tool selected:

• Click inside your farm.

• Add an extra piece of land.

• Right-click back inside the farm:

The result of the above:
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You can do the opposite, too:

• Click outside the feature.

• Take a bite out of it.

• Right-click outside the farm again:
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The result of the above:
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6.2.10 Try yourself... Tool: Split Features

The Split Features tool is similar to how you took part of the farm away, except that it doesn’t
delete either of the two parts. Instead, it keeps them both.

• Try it and see!

• Undo your edit before continuing with the exercise for the next tool.

6.2.11 Try yourself... Tool: Merge Features

• Find and select these farms:
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• Use the Merge Selected Features and Merge Attributes of Selected Features tools.

• Note the differences.

Check your results

6.2.12 In conclusion

Topology editing is a powerful tool that allows you to create and modify objects quickly and
easily, while ensuring that they remain topologically correct.

6.2.13 What’s next?

Now you know how to digitize the shape of the objects easily, but adding in the attributes is still
a bit of a headache! Next we’ll show you how to use forms so that attribute editing is simpler
and more effective.

6.3 Lesson: Forms

When you add new data via digitizing, you’re presented with a dialog that lets you fill in the
attributes for that feature. However, this dialog is not, by default, very nice to look at. This can
cause a usability problem, especially if you have large datasets to create, or if you want other
people to help you digitize and they find the default forms to be confusing.
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Fortunately, QGIS lets you create your own custom dialogs for a layer. This lesson shows you
how.

The goal for this lesson: To create a form for a layer.

6.3.1 Follow along: Using QGIS’ Form Design Functionality

• Select the streets layer in the Layers list.

• Enter Edit Mode as before.

• Open its Attribute Table.

• Right-click on any cell in the table. A short menu will appear, with the only entry being
Open form.

• Click on it to see the form that QGIS generates for this layer.

Obviously it would be nice to be able to do this while looking at the map, rather than needing
to search for a specific street in the Attribute Table all the time.

• Go to the Settings → Options menu (in the same row as the File menu, etc.).

• In the dialog that appears, select the Map Tools tab.

• Check the Open feature form ... checkbox:

• Close the Settings dialog.

• Select the streets layer in the Layers list.

• Using the Identify tool, click on any street in the map.
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Instead of the normal Identify dialog, you’ll see the now-familiar form instead:

6.3.2 Try yourself... Using the Form to Edit Values

If you are in edit mode, you can use this form to edit a feature’s attributes!

• Activate edit mode.

• Using the Identify tool, click on the main street running through Swellendam:
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• Edit its LANES value to the correct value of 2.

• Save your edits.

• Exit edit mode.

• Open the Attribute Table and see your edit there!

Note that there is more than one road on this map called Voortrekker. The one you edited had
a TYPE of tertiary.

6.3.3 Follow along: Setting Form Field Types

It’s nice to edit things using a form, but you still have to enter everything by hand. Fortunately,
forms have different kinds of so-called “widgets” that allow you to edit data in various different
ways.

• Open the streets layer’s Layer Properties.

• Switch to the Fields tab. You’ll see this:
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• Click on the Line edit button in the same row as LANES and you’ll be given a new dialog.

• In its only dropdown list, set the value to Range:
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• Set the values to this:
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• Click OK.

• Apply the changes to the Layer Properties.

• Enter edit mode.

• Click on the Identify tool.

• Click on Voortrekker road.

Now instead of entering values manually, you can use the up and down arrows next to the
LANES field to edit its values!

6.3.4 Try yourself...

Set new, more appropriate form widgets for these fields:

• TYPE
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• ONEWAY

Check your results

6.3.5 Try yourself... Creating Test Data

You can also design your own custom form completely from scratch.

• Create a simple point layer with two attributes:

– Name (text)

– Age (text)
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• Capture a couple of points to your new layer using the digitizing tools so that you have a
little data to play with. You should be presented with the default QGIS generated attribute
capture form each time you capture a new point.
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6.3.6 Follow along: Creating a New Form

Now we want to create our own custom form for the attribute data capture phase. To do this,
you need to have Qt4 Designer installed (only needed for the person who creates the forms). It
should be provided as part of your course materials, if you’re using Windows. You may need
to look for it if you’re using another OS. In Ubuntu, do the following in the terminal:

sudo apt-get install qt4-designer

... and it should install automatically. Otherwise, look for it in the Software Center.

• Start Designer by opening its Start Menu entry in Windows (or whatever approach is
appropriate in your OS).

• In the dialog that appears, create a new dialog:
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• Look for the Widget Box along the left of your screen (default). It contains an item called
Line Edit.

• Click and drag this item into your form. This creats a new Line Edit in the form.

• With the new line edit element selected, you’ll see its properties along the side of your
screen (on the right by default):
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• Set its name to Name.

• Using the same approach, create a new spinbox and set its name to Age.

• Add a Label with the text Add a New Person in a bold font (look in the object
properties to find out how to set this). Alternatively, you may want to set the title of
the dialog itself (rather than adding a label).

• Click anywhere in your dialog.

• Find the Lay Out Vertically button (in a toolbar along the top edge of the screen, by
default). This lays out your dialog automatically.

• Set the dialog’s maximum size (in its properties) to 200 (width) by 100 (height).

• Save your new form as exercise_data/forms/add_people.ui.
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• When it’s done saving, you can close the Qt4 Designer program.

6.3.7 Follow along: Associating the Form with Your Layer

• Go back to QGIS.

• Double click the layer in the legend to access its properties.

• Click on the General tab in the Layer Properties dialog.

• Specify the path to your ui file in the Edit UI field.

• Click OK on the Layer Properties dialog.

• Enter edit mode and capture a new point.

• When you do so, you will be presented with your custom dialog (instead of the generic
one that QGIS usually creates).

• If you click on one of your points using the Identify tool, you can now bring up the form
by right clicking in the identify results window and choosing View Feature Form from
the context menu.

• If you are in edit mode for this layer, that context menu will show Edit Feature Form
instead, and you can then adjust the attributes in the new form even after initial capture.

6.3.8 In conclusion

Using forms, you can make life easier for yourself when editing or creating data. By editing
widget types or creating an entirely new form from scratch, you can control the experience
of someone who digitizes new data for that layer, thereby minimizing misunderstandings and
unnecessary errors.

6.3.9 Further reading

If you completed the advanced section above and have knowledge of Python, you may want to
check out this blog entry1 about creating custom feature forms with Python logic, which allows
advanced functions including data validation, autocompletion, etc.

6.3.10 What’s next?

Opening a form on identifying a feature is one of the standard actions that QGIS can perform.
However, you can also direct it to perform custom actions that you define. This is the subject
of the next lesson.

1http://tinyurl.com/6tr42rb
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6.4 Lesson: Actions

Now that you’ve seen a default action in the previous lesson, it’s time to define your own
actions. An action is something that happens when you click on a feature. It can add a lot of
extra functionality to your map, allowing you to retrieve additional information about an object,
for example. Assigning actions can add a whole new dimension to your map!

The goal for this lesson: To learn how to add custom actions.

6.4.1 Follow along: The Actions Tab

• Open the Layer Properties dialog for the rural layer.

• Click on the Actions tab to see its contents.

Seems intimidating! But it doesn’t need to be. Let’s see how it works by adding a new action.

6.4.2 Follow along: Open an Image

Use the school_property layer you created previously. The course materials include photos of
each of the three properties you digitized. What we’re going to do next is to associate each
property with its image. Then we’ll create an action that will open the image for a property
when clicking on the property.

6.4.3 Follow along: Add a Field for Images

The school_property layer has no way to associate an image with a property yet. First we’ll
create a field for this purpose.

• Open the Layer Properties dialog.

• Click on the Fields tab.

• Toggle editing mode:
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• Add a new column:
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• Enter the values below:

• After the field has been created, click on the Line edit button next to the new field.

• Set it up for a File name:
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• Click OK on the Layer Properties dialog.

• Use the Identify tool to click on one of the three features in the school_property layer.

Since you’re still in edit mode, the dialog should be active and look like this:
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• Click on the browse button (the ... next to the image field).

• Select the path for your image. The images are in
exercise_data/school_property_photos/ and are named the same as
the features they should be associated with.

• Click OK.

• Associate all of the images with the correct features using this method.

• Save your edits and exit edit mode.

6.4.4 Follow along: Creating an Action

• Open the Actions form for the school_property layer, as explained above for the rural
layer.

• Enter the words Show Image into the Name field:
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What to do next varies according to your operating system, so choose the appropriate course to
follow:

Windows

• Click on the Type dropdown and choose Open.

Ubuntu Linux

• Under Action, write eog for the Gnome Image Viewer, or write display to use Im-
ageMagick. Remember to put a space after the command!

MacOS

• Click on the Type dropdown and choose Mac.

• Under Action, write open. Remember to put a space after the command!

Continue writing the command

The next part is easy! You want to open the image, and QGIS knows where the image is. All it
needs to do is to tell the Action where the image is.

• Select image from the list:
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• Click the Insert field button. QGIS will add the phrase [% "image" %] in the Action
field.

• Click the Add to action list button.

• Click OK on the Layer Properties dialog.

Now to test the new action!

• Click on the school_property layer in the Layers list so that it is highlighted.

• Find the Run feature action button (on the same toolbar as the Open Attribute Table
button):

• Click on the down arrow to the right of this button. There’s only one action defined for
this layer so far, which is the one you just created.

• Click the button itself to activate the tool.

• Using this tool, click on any of the three school properties.
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• The image for that property will now open. Congratulations!

6.4.5 Follow along: Searching the Internet

Let’s say we’re looking at the map and want to know more about the area that a farm is in.
Suppose you know nothing of the area in question and want to find general information about
it. Your first impulse, considering that you’re using a computer right now, would probably be
to Google the name of the area. So let’s tell QGIS to do that automatically for us!

• Open the attribute table for the rural layer (you may need to close Layer Properties first).

There are several fields with names of the area that the farms are in, but many of them contain
some rather strange names. The one field that contains names that are easy to search for on
Google is the SGADMIN field. So we’ll be using that field for our searches.

• Close the attribute table.

• Go back to Actions in Layer Properties.

• In the field Action Properties → Name, write Google Search.

What to do next varies according to your operating system, so choose the appropriate course to
follow:

Windows

• Under Type, choose Open. This will tell Windows to open an Internet address in your
default browser, such as Internet Explorer.

Ubuntu Linux

• Under Action, write xdg-open. This will tell Ubuntu to open an Internet address in
your default browser, such as Chrome or Firefox.

MacOS

• Under Action, write open. This will tell MacOS to open an Internet address in your
default browser, such as Safari.

Continue writing the command

Whichever command you used above, you need to tell it which Internet address to open next.
You want it to visit Google, and to search for a phrase automatically.

Usually when you use Google, you enter your search phrase into the Google Search bar.
But in this case, you want your computer to do this for you. The way you tell Google to
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search for something (if you don’t want to use its search bar directly) is by giving your Inter-
net browser the address http://www.google.co.za/search?q=SEARCH_PHRASE,
where SEARCH_PHRASE is what you want to search for. Since we don’t know what phrase to
search for yet, we’ll just enter the first part (without the search phrase).

• In the Action field, write http://www.google.co.za/search?q=. Remember
to add a space after your initial command before writing this in!

Now you want QGIS to tell the browser to tell Google to search for the value of SGADMIN for
any feature that you could click on. Sounds complicated, but QGIS lets you do this easily.

• Select the SGADMIN field.

• Click Insert field:

This will tell QGIS to add the phrase next:

What this means is that QGIS is going to open the browser and send it to the
address http://www.google.co.za/search?q=[% "SGADMIN" %]. But [%
"SGADMIN" %] tells QGIS to use the contents of the SGADMIN field as the phrase to search
for. So if, for example, the farm you clicked on is in the Montagu area, then QGIS is going
to send the browser to http://www.google.co.za/search?q=Montagu, which will
cause the browser to visit Google, which will in turn search for the word “Montagu”.

• If you haven’t done so already, set everything up as explained above.

• Click the Add to action list button. The new action will appear in the list above.

• Click OK on the Layer Properties dialog.
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Now to test the new action!

• With the rural layer active in the Layers list, click on the Run feature action.

• Click on any farm you can see on the map. Your browser will now open, and will au-
tomatically start a Google search for the town that is recorded as that farm’s SGADMIN
value.

Note: If your action doesn’t work, check that everything was entered correctly; typos are
common with this kind of work!

6.4.6 Follow along: Open a Webpage Directly in QGIS

Above, you’ve seen how to open a webpage in an external browser. There are some shortcom-
ings with this approach in that it adds an unknowable dependency – will the end-user have the
software required to execute the action on their system? As you’ve seen, they don’t necessarily
even have the same kind of base command for the same kind of action, if you don’t know which
OS they’ll be using. With some OS versions, the above commands to open the browser might
not work at all. It looks like quite the insurmountable problem.

However, QGIS sits on top of the incredibly powerful and versatile Qt4 library. All that good-
ness is just a heartbeat away with a Python line or two. Also, QGIS actions can be arbitrary,
tokenized (i.e. using variable information based on the contents of a field attribute) Python
commands!

Now you’ll see how to use a python action to show a web page. It’s the same general idea as
opening a site in an external browser, but it requires no browser on the user’s system since it
uses the Qt4 QWebView class (which is a webkit based html widget) to display the content in
a pop up window.

Instead of Google, let’s use Wikipedia this time. So the URL you request will look like this:

http://wikipedia.org/wiki/SEARCH_PHRASE

To create the layer action:

• Open the Layer Properties dialog and head over to the Actions tab.

• Set up a new action using the following properties for the ac-
tion: * Type: Python * Name: Wikipedia * Action (all
on one line): from PyQt4.QtCore import QUrl; from
PyQt4.QtWebKit import QWebView; myWV = QWebView(None);
myWV.load(QUrl(’http://wikipedia.org/wiki/[% "SGADMIN"
%]’)); myWV.show()

There are a couple of things going on here:

• All the python code is in a single line with semi-colons separating commands (instead of
newlines, the usual way of separating Python commands).

• [% "SGADMIN" %] will be replaced by the actual attribute value when the action is
invoked (as before).
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• The code simply creates a new QWebView instance, sets its URL, and then calls
show() on it to make it visible as a window on the user’s desktop.

Note that this is a somewhat contrived example. Python works with semantically significant
indentation, so separating things with semicolons isn’t the best way to write it. So, in the real
world, you’d be more likely to import your logic from a Python module and then call a function
with a field attribute as parameter.

You could equally use the approach to display an image without requiring that the user has a
particular image viewer on their system.

6.4.7 In conclusion

Actions allow you to give your map extra functionality, useful to the end-user who views the
same map in QGIS. Due to the fact that you can use shell commands for any operating system,
as well as Python, the sky’s the limit in terms of the functions you could incorporate!

6.4.8 What’s next?

Now that you’ve done all kinds of vector data creation, you’ll learn how to analyze this data to
solve problems. That’s the topic of the next module.
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CHAPTER 7

Module: Vector Analysis

Now that you have edited a few features, you must want to know what else one can do with
them. Having features with attributes is nice, but when all is said and done, this doesn’t really
tell you anything that a normal, non-GIS map can’t.

The key advantage of a GIS is this: a GIS can answer questions.

For the next three modules, we’ll endeavor to answer a research question using GIS functions.
Suppose you are a property developer, and you want to build a new residential development.
You need to buy a farm to build it on. Your market research has given you the following criteria.
The farm must:

• be at least a certain area in size;

• be within the Swellendam town region;

• have a road running through it for easy access;

• be within a certain distance from a school;

• be on a flat surface for easy construction of new buildings; and

• stay out of the shadow of the mountains in winter.

Within the next few modules, we’ll harness the power of GIS analysis tools to locate suitable
farm properties for this new residential development.

7.1 Lesson: Reprojecting and Transforming Data

Let’s talk about Coordinate Reference Systems (CRSs) again. We’ve touched on this briefly
before, but haven’t discussed what it means practically.

The goal for this lesson: To reproject and transform vector datasets.
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7.1.1 Follow along: Projections

The CRS that all the data as well as the map itself are in right now is called WGS84. This
is a very common Geographic Coordinate System (GCS) for representing data. But there’s a
problem, as we will see.

• Save your current map.

• Then open the map of the world which you’ll find under
exercise_data/world/world.qgs.

• Zoom in to South Africa by using the Zoom In tool.

• Try setting a scale in the Scale field, which is in the Status Bar along the bottom of the
screen. While over South Africa, set this value to 1:5000000 (one to five million).

• Pan around the map while keeping an eye on the Scale field.

Notice the scale changing? That’s because you’re moving away from the one point that you
zoomed into at 1:5000000, which was at the center of your screen. All around that point, the
scale is different.

To understand why, think about a globe of the Earth. It has lines running along it from North
to South. These longitude lines are far apart at the equator, but they meet at the poles.

In a GCS, you’re working on this sphere, but your screen is flat. When you try to represent
the sphere on a flat surface, distortion occurs, similar to what would happen if you cut open a
tennis ball and tried to flatten it out. What this means on a map is that the longitude lines stay
equally far apart from each other, even at the poles (where they are supposed to meet). This
means that, as you travel away from the equator on your map, the scale of the objects that you
see gets larger and larger. What this means for us, practically, is that there is no constant scale
on our map!

To solve this, let’s use a Projected Coordinate System (PCS) instead. A PCS “projects” or
converts the data in a way that makes allowance for the scale change and corrects it. Therefore,
to keep the scale constant, we should reproject our data to use a PCS.

7.1.2 Follow along: “On the Fly” Reprojection

QGIS allows you to reproject data “on the fly”. What this means is that even if the data itself is
in another CRS, QGIS can project it as if it were in a CRS of your choice.

• To enable “on the fly” projection, click on the CRS Status button in the Status Bar along
the bottom of the QGIS window:

• In the dialog that appears, check the box next to Enable ‘on the fly’ CRS transformation.

• Type the word global into the Filter field. One CRS (NSIDC EASE-Grid Global) will
appear in the list below.
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• Click on it to select it, then click OK.

• Notice how the shape of South Africa changes. All projections work by changing the
apparent shapes of objects on Earth.

• Zoom in to a scale of 1:5000000 again, as before.

• Pan around the map.

• Notice how the scale stays the same!

“On the fly” reprojection is also used for combining datasets that are in different CRSs.

• Deactivate “on the fly” reprojection again:

– Click on the CRS Status button again.

– Uncheck the Enable ‘on the fly’ CRS transformation box.

– Clicking OK.

• Add another vector layer to your map which has the data for South Africa only. You’ll
find it as exercise_data/world/RSA.shp.

What do you notice?

The layer isn’t visible! But that’s easy to fix, right?

• Right-click on the layer in the Layers list.

• Select Zoom to Layer Extent.

OK, so now we see South Africa... but where is the rest of the world?

It turns out that we can zoom between these two layers, but we can’t ever see them at the
same time. That’s because their Coordinate Reference Systems are so different. The continents
dataset is in degrees, but the RSA dataset is in meters. So, let’s say that a given point in Cape
Town in the RSA dataset is about 4 100 000 meters away from the equator. But in the
continents dataset, that same point is about 33.9 degrees away from the equator.

This is the same distance - but QGIS doesn’t know that! You haven’t told it to reproject the
data. So as far as it’s concerned, the version of South Africa that we see in the RSA dataset
has Cape Town at the correct distance of 4 100 000 meters from the equator. But in the
continents dataset, Cape Town is only 33.9 meters away from the equator! You can see why
this is a problem.

QGIS doesn’t know where Cape Town is supposed to be - that’s what the data should be telling
it. If the data tells QGIS that Cape Town is 34 meters away from the equator and that South
Africa is only about 12 meters from north to south, then that is what QGIS will draw.

To correct this:

• Switch Enable ‘on the fly’ CRS transformation on again as before.

• Zoom to the extents of the RSA dataset.

Now, because they’re made to project in the same CRS, the two datasets fit perfectly:
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When combining data from different sources, it’s important to remember that they might not
be in the same CRS. “On the fly” reprojection helps you to display them together.

7.1.3 Follow along: Saving a Dataset to Another CRS

Remember when you calculated areas for the farms in the Classification lesson? You did it so
that you could classify the farms according to area.

• Open your usual map again (containing the Swellendam data).

• Open the attribute table for the rural layer.

• Scroll to the right until you see the AREA field.

Notice how the areas are all very small; basically zero. This is because these areas are given in
degrees - the data isn’t in a Projected Coordinate System. In order to calculate the area for the
farms in square meters, the data has to be in square meters as well. So, we’ll need to reproject
it.

But it won’t help to just use “on the fly” reprojection. “On the fly” does what it says - it doesn’t
change the data, it just reprojects the layers as they appear on the map. To truly reproject the
data itself, you need to export it to a new file using a new projection.

• Right-click on the rural layer in the Layers list.
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• Select Save As... in the menu that appears. You will be shown the Save vector layer as...
dialog.

• Click on the Browse button next to the Save as field.

• Navigate to exercise_data/ and specify the name of the new layer as
rural_reprojected.shp.

• Leave the Encoding unchanged.

• Change the value of the Layer CRS dropdown to Selected CRS.

• Click the Browse button beneath the dropdown.

• The CRS Selector dialog will now appear.

• In its Filter field, search for 33S.

• Choose WGS 84 / UTM zone 33S from the list.

• Click OK.

The Save vector layer as... dialog now looks like this:
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• Click OK and after an instant, you should be presented with:
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• Click OK.

• Start a new map:

Refer back to the lesson on Classification to remember how you calculated areas.

• Update the AREAS field by running the same expression as before:

This will update the AREAS field with the areas of the farms in square meters.

• To calculate the area in hectares, do this:
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Look at the new values in your attribute table. This is much more useful, as people actually
quote property areas in hectares, not in degrees. And projecting the data in an appropriate
projection before calculating the area will actually give you the area in hectares. This is why
it’s a good idea to reproject your data, if necessary, before calculating areas, distances, and
other values that are dependent on the spatial properties of the layer.

7.1.4 Follow along: Creating Your Own Projection

There are many more projections than just those included in QGIS by default. You can also
create your own projections.

• Start a new map.

• Load the world/oceans.shp dataset.

• Go to Settings → Custom CRS... and you’ll see this dialog:
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• Click on the button with the star icon to create a new projection. You’ll notice that the
name and parameters are now blank.

An interesting projection to use is called Van der Grinten I.

• Enter its name in the Name field.

This projection represents the Earth on a circular field instead of a rectangular one, as most
other projections do.

• For its parameters, use the following string:
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+proj=vandg +lon_0=0 +x_0=0 +y_0=0 +R_A +a=6371000 +b=6371000
+units=m +no_defs

• Click the Save button:

• Click OK.

• Enable “on the fly” reprojection.

• Choose your newly defined projection (search for its name in the Filter field).

• On applying this projection, the map will be reprojected thus:

7.1.5 In conclusion

Different projections are useful for different purposes. By choosing the correct projection, you
can ensure that the features on your map are being represented accurately.
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7.1.6 Further reading

Materials for the Advanced section of this lesson were taken from this article1.

Further information on Coordinate Reference Systems is available here2.

7.1.7 What’s next?

In the next lesson you’ll learn how to analyze vector data using QGIS’ various vector analysis
tools.

7.2 Lesson: Vector Analysis

Vector data can also be analyzed to reveal how different features interact with each other in
space. There are many different analysis-related functions in GIS, so we won’t go through
them all. Rather, we’ll pose a question and try to solve it using the tools that QGIS provides.

The goal for this lesson: To ask a question and solve it using analysis tools.

7.2.1 The GIS Process

Before we start, it would be useful to give a brief overview of a process that can be used to
solve any GIS problem. The way to go about it is:

1. State the Problem

2. Get the Data

3. Analyze the Problem

4. Present the Results

7.2.2 The problem

Let’s start off the process by deciding on a problem to solve. Let’s say you’re a property
developer, and you need to buy a farm to build a new residential development for people who
have had enough of Cape Town and Johannesburg. You’ve done some market research, and
you’ve come up with the following requirements that a farm needs to satisfy:

1. It needs to be in Swellendam.

2. You don’t want to have to build a long access road (maximum distance 500 meters), and
it has to be easily accessible from main routes.

1http://tinyurl.com/75b92np
2http://linfiniti.com/dla/worksheets/7_CRS.pdf

7.2. Lesson: Vector Analysis 169

http://tinyurl.com/75b92np
http://linfiniti.com/dla/worksheets/7_CRS.pdf


Quantum GIS Training Manual, Release 1.0

3. The people who make up the target market will probably have children, so it must be
within a reasonable distance (by car) from a school.

4. The farm must be between 100 and 150 hectares in area.

7.2.3 The data

To answer these questions, we’re going to need the following data:

1. The farms we’re going to be choosing from.

2. The roads that need to be running through these farms.

3. The location of schools.

For this exercise the data has been provided already, but in reality you may need to find a
provider for the datasets in question. In South Africa, the Surveyor-General’s Office is a good
source of the kind of data you’d find on 1: 50 000 topographic map sheets, which includes all
of the data we need for this particular problem.

7.2.4 Follow along: Start a Project

So now that we know what we want to do, let’s start doing it!

• Start a new QGIS project.

• Start adding new layers. They’re all to be found in the
exercise_data/projected_data folder.

• Add the schools_33S, roads_33S and farms_33S layers.

They’ll probably look very familiar. They’re the same data we’ve been working with all along,
except that they’re now in a Projected Coordinate System. This is necessary for analysis, for
reasons we’ve covered in the previous lesson. (We want to be able to calculate distances in
meters and areas in hectares, not in degrees.)

Once you’ve got these layers in your Layers list:

• Rename the layers by right-clicking on them and selecting the Rename option.

• Give them the new, less messy names roads, schools and farms.

• Save your map under exercise_data, as analysis.qgs.

• In your operating system’s file manager, create a new folder under exercise_data and call
it residential_development. This is where you’ll save the datasets that will be
the results of the analysis functions.

Now that we’ve got the data, let’s analyze the problem!
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7.2.5 Follow along: Analyzing the Problem: Farms in Swellen-
dam

The first criterion we’re facing is that the farm needs to be in Swellendam. So let’s tell QGIS
to only show us the farms that are, in fact, in Swellendam!

• Right-click on the farms layer in the Layers list.

• Select the option Query.... This gives you a new Query Builder dialog.

• Scroll down in the Fields list on the left of this dialog until you see the field TOWN.

• Click on it once.

• Click the All button underneath the Values list:

Now we need to tell QGIS to only show us the farms where the value of TOWN is equal to
Swellendam.

• Double-click the word TOWN in the Fields list.

• Watch what happens in the SQL where clause field below:
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The word "TOWN" has appeared! To build the rest of the query:

• Click the = button (under Operators).

• Double-click the value Swellendam in the Values list.

Your query is this:

And now your farms layer looks like this:
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For further analysis, it’s better if we’ve got these farms as a separate layer.

• Right-click on the farms layer and click Save As....

• Next to the Save as field in the dialog that appears, click the Browse button.

• Save the layer under exercise_data/residential_development/, as
swellendam_farms.shp.

• Check the Add saved file to map box in the Save vector layer as... dialog.

• Click OK. It will tell you that Export to vector file has been
completed.

• Click OK.

Now we’ve got the farms twice, but we only need the one we just created.

• Right-click on the old farms layer and remove it.

7.2.6 Try yourself... find important roads

We have a similar problem with the roads; the only roads we’re taking into account are the
main ones.

• Build a query for the roads layer, like you did above for the farms layer. You want only
the types primary, secondary, tertiary and trunk, so you need to build this
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query:

"TYPE" = ’primary’ OR "TYPE" = ’secondary’ OR "TYPE" =
’tertiary’ OR "TYPE" = ’trunk’

You can either use the approach above, where you double-clicked values and clicked buttons,
or you can copy and paste the command above.

Check your results

7.2.7 Try yourself... find high schools

Your future customers will want to send their children to high schools.

• Use the same approach as before and build this query for the schools layer:

"has_high_s" = ’y’

You should have only 3 out of the 4 original schools left.

• Save the resulting layer under exercise_data/residential_development/
as high_schools.shp.

7.2.8 Follow along: Analyzing the Problem: Distances From
Schools and Roads

QGIS allows you to calculate distances from any vector object.

• Make sure that only the important_roads and swellendam_farms layers are visible, to
simplify the map while you’re working.

• Click on the Vector → Geoprocessing Tools → Buffer(s) tool:

This gives you a new dialog.

• Set it up like this:
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The Buffer distance is in meters because our input dataset is in a Projected Coordinate System.
This is why we needed to use projected data!

• Save the resulting layer under exercise_data/residential_development/
as important_roads_buffer_500m.shp.

• Click OK and it will create the buffer.

• When it asks you if it should “add the new layer to the TOC”, click Yes. (“TOC” stands
for “Table of Contents”, by which it means the Layers list).

Now you’ve got this:
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OK, that looks interesting! Those are all the areas that are within 500 meters of an important
road.

But look closer: it looks like there are joins between different sections of road! That’s not nice.
Remove that layer and let’s try again:
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• Note that we’re now checking the Dissolve buffer results box.

• Save the output under the same name as before (click Yes when it asks your permission
to overwrite the old one).

• Click OK.

Once you’ve added the layer to the Layers list, it will look like this:
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That’s more like it! Now there are no unnecessary subdivisions.

7.2.9 Try yourself... distance from high schools

• Use the same approach as above and create a buffer for your schools.

It needs to be 10 km in radius, and saved under the usual directory as
high_schools_buffer_10km.shp.

Check your results

7.2.10 Follow along: Overlapping Areas

Now we have areas where the road in 500 meters away and there’s a school within 10 km (as
the crow flies). But obviously, we only want the areas where both of these criteria are satisfied
at once! To do that, we’ll need to use the Intersect tool. Find it under Vector → Geoprocessing
Tools → Intersect. Set it up like this:
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The two input layers are the two buffers; the save location is as usual; and the file name is
road_school_buffers_intersect.shp. Once it’s set up like this, click OK and add
the layer to the Layers list when prompted.

In the image below, the blue areas show us where both distance criteria are satisfied at once!
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You may remove the two buffer layers and only keep the one that shows where they overlap,
since that’s what we really wanted to know in the first place.

7.2.11 Follow along: Select the Farms

Now you’ve got the area that the farms must overlap. Next, you want to select the farms in that
area.

• Click on the menu entry Vector → Research Tools → Select by location. A dialog will
appear.

• Set it up like this:
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• Click OK and you’ll see the results:

The yellow farms are the selected ones. Let’s save them as a new layer.

• Right-click on the swellendam_farms layer in the Layers list.
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• Select Save Selection As....

• Set the dialog up like this:

• The file name is well_located_farms.shp.

• Click OK.

Now you have the selection as a separate layer.
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7.2.12 Follow along: Select Farms of the Right Size

To see which farms are the right area (between 100 and 150 ha), we first need to calculate their
areas in hectares.

• Open the attribute table for the well_located_farms layer.

• Enter edit mode:

• Start the field calculator:

• Set it up like this:

• If you can’t find AREA in the list, try this instead:
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• Click OK.

• Scroll to the right of the attribute table; your AREA field now has areas in hectares for all
the farms in your well_located_farms layer.

• Click the edit mode button again as above, and save your edits when prompted.

• Do a query:
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• Click OK. Your results should look like this:
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That’s it! Those red farms are the ones satisfying your criteria. Well done!

7.2.13 Try yourself...

• Save your solution as a new layer, using the approach you learned above for doing so.
The file should be saved under the usual directory, with the name solution.shp.

7.2.14 In conclusion

Using the GIS problem-solving approach together with QGIS vector analysis tools, you were
able to solve a problem with multiple criteria quickly and easily.

7.2.15 What’s next?

In the next lesson, we’ll look at how to calculate the shortest distance along the road from one
point to another.
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7.3 Lesson: Network Analysis

Calculating the shortest distance between two points is a commonly cited use for GIS. QGIS
ships with this tool, but it’s not visible by default. In this brief lesson, we’ll show you what you
need to get started.

The goal for this lesson: To activate, configure and use the Road Graph plugin.

7.3.1 Follow along: Activate the Tool

QGIS has many plugins that add to its basic functions. Many of these plugins are so useful
that they ship along with the program straight out of the box. They’re still hidden by default,
though. So in order to use them, you need to activate them first.

To activate the Road Graph plugin:

• Start the Plugin Manager by clicking on the QGIS main window’s menu item Plugins →
Manage Plugins. A dialog appears.

• Select the plugin like this:

• Click OK on the Plugin Manager dialog.

• To see the plugin in your interface, go to View → Panels and ensure that Shortest path
has a check mark next to it.

This panel will appear in your interface:
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7.3.2 Follow along: Configure the Tool

To have a layer to calculate on, first save your current map. Then create a new map and load
the layer exercise_data/projected_data/roads_33S.shp.

Since so many different configurations are possible when analyzing networks, the plugin
doesn’t assume anything before you’ve set it up. Unfortunately, this means that it won’t do
anything at all if you don’t set it up first.

• Click on the menu item Plugins → Road graph → Road graph settings. A dialog will
appear.

• Make sure it’s set up like this (use defaults unless otherwise specified):
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• Time unit: hour

• Distance unit: kilometer

• Layer: roads_33S

• Speed field: Always use default / km/h
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• Direction: Two-way direction

• Speed: 60

7.3.3 Follow along: Use the Tool

Let’s say you want to get from Barrydale to Bonnievale:
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• In the plugin panel, click on the Capture Point button next to the Start field:

• Click somewhere in Barrydale.

• Use the Capture Point button next to the Stop field and capture a point somewhere in
Bonnievale.

• Click on the Calculate button to see the solution:
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7.3.4 Follow along: Using Criteria

Note: Section developed by Linfiniti and S Motala (Cape Peninsula University of Technology)

• Add the layer exercise_data/projected_data/places_33S.shp.
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• Add the aerial photographs under exercise_data/raster/.

• Zoom to the Swellendam area (the town / cluster of roads in the center of the map).

• Select only the roads that are in the categories trunk, primary or tertiary by
running this attribute selection query on the road layer:

"TYPE" = ’trunk’ OR "TYPE" = ’primary’ OR "TYPE" = ’tertiary’

• Right-click on the roads_33S layer in the Layers list.

• Save it out to a new file, roads_subset. Only the currently visible features will be
saved.

• Remove the original roads_33S layer from the Layers list.

• Open the attribute table for the roads_subset layer and enter edit mode:

• Add a new column:

• Call this new column SPEED, and give it the type Whole number (integer) with a width
of 3.

• In the main window, activate the Select Features by Rectangle tool:

• Select these roads:

7.3. Lesson: Network Analysis 193



Quantum GIS Training Manual, Release 1.0

(To select more than one road, hold the ctrl button and drag a box across any road that you
want to include in the selection.)

• In the attribute table, click on the Show selected only box.

• Set the SPEED value for all the selected streets to 60:

In context, this means that you’re setting the speed limit on those roads to 60 km/h.

• Select the highway outside of town:
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• Set the SPEED value for all the selected streets to 120.

• Close the attribute table, save your edits, and exit edit mode.

• Check the Vector → Road graph → Road graph settings to ensure that it’s set up as
explained previously in this lesson, but with the Speed value set to the SPEED field you
just created.

• In the Shortest path panel, click the Start point button.

• Set the starting point to where the dirt road meets the on/off-rqamp at the edge of town
on the east.

• Set the end point to the T-junction west of town.
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• In the Criterion drop-down list in the Shortest path panel, select Length.

• Click Calculate. The route will be calculated for the shortest distance:
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Notice the values of Length and Time in the Shortest path panel.

• Set the Criterion to Time.

• Click Calculate again. The route will be calculated for the shortest time:
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You can switch back and forth between these criteria, recalculating each time, and note the
changes in the Length and Time taken. Remember that the assumption being made to arrive at
the time taken to travel a route does not account for acceleration, and assumes that you will
be traveling at the speed limit at all times. In a real situation, you may want to split roads into
smaller sections and note the average or expected speed in each section, rather than the speed
limit.

7.3.5 Try yourself...

• Digitize the roads in Railton.

These are the main roads, type tertiary, speed 60:
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And these are the smaller streets, type residential, speed 40:

7.3. Lesson: Network Analysis 199



Quantum GIS Training Manual, Release 1.0

• Use the Shortest path tool to calculate the shortest and fastest ways to get from the south-
ern extreme of town to the highway.

If, on clicking Calculate, you’re getting an error stating that a path could not be found, then
make sure that the roads you digitized actually meet each other. If they’re not quite touching,
either fix them by modifying the features, or set the Topology tolerance (Road graph plugin
settings). If they’re passing over each other without intersecting, use the Split features tool to
“split” roads at their intersections:
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Remember that the Split features tool only works in edit mode on selected features, though!

7.3.6 In conclusion

Now you know how to use the Road Graph plugin to solve shortest-path problems.

7.3.7 What’s next?

Next you’ll see how to run spatial statistics algorithms on vector datasets.

7.4 Lesson: Spatial Statistics

Note: Lesson developed by Linfiniti and S Motala (Cape Peninsula University of Technology)

Spatial statistics allow you to analyze and understand what is going on in a given vector dataset.
QGIS includes several standard tools for statistical analysis which prove useful in this regard.

The goal for this lesson: To know how to use QGIS’ spatial statistics tools.

7.4.1 Follow along: Create a Test Dataset

In order to get a point dataset to work with, we’ll need a point dataset. In order to mimic a real
dataset, let’s create a random set of points.

To do so, you’ll need a polygon dataset defining the extents of the area you want to create the
points in.

We’ll use the area covered by streets.

• Create a new empty map.

• Add the roads_33S layer from the exercise_data/projected_data
directory, as well as the srtm_41_19.tif raster found in
exercise_data/raster/SRTM/.

• Use the Convex hull(s) tool (available under Vector → Geoprocessing Tools) to generate
an area enclosing all the roads:
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• Save the output under exercise_data/spatial_statistics/ as
roads_hull.shp.

• Add it to the TOC (Layers list) when prompted.

Creating random points

• Create random points in this area using the tool at Vector → Research Tools → Random
points:
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• Save the output under exercise_data/spatial_statistics/ as
random_points.shp.

• Add it to the TOC (Layers list) when prompted:
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Sampling the data

• To create a sample dataset from the raster, you’ll need to use the Point sampling tool
plugin.

• Refer ahead to the module on plugins if necessary.

• Search for the phrase point sampling in the Plugin Installer and you will find the
plugin.

• Note that it is in a third-party repository at time of writing, so you’ll need to have third-
party repositories enabled.

• As soon as it has been activated with the Plugin Manager, you will find the tool under
Plugins → Analyses → Point sampling tool:
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• Select random_points as the layer containing sampling points, and the SRTM raster as
the band to get values from.

• Save the output under exercise_data/spatial_statistics/ as
random_samples.shp.

• Add it to the TOC (Layers list) when prompted.

A possible sample layer is shown here:

7.4. Lesson: Spatial Statistics 205



Quantum GIS Training Manual, Release 1.0

The sample points are classified by their value such that darker points are at a lower altitude.

You’ll be using this sample layer for the rest of the statistical exercises.

7.4.2 Follow along: Basic Statistics

Now get the basic statistics for this layer.

• Click on the Vector → Analysis Tools → Basic statistics menu entry.

• In the dialog that appears, specify the random_samples layer as the source.

• Click OK. You’ll get results like this:
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Note: You can copy and paste the results into a spreadsheet. The data uses a (colon :)
separator.
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• Close the plugin dialog when done.

To understand the statistics above, refer to this definition list:

Mean The mean (average) value is simply the sum of the values divided by the amount of
values.

StdDev The standard deviation. Gives an indication of how closely the values are clustered
around the mean. The smaller the standard deviation, the closer values tend to be to the
mean.

Sum All the values added together.

Min The minimum value.

Max The maximum value.

N The amount of samples/values.

CV The spatial3 covariance4 of the dataset.

Number of unique values The number of values that are unique across this dataset. If there
are 90 unique values in a dataset with N=100, then the 10 remaining values are the same
as one or more of each other.

Range The difference between the minimum and maximum values.

Median If you arrange all the values from least to greatest, the middle value (or the average of
the two middle values, if N is an even number) is the median of the values.

7.4.3 Follow along: Compute a Distance Matrix

• Create a new point layer in the same projection as the other datasets (WGS 84 / UTM
33S).

• Enter edit mode and digitize three point somewhere among the other points.

3http://en.wikipedia.org/wiki/Spatial_covariance
4http://en.wikipedia.org/wiki/Covariance
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• Alternatively, use the same random point generation method as before, but specify only
three points.

• Save your new layer as distance_points.shp.

In order to compare layers using statistical tools, a layer needs to have a unique ID field. Let’s
create one for your random_samples layer.

• Open the attribute table for this layer.

• Enter edit mode.

• Open the raster calculator.

• Create a new field called id, with an integer field type and a width of 3.

• Look in the Function list under the category Record, and double-click on the item $id, so
that it appears in the Expression field below.

• Click OK to generate a unique ID for this layer.

To generate a distance matrix using these points:

• Open the tool Vector → Analysis Tools → Distance matrix.

• Select the distance_points layer as the input layer, and the random_samples layer as the
target layer.

• Set it up like this:
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• Click OK to generate the distance matrix.

• Open it in a spreadsheet program to see the results. Here is an example:
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7.4.4 Follow along: Nearest Neighbor Analysis

To do a nearest neighbor analysis:

• Click on the menu item Vector → Analysis Tools → Nearest neighbor analysis.

• In the dialog that appears, select the random_samples layer and click OK.

• The results will appear in the dialog’s text window, for example:

Note: You can copy and paste the results into a spreadsheet. The data uses a (colon :)
separator.

7.4.5 Follow along: Mean Coordinates

To get the mean coordinates of a dataset:

• Click on the Vector → Analysis Tools → Mean coordinate(s) menu item.

• In the dialog that appears, specify random_samples as the input layer, but leave the op-
tional choices unchanged.

• Specify the output layer as mean_coords.shp.

• Click OK.

• Add the layer to the Layers list when prompted.

Let’s compare this to the central coordinate of the polygon that was used to create the random
sample.

• Click on the Vector → Geometry Tools → Polygon centroids menu item.

• In the dialog that appears, select roads_hull as the input layer.

• Save the result as center_point.

• Add it to the Layers list when prompted.

As you can see from the example below, the mean coordinates and the center of the study area
(in orange) don’t necessarily coincide:
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7.4.6 Follow along: Image Histograms

The histogram of a dataset shows the distribution of its values. The simplest way to demonstrate
this in QGIS is via the image histogram, available in the Layer Properties dialog of any image
layer.

• In your Layers list, right-click on the SRTM DEM layer.

• Select Layer Properties.

• Choose the tab Histogram. You will see a graph describing the frequency of values in the
image.

• You can export it as an image:
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• Look at the metadata for this layer (under the Metadata tab).

The mean value is 332.8, and the maximum value is 1699! But those values don’t show up
on the histogram. Why not? It’s because there are so few of them, compared to the abundance
of pixels with values below the mean. That’s also why the histogram extends so far to the right,
even though there is no visible red line marking the frequency of values higher than about 250.

Therefore, keep in mind that a histogram shows you the distribution of values, and not all values
are necessarily visible on the graph.

• (You may now close Layer Properties.)

7.4.7 Follow along: Spatial Interpolation

Let’s say you have a collection of sample points from which you would like to extrapolate data.
For example, you might have access to the random_samples dataset we created earlier, and

7.4. Lesson: Spatial Statistics 213



Quantum GIS Training Manual, Release 1.0

would like to have some idea of what the terrain looks like.

To start, launch the Grid (Interpolation) tool by clicking on the Raster → Analysis → Grid
(Interpolation) menu item.

• In the Input file field, select random_samples.

• Check the Z Field box, and select the value field (not the id field).

• Set the Output file location to exercise_data/spatial_statistics/interpolation.tif.

• Check the Algorithm box and select Inverse distance to a power.

• Set the Power to 5.0 and the Smoothing to 2.0. Leave the other values as-is.

• Check the Load into canvas when finished box and click OK.

• When it’s done, click OK on the dialog that says Process completed, click OK on
the dialog showing feedback information (if it has appeared), and click Close on the Grid
(Interpolation) dialog.

Here’s a comparison of the original dataset (left) to the one constructed from our sample points
(right). Yours may look different due to the random nature of the location of the sample points.

As you can see, 100 sample points aren’t really enough to get a detailed impression of the
terrain. It gives a very general idea, but it can be misleading as well. For example, in the image
above, it is not clear that there is a high, unbroken mountain running from east to west; rather,
the image seems to show a valley, with high peaks to the west. Just using visual inspection, we
can see that the sample dataset is not representative of the terrain.

7.4.8 Try yourself...

• Use the processes shown above to create a new set of 1000 random points.

• Use these points to sample the original DEM.

• Use the Spatial Interpolation tool on this new dataset as above.

• Set the output filename to interpolation_1000.tif, with Power and Smoothing
set to 5.0 and 2.0, respectively.
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The results (depending on the positioning of your random points) will look more or less like
this:

The border shows the roads_hull layer (which represents the boundary of the random sample
points) to explain the sudden lack of detail beyond its edges. This is a much better representa-
tion of the terrain, due to the much greater density of sample points.

Here is an example of what it looks like with 10 000 sample points:

Note: It’s not recommended that you try doing this with 10 000 sample points if you are not
working on a fast computer, as the size of the sample dataset requires a lot of processing time.
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7.4.9 Follow along: Installing SEXTANTE

The SEXTANTE plugin allows you to access various plugin tools from within a single in-
terface. It is standard in QGIS starting with version 1.8. If you’re unsure whether you have
SEXTANTE, check if it’s marked as installed in your Plugin Installer.

Assuming you have it installed (and enabled in the Plugin Manager):

• Activate SEXTANTE by enabling the View → Panels → SEXTANTE Toolbox menu entry.
The toolbox looks like this:

You will probably see it docked in QGIS to the right of the map. Note that the tools listed here
are links to the actual tools. SEXTANTE doesn’t have many tools of its own. To have access
to spatial statistics tools, you will need to install the SAGA GIS program.

7.4.10 Follow along: Installing SAGA

SAGA is a GIS program with many useful analysis functions. To make use of these functions
in QGIS via SEXTANTE, you need to install SAGA first.
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On Windows

Included in your course materials you will find the SAGA installer for Windows.

• Start the program and follow its instructions to install SAGA on your Windows system.
Take note of the path you are installing it under!

Once you have installed SAGA, you’ll need to configure SEXTANTE to find the path it was
installed under.

• Click on the menu entry Analysis → SAGA options and configuration.

• In the dialog that appears, expand the SAGA item and look for SAGA folder. Its value
will be blank.

• In this space, insert the path where you installed SAGA.

On Ubuntu

• Search for SAGA GIS in the Software Center, or enter the phrase sudo apt-get
install saga-gis in your terminal. (You may first need to add a SAGA reposi-
tory to your sources.)

• QGIS will find SAGA automatically, although you may need to restart QGIS if it doesn’t
work straight away.

After installing

Now that you have installed and configured SAGA, its functions will become accessible to you.

7.4.11 Follow along: Spatial Point Pattern Analysis

For a simple indication of the spatial distribution of points in the random_samples dataset, we
can make use of SAGA’s Spatial Point Pattern Analysis tool.

• In the SEXTANTE Toolbox, find this tool under SAGA → Geostatistics → Spatial Point
Pattern Analysis.

• Double-click on it to open its dialog.

• It produces three outputs, and so will require three output paths.

• Save these three outputs under exercise_data/spatial_statistics/, using
whatever file names you find appropriate.
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The output will look like this (the symbology was changed for this example):
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The red dot is the mean center; the large circle is the standard distance, which gives an indica-
tion of how closely the points are distributed around the mean center; and the rectangle is the
bounding box, describing the smallest possible rectangle which will still enclose all the points.

7.4.12 Follow along: Minimum Distance Analysis

Often, the output of an algorithm will not be a shapefile, but rather a table summarizing the
statistical properties of a dataset. One of these is the Minimum Distance Analysis tool.

• Find this tool in the SEXTANTE Toolbox as SAGA → Geostatistics → Minimum Distance
Analysis.

It does not require any other input besides specifying the vector point dataset to be analyzed.

• Choose the random_points dataset.

• Click OK. On completion, a DBF table will appear in the Layers list.

• Select it, then open its attribute table. Although the figures may vary, your results will be
in this format:
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7.4.13 In conclusion

QGIS allows many possibilities for analyzing the spatial statistical properties of datasets.

7.4.14 What’s next?

Now that we’ve covered vector analysis, why not see what can be done with rasters? That’s
what we’ll do in the next module!
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Module: Rasters

We’ve used rasters for digitizing before, but raster data can also be used directly. In this module,
you’ll see how it’s done in QGIS.

8.1 Lesson: Working with Raster Data

Raster data is quite different from vector data. Vector data has discrete features constructed out
of vertices, and perhaps connected with lines and/or areas. Raster data, however, is like any
image. Although it may portray various properties of objects in the real world, these objects
don’t exist as separate objects; rather, they are represented using pixels of various different
color values.

During this module you’re going to use raster data to supplement your existing GIS analysis.

The goal for this lesson: To learn how to work with raster data in the QGIS environment.

8.1.1 Follow along: Loading Raster Data

• Open your analysis.qgs map.

• Deactivate all the layers except the solution and important_roads layers.

• Click on the Load Raster Layer button:

The Load Raster Layer dialog will open. The data for this project is in
exercise_data/rasters.

• Either load them all in separately, or hold down ctrl and click on all four of them in
turn, then open them at the same time.

The first thing you’ll notice is that nothing seems to be happening in your map. Are the rasters
not loading? Well, there they are in the Layers list, so obviously they did load. The problem is
that they’re not in the same projection. Luckily, we’ve already seen what to do in this situation.
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• Click on the CRS Status button:

• Enable “on the fly” reprojection.

• Set it to the same projection as the rest of your data (WGS 84 / UTM zone 33S).

• Click OK.

The rasters should fit nicely:

There we have it - four aerial photographs covering our whole study area.

8.1.2 Follow along: Create a Virtual Raster

Now as you can see from this, your solution layer lies across all four photographs. What this
means is that you’re going to have to work with four rasters all the time. That’s not ideal; it
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would be better to have one file for one (composite) image, right?

Luckily, QGIS allows you to do exactly this, and without needing to actually create a new raster
file, which could take up a lot of space. Instead, you can create a Virtual Raster. This is also
often called a Catalog, which explains its function. It’s not really a new raster. Rather, it’s a
way to organize your existing rasters into one catalog: one file for easy access.

To make a catalog:

• Click on the menu item Raster → Miscellaneous → Build Virtual Raster (Catalog).

• In the dialog that appears, check the box next to Use visible raster layers for input.

• Anter exercise_data/residential_development as the output location.

• Enter aerial_photos.vrt as the file name.

• Check the Load into canvas when finished button.

Notice the text field below. What this dialog is actually doing is that it’s writing that text for
you. It’s a long command that QGIS is going to run.

Note: Keep in mind that the command text is editable, so you can customize
the command further if preferred. Search online for the initial command (in this case,
gdalbuildvrt) for help on the syntax.

• Click OK to run the command.

It may take a while to complete. When it’s done, it will tell you so with a message box.

• Click OK to chase the message away.

• Click Close on the Build Virtual Raster (Catalog) dialog. (Don’t click OK again, other-
wise it’s going to start running that command again!)

• You can now remove the original four rasters from the Layers list.

• If necessary, click and drag the new aerial_photos raster catalog layer to the bottom of
the Layers list so that the other activated layers become visible.

8.1.3 Transforming Raster Data

The above methods allow you to virtually merge datasets using a catalog, and to reproject them
“on the fly”. However, if you are setting up data that you’ll be using for quite a while, it may
be more efficient to create new rasters that are already merged and reprojected. This improves
performance while using the rasters in a map, but it may take some time to set up initially.

Reprojecting rasters

• Click on the menu item Raster → Projection → Warp (Reproject).
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Note that this tool features a handy batch option for reprojecting the contents of whole direc-
tories. You can also reproject virtual rasters (catalogs), as well as enabling a multithreaded
processing mode.

Merging rasters

• Click on the menu item Raster → Miscellaneous → Merge.

You can choose to process entire directories instead of single files, giving you a very useful
built-in batch processing capability. You can specify a virtual raster as input file, too, and all of
the rasters that it consists of will be processed.

You can also add your own command line options using the Creation Options checkbox and
list. This only applies if you have knowledge of the GDAL library’s operation.

8.1.4 In conclusion

QGIS makes it easy to include raster data into your existing projects.

8.1.5 What’s next?

Next, we’ll use raster data that isn’t aerial imagery, and see how symbolization is useful in the
case of rasters as well!

8.2 Lesson: Changing Raster Symbology

Not all raster data consists of aerial photographs. There are many other forms of raster data,
and in many of those cases, it’s essential to symbolize the data properly so that it becomes
properly visible and useful.

The goal for this lesson: To change the symbology for a raster layer.

8.2.1 Try yourself...

• Use the Add Raster Layer button to load the new raster dataset.

• Into your current map (which, following from the previous lesson, should be
analysis.qgs) load the dataset srtm_41_19.tif, found under the directory
exercise_data/raster/SRTM/.

• Once it appears in the Layers list, rename it to DEM.

This dataset is a Digital Elevation Model (DEM). It’s a map of the elevation (altitude) of the
terrain, allowing us to see where the mountains and valleys are, for example.
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Once it’s loaded, you’ll notice that it’s basically a gray rectangle. It’s seen here with the vector
layers on top:

That’s because its symbology hasn’t been customized. In a color aerial photograph, everything
is already defined. But if you load a raster and it’s just a gray rectangle, then you know there’s
no symbology for it yet. It still needs to be defined. So that’s what you should do next.

8.2.2 Follow along: Changing Raster Layer Symbology

• Open the Layer Properties dialog for the SRTM layer.

• Switch to the Style tab.

These are the current settings, and as we’ve seen, they don’t give us much information on the
layer. Does it even have any data in it? Let’s see.

• Change the Color map to Pseudocolor:
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• Click OK.

You’ll see the raster looking like this:

That does tell us what we need to know. There is data in this layer. But maybe we don’t want
to symbolize it using these colors.

• Open Layer Properties again.

• Switch the Color map back to Grayscale.
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But this time, to prevent it from becoming a gray rectangle again, let’s tell QGIS to “stretch”
the color values. This will make QGIS use all of the available colors (in Grayscale, this is
black, white and all shades of gray in between).

• Tell it to use Custom min / max values:

• Set the value Current of Contrast enhancement to Stretch To MinMax:

But what are the minimum and maximum values that should be used for the stretch? The
ones that are currently under Custom min / max values are the same values that just gave us a
gray rectangle before. Instead, we should be using the minimum and maximum values that are
actually in the image, right? Fortunately, you can determine those values easily by loading the
minimum and maximum values of the raster.

• Under Load min / max values from band, select Estimate (faster).

• Click the Load button:

Notice how the Custom min / max values have changed:

• Click OK.

You’ll see the values of the raster properly displayed, with the darker colors representing valleys
and the lighter ones, mountains:
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But isn’t there a quicker way?

Yes, there is! Now that you understand what needs to be done, you’ll be glad to know that
there’s a tool for doing all of this easily.

• Remove the current DEM from the Layers list.

• Load the raster in again, renaming it to DEM as before. It’s a gray rectangle again...

• Enable the tool you’ll need by enabling View → Toolbars → Raster. These icons will
appear in the interface:

The button on the right will stretch the minimum and maximum values to give you the best
contrast in the local area that you’re zoomed into. It’s useful for large datasets. The button
on the left will stretch the minimum and maximum values to constant values across the whole
image.

• Click the button on the left (Stretch Histogram to Full Dataset). You’ll see the data is
now correctly represented as before!
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8.2.3 In conclusion

These are only the basic functions to get you started with raster symbology. QGIS also allows
you many other options, such as symbolizing a layer using standard deviations, or representing
different bands with different colors in a multispectral image.

8.2.4 Reference

The SRTM dataset was obtained from http://srtm.csi.cgiar.org/

8.2.5 What’s next?

Now that we can see our data displayed properly, let’s investigate how we can analyze it further.

8.3 Lesson: Terrain Analysis

Certain types of rasters allow you to gain more insight into the terrain that they represent.
Digital Elevation Models (DEMs) are particularly useful in this regard. In this lesson you will
use terrain analysis tools to find out more about the study area for the proposed residential
development from earlier.

The goal for this lesson: To use terrain analysis tools for more information on terrain.

8.3.1 Follow along: Calculating a Hillshade

The DEM you have on your map right now does show you the elevation of the terrain, but it
can sometimes seem a little abstract. It contains all the 3D information about the terrain that
you need, but it doesn’t look like a 3D object. To get a better look at the terrain, it is possible
to calculate a hillshade, which is a raster that maps the terrain using light and shadow to create
a 3D-looking image.

To work with DEMs, you should use QGIS’ all-in-one DEM (Terrain models) analysis tool.

• Click on the menu item Raster → Analysis → DEM (Terrain models).

• In the dialog that appears, ensure that the Input file is the DEM layer.

• Set the Output file to hillshade.tif in the directory
exercise_data/residential_development.

• Check the box next to Load into canvas when finished.

• You may leave all the other options unchanged.

• Click OK to generate the hillshade.

• When it tells you that processing is completed, click OK on the message to get rid of it.
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• Click Close on the main DEM (Terrain models) dialog.

You will now have a new layer called hillshade that looks like this:

That looks nice and 3D, but can we improve on this? On its own, the hillshade looks like a
plaster cast. Can’t we use it together with our other, more colorful rasters somehow? Of course
we can, by using the hillshade as an overlay.

8.3.2 Follow along: Using a Hillshade as an Overlay

A hillshade can provide very useful information about the sunlight at a given time of day. But
it can also be used for aesthetic purposes, to make the map look better. The key to this is setting
the hillshade to being mostly transparent.

• Change the symbology of the original DEM to use the Pseudocolor scheme.

• Hide all the layers except the DEM and hillshade layers.

• Click and drag the DEM to be beneath the hillshade layer in the Layers list. Control
rendering order (beneath the list) should be checked as well.

• Set the hillshade layer to be transparent.

• Open its Layer Properties and go to the Transparency tab.
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• Set the Global transparency to 50%:

• Click OK on the Layer Properties dialog. You’ll get a result like this:

• Switch the hillshade layer off and back on in the Layers list to see the difference it makes.

Using a hillshade in this way, it’s possible to enhance the topography of the landscape. If the
effect doesn’t seem strong enough to you, you can change the transparency of the hillshade
layer; but of course, the brighter the hillshade becomes, the dimmer the colors behind it will
be. You will need to find a balance that works for you.

Remember to save your map when you are done.

Note: For the next two exercises, please use a new map. Load only the DEM raster
dataset into it (exercise_data/raster/SRTM/srtm_41_19.tif). This is to sim-
plify matters while you’re working with the raster analysis tools. Save the map as
exercise_data/raster_analysis.qgs.

8.3.3 Follow along: Calculating the Slope

Another useful thing to know about the terrain is how steep it is. If, as in our analysis, you want
to build houses on the land there, then you need land that is relatively flat.

To do this, you need to use the Slope mode of the DEM (Terain models) tool.

• Open the tool as before.
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• Select the Mode option Slope:

• Set the save location to exercise_data/residential_development/slope.tif

• Enable the Load into canvas... checkbox.

• Click OK and close the dialog when processing is complete. You’ll see a new raster
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loaded into your map.

• With the new raster selected in the Layers list, click the Stretch Histogram to Full Dataset
button. Now you’ll see the slope of the terrain, with black pixels being flat terrain and
white pixels, steep terrain:

8.3.4 Try yourself... calculating the aspect

The aspect of terrain refers to the direction it’s facing in. Since this study is taking place in the
Southern Hemisphere, properties should ideally be built on a north-facing slope so that they
can remain in the sunlight.

• Use the Aspect mode of the DEM (Terain models) tool to calculate the aspect of the
terrain.

Check your results

8.3.5 Follow along: Using the Raster Calculator

Think back to the residential property development problem, which we last addressed in the
Vector Analysis lesson. So far, you’ve identified several farms that would be suitable, but
without taking the terrain into account. Let’s say that an ideal farm for development needs to
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have areas on it that are north-facing, and with a slope of less than five degrees. But if the slope
is less than 2 degrees, then the aspect doesn’t matter.

Fortunately, you already have rasters showing you the slope as well as the aspect, but you have
no way of knowing where both conditions are satisfied at once. How could this analysis be
done?

The answer lies with the Raster calculator.

• Click on Raster > Raster calculator... to start this tool.

• To make use of the aspect dataset, double-click on the item aspect@1 in the Raster bands
list on the left. It will appear in the Raster calculator expression text field below.

North is at 0 (zero) degrees, so for the terrain to face north, its aspect needs to be greater than
270 degrees and less than 90 degrees.

• In the Raster calculator expression field, enter this expression:

aspect@1 <= 90 OR aspect@1 >= 270

• Set the output file to aspect_north.tif in the directory
exercise_data/residential_development/.

• Ensure that the box Add result to project is checked.

• Click OK to begin processing.

Your result will be this:
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8.3.6 Try yourself...

Now that you’ve done the aspect, create two separate new analyses of the DEM layer.

• The first will be to identify all areas where the slope is less than or equal to 2 degrees.

• The second is similar, but the slope should be less than or equal to 5 degrees.

• Save them under exercise_data/residential_development/ as
slope_lte2.tif and slope_lte5.tif.

Check your results

8.3.7 Follow along: Combining Raster Analysis Results

Now you have three new analysis rasters of the DEM layer:

• aspect_north: the terrain faces north

• slope_lte2: the slope is at or below 2 degrees

• slope_lte5: the slope is at or below 5 degrees
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Where the conditions of these layers are met, they are equal to 1. Elsewhere, they are equal to
0. Therefore, if you multiply one of these rasters by another one, you will get the areas where
both of them are equal to 1.

The conditions to be met are: at or below 5 degrees of slope, the terrain must face north; but at
or below 2 degrees of slope, the direction that the terrain faces in does not matter.

Therefore, you need to find areas where the slope is at or below 5 degrees AND the terrain
is facing north; OR the slope is at or below 2 degrees. Such terrain would be suitable for
development.

To calculate the areas that satisfy these criteria:

• Open your Raster calculator again.

• Use the Raster bands list, the Operators buttons, and your keyboard to build this expres-
sion in the Raster calculator expression text area:

( aspect_north@1 = 1 AND slope_lte5@1 = 1 ) OR
slope_lte2@1 = 1

• Save the output under exercise_data/residential_development/ as
all_conditions.tif.

• Click OK on the Raster calculator. Your results:
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8.3.8 Follow along: Simplifying the Raster

As you can see from the image above, the combined analysis has left us with many, very small
areas where the conditions are met. But these aren’t really useful for our analysis, since they’re
too small to build anything on. Let’s get rid of all these tiny unusable areas.

• Open the Sieve tool (Raster → Analysis → Sieve).

• Set the Input file to all_conditions, and the Out-
put file to all_conditions_sieve.tif (under
exercise_data/residential_development/).

• Set both the Threshold and Pixel connections values to 8, then run the tool.

Once processing is done, the new layer will load into the canvas. But when you try to use the
histogram stretch tool to view the data, this happens:

What’s going on? The answer lies in the new raster file’s metadata.

• View the metadata under the Metadata tab of the Layer Properties dialog.

Whereas this raster, like the one it’s derived from, should only feature the values 1 and 0, it has
the STATISTICS_MINIMUM value of a very large negative number. Investigation of the data
shows that this number acts as a null value. Since we’re only after areas that weren’t filtered
out, let’s set these null values to zero.

• Open the Raster Calculator again, and build this expression:

(all_conditions_sieve@1 <= 0) = 0
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This will maintain all existing zero values, while also setting the negative numbers to
zero; which will leave all the areas with value 1 intact.

• Save the output under exercise_data/residential_development/ as
all_conditions_simple.tif.

Your output looks like this:

This is what was expected: a simplified version of the earlier results. Remember that if the re-
sults you get from a tool aren’t what you expected, viewing the metadata (and vector attributes,
if applicable) can prove essential to solving the problem.

8.3.9 In conclusion

You’ve seen how to derive all kinds of analysis products from a DEM. These include hillshade,
slope and aspect calculations. You’ve also seen how to use the raster calculator to further
analyze and combine these results.

8.3.10 What’s next?

Now you have two analyses: the vector analysis which shows you the potentially suitable
farms, and the raster analysis that shows you the potentially suitable terrain. How can these
be combined to arrive at a final result for this problem? That’s the topic for the next lesson,
starting in the next module.
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Module: Completing the Analysis

You now have two halves of an analysis: a vector and a raster part. In this module, you’ll see
how to combine them. You will conclude the analysis and present the final results.

9.1 Lesson: Raster to Vector Conversion

Converting between raster and vector formats allows you to make use of both raster and vector
data when solving a GIS problem, as well as using the various analysis methods unique to these
two forms of geographic data. This increases the flexibility you have when considering data
sources and processing methods for solving a GIS problem.

To combine a raster and vector analysis, you need to convert the one type of data to the other.
Let’s convert the raster result of the previous lesson to a vector.

The goal for this lesson: To get the raster result into a vector that can be used to complete the
analysis.

9.1.1 Follow along: The Raster to Vector Tool

• Click on Raster → Conversion → Polygonize (Raster to Vector). The tool dialog will
appear.

• Set it up like this:
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• Change the field name (describing the values of the raster) to suitable.

• Save the shapefile under exercise_data/residential_development as
all_terrain.shp.

Now you have a vector file which contains all the values of the raster, but the only areas you’re
interested in are those that are suitable; i.e., those polygons where the value of suitable is
1.

9.1.2 Try yourself...

Refer back to the module on vector analysis.

• Create a new vector file that contains only the polygons where suitable has the value
of 1.

• Save the new file under exercise_data/residential_development as suit-
able_terrain.shp.

Check your results

9.1.3 Follow along: The Vector to Raster Tool

Although unnecessary for our current problem, it’s useful to know about the opposite conver-
sion from the one performed above.

• Click on Raster → Conversion → Rasterize (Vector to Raster) to start this tool, then set
it up as in the screenshot below:
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• Input file is all_terrain;

• Output file... is exercise_data/residential_development/raster_conversion.tif;

• Width and Height are 837 and 661, respectively.

Note: The size of the output image is specified here to be the same as the original raster which
was vectorized. To view the dimensions of an image, open its metadata (Metadata tab in the
Layer Properties).

• Click OK on the dialog to begin the conversion process.

• When it is complete, gauge its success by comparing the new raster with the original one.
They should match up exactly, pixel for pixel.

9.1.4 In conclusion

Converting between raster and vector formats allows you to widen the applicability of data, and
need not lead to data degradation.

9.1.5 What’s next?

Now that we have the results of the terrain analysis available in vector format, they can be used
to solve the problem of which farms we should consider for the residential development.
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9.2 Lesson: Combining the Analyses

Using the vectorized results of the raster analysis will allow you to select only those farms with
suitable tarrain.

The goal for this lesson: To use the vectorized terrain results to select suitable farms.

9.2.1 Try yourself...

• Save your current map (raster_analysis.qgs).

• Open the map in which you did the vector analysis earlier (analysis.qgs).

• In the Layers list, enable these layers: - hillshade, - solution, - important_roads and -
either aerial_photos or DEM.

• In addition to these layers, which should already be loaded in the map from when you
worked on it before, also add the suitable_terrain.shp dataset.

• Select all the farms (in the solution layer) that intersect with the suitable_terrain
layer. (Use the select by location tool as before.)

• Save the selection as new_solution.shp.

You should now have a layer with these farms as your solution:
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9.2.2 Try yourself... Inspecting the Results

Look at each of the farms in your new_solution layer. Compare them with the suitable_terrain
layer by changing the symbology for the new_solution layer so that it has outlines only. What
do you notice about some of the farms? Are they all suitable just because they intersect with
the suitable_terrain layer? Why or why not? Which ones would you deem to be unsuitable?

Check your results

9.2.3 Try yourself... Refining the Analysis

Now that you can see from the results that some farms were included that were not really
suitable, it becomes possible to refine the analysis.

We can see that there are some farms which do have suitable areas in them, but these areas
are too small to be useful. The decision is made that for a farm to be considered, it must have
suitable areas on it that are continuous for 350 meters or more. How would you ensure that the
farms meet this requirement? Use (a) vector analysis tool(s) for this.

Check your results
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9.2.4 In conclusion

You have now answered the original research question, and can offer an opinion (with reasons,
backed by analysis) for a recommendation regarding which property to develop.

9.2.5 What’s next?

Next you will present these results as part of your second assignment.

9.3 Assignment

Using the Map Composer, make a new map representing the results of your analysis. Include
these layers:

• places (with labels),

• hillshade,

• solution (or new_solution),

• important_roads and

• either aerial_photos or DEM.

Write a short explanatory text to accompany it. Include in this text the criteria that were used
in considering a farm for development, as well as explaining your recommendation for which
farm to use.

9.4 Lesson: Supplementary Exercise

In this lesson, you will be guided through a complete GIS analysis in QGIS.

Note: Lesson developed by Linfiniti and S Motala (Cape Peninsula University of Technology)

9.4.1 Problem Statement

You are tasked with finding areas in and around the Cape Peninsula that are a suitable habitat
for a rare fynbos plant species. The extent of your area of investigation in the Cape Peninsula
is: south of Melkbosstrand, west of Strand. Botanists have provided you with the following
preferences exhibited by the species in question:

• It grows on east facing slopes.

• It grows on slopes with a gradient between 15% and 60%.

• It grows in areas that have a total annual rainfall of > 1200 mm.
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• It will only be found at least 250 m away from any human settlement.

• The area of vegetation in which it occurs should be at least 6000m2 in area.

As a volunteer for Cape Nature, you have agreed to search for the plant on the closest suitable
piece of land to your house. Use your GIS skills to determine where you should go to look.

9.4.2 Solution Outline

In order to solve this problem, you will have to use the available data (available in
exercise_data/more_analysis) to find the candidate area that is closest to your
house. If you don’t live in Cape Town (where this problem is based) you can choose any
house in the Cape Town region. The solution will involve:

• analysing the DEM to find the east facing slopes and the slopes with the correct gradients;

• analysing the rainfall raster to find the areas with the correct amount of rainfall;

• analysing the Zoning vector layer to find areas that are away from human settlement and
are of the correct size.

9.4.3 Setting up the Map

• Click on the “CRS status” button in the extreme lower right corner of the screen. Under
the CRS tab of the screen that appears, you will see the box Coordinate reference systems
of the world.

• In this box, navigate to Projected Coordinate Systems → Universal Transverse Mercator
(UTM).

• Select the entry WGS 84 / UTM zone 33S (with the EPSG code 32733).

• Click OK. The map is now in the UTM33S coordinate reference system.

• Save the map by clicking on the Save Project As toolbar button, or use the File → Save
Project As... menu item.

• Save the map in a directory called Rasterprac that you should create somewhere on
your computer. You will save whatever layers you create in this directory as well.

9.4.4 Loading Data into the Map

In order to process the data, you will need to load the necessary layers (street names, zones,
rainfall, DEM) into the map canvas.

For vectors ...

• Click on the Add Vector Layer button, or use the Layer → Add Vector Layer... menu item.

• In the dialog that appears, ensure that the File radio button is selected.
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• Click on the Browse button.

• In the dialog that appears, open the exercise_data/more_analysis/streets directory.

• Select the file Street_Names_UTM33S.shp.

• Click Open.

The dialog closes and shows the original dialog, with the file path specified in the text field
next to the Browse button. This allows you to ensure that the correct file is selected. It is also
possible to enter the file path in this field manually, should you wish to do so.

• Click Open. The vector layer will load in your map. Its color is automatically assigned.
It will be changed later.

• Rename the layer to Streets.

• Right-click on it in the Layers list (by default, the pane along the left-hand side of the
screen).

• Click Rename in the dialog that appears and rename it, pressing the Enter key when done.

• Repeat the vector adding process, but this time select the Gener-
alised_Zoning_Dissolve_UTM33S.shp file in the Zoning directory.

• Rename it to Zoning.

For rasters ...

• Click on the Add Raster Layer button, or use the Layer → Add Raster Layer... menu
item.

• Navigate to the appropriate file, select it, and click Open.

• Do this for each of the two raster files. The files you want are DEM/reproject/DEM and
Rainfall/reprojected/rainfall.tif.

• Rename the rainfall raster to Rainfall (with an initial capital). Initially when you load
them, the images will be gray rectangles. Don’t worry, this will be changed later.

• Save the map.

In order to properly see what’s going on, the symbology for the layers needs to be changed.

9.4.5 Changing the symbology of vector layers

• In the Layers list, right-click on the Streets layer.

• Select Properties from the menu that appears.

• Switch to the Style tab in the dialog that appears.

• Click on the button labeled Change, with a square showing the current color of the Streets
layer.

• Select a new color in the dialog that appears.
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• Click OK.

• Click OK again in the Layer Properties dialog. This will change the color of the Streets
layer.

• Follow a similar process for the Zoning layer and choose an appropriate color for it.

9.4.6 Changing the symbology of raster layers

Raster layer symbology is somewhat different.

• Open the Properties dialog for the Rainfall raster.

• Switch to the Style tab. You’ll notice that this style dialog is very different from the
version used for vector layers.

• Ensure that the button Use standard deviation is selected.

• Change the value in the associated box to 2.00 (it should be set to 0.00 by default).

• Under the heading Contrast enhancement, change the value of the Current dropdown list
to Stretch to MinMax.

• Click OK. The “Rainfall” raster, if visible, should change colors, allowing you to see
different brightness values for each pixel.

• Repeat this process for the DEM, but set the standard deviations used for stretching to
4.00.

9.4.7 Changing the layer order

• In the Layers list, click and drag layers up and down to change the order they appear in
on the map.

• Newer versions of QGIS may have a Control rendering order checkbox beneath the Lay-
ers list. Ensure that it is checked.

Now that all the data is loaded and properly visible, the analysis can begin. It is best if the
clipping operation is done first. This is so that no processing power is wasted on computing
values in areas that aren’t going to be used anyway.

9.4.8 Find the Correct Districts

• Load the vector layer admin_boundaries/Western_Cape_UTM33S.shp into
your map.

• Rename it to Districts.

• Right-click on the Districts layer in the Layers list.

• In the menu that appears, select the Query... menu item. The Query Builder dialog
appears.
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You will now build a query to select only the following list of districts:

• Bellville,

• Cape,

• Goodwood,

• Kuils River,

• Mitchells Plain,

• Simons Town, and

• Wynberg.

• In the Fields list, double-click on the NAME_2 field. It appears in the SQL where clause
text field below.

• Click the = button; an = sign is added to the SQL query.

• Click the All button below the (currently empty) Values list. After a short delay, this will
populate the Values list with the values of the selected field (NAME_2).

• Double-click the value Bellville in the Values list. As before, this will be added to the
SQL query.

In order to select more than one district, you’ll need to use the OR boolean operator.

• Click the OR button and it will be added to the SQL query.

• Using a process similar to the above, add the following to the existing SQL query:

"NAME_2" = ’Cape’

• Add another OR operator, then work your way through the list of districts above in a
similar fashion.

• The final query should be

"NAME_2" = ’Bellville’ OR "NAME_2" = ’Cape’ OR "NAME_2" = ’Goodwood’ OR
"NAME_2" = ’Kuils River’ OR "NAME_2" = ’Mitchells Plain’ OR "NAME_2" =
’Simons Town’ OR "NAME_2" = ’Wynberg’

• Click OK. The districts shown in your map are now limited to those in the list above.

9.4.9 Clip the Rasters

Now that you have an area of interest, you can clip the rasters to this area.

• Ensure that the only layers that are visible are the DEM, Rainfall and Districts layers.

• Districts must be on top so that they are visible.

• Open the clipping dialog by selecting the menu item Raster → Extraction → Clipper.

• In the Input file (raster) dropdown list, select the DEM layer.

• Specify an output location in the Output file text field by clicking the Select... button.
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• Navigate to your Rasterprac directory.

• Enter a file name.

• Save the file. Leave the No data value checkbox unchecked.

• Use the Extent clipping mode by ensuring the correct radio button is selected.

• Click and drag an area in the canvas, so that the area which includes the districts is
selected.

• Check the Load into canvas when finished box.

• Click OK.

• After the clipping operation is completed, DO NOT CLOSE the Clipper dialog. (Doing
so would cause you to lose the clipping area that you have already defined.)

• Select the Rainfall raster in the Input file (raster) dropdown list and choose a different
output file name.

• Do not change any other options. Do not alter the existing clipping area which you drew
previously. Leave everything the same and click OK.

• After the second clipping operation has completed, you may close the Clipper dialog.

• Save the map.

9.4.10 Clean up the map

• Remove the original Rainfall and DEM layers from the Layers list:

• Right-click on these layers and select Remove.

– This will not remove the data from your storage device, it will merely take it out of
your map.

• Deactivate the labels on the Streets layer:

– Click the Labeling button.

– Uncheck the Label this layer with box.

– Click OK.

• Show all the Streets again:

– Right-click on the layer in the Layers list.

– Select Query.

• In the Query dialog that appears, click the Clear button, then click OK.

• Wait while the data is loaded. All the streets will now be visible.

• Change the raster symbology as before (see Changing the symbology of raster layers).

• Save the map.
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• You can now hide the vector layers by unchecking the box next to them in the Layers list.
This will make the map render faster and will save you some time.

In order to create the hillshade, you will need to use a plugin that was written for this purpose.

9.4.11 Activating the Raster Terrain Analysis plugin

This plugin is included by default in QGIS 1.8. However, it may not be immediately visible.
To check if it is accessible on your system:

• Click on the menu item Plugins –> Manage Plugins....

• Ensure that the box next to Raster Terrain Analysis plugin is selected.

• Click OK.

You will now have access to this plugin via the Raster → Terrain analysis menu item.

Remember that plugins may sometimes depend on certain Python modules being installed on
your system. Should a plugin refuse to work while complaining of missing dependencies,
please ask your tutor or lecturer for assistance.

9.4.12 Create the hillshade

• In the Layers list, ensure that the DEM is the active layer (i.e., it is highlighted by having
been clicked on).

• Click on the Raster → Terrain analysis → Hillshade menu item to open the Hillshade
dialog.

• Specify an appropriate location for the output layer and call it hillshade.

• Check the Add result to project box.

• Click OK.

• Wait for it to finish processing.

The new hillshade layer has appeared in your Layers list.

• Right-click on the hillshade layer in your Layers list and bring up the Properties dialog.

• Click on the Transparency tab and set the transparency slider to 80%.

• Click OK on the dialog.

• Note the effect when the transparent hillshade is superimposed over the clipped DEM.

9.4.13 Slope

• Click on the menu item Raster → Terrain analysis.

• Select the Slope analysis type, with the clipped DEM as the input layer.
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• Specify an appropriate file name and location for output purposes.

• Check the Add result to project box.

• Click OK.

The slope image has been calculated and added to the map. However, as usual it is just a gray
rectangle. To properly see what’s going on, change the symbology as follows.

• Open the layer Properties dialog (as usual, via the right-click menu of the layer).

• Click on the Style tab.

• Where it says Grayscale (in the Color map dropdown menu), change it to Pseudocolor.

• Ensure that the Use standard deviation radio button is selected.

9.4.14 Aspect

• Use the same approach as for calculating the slope, but select Aspect in the initial dialog
box.

Remember to save the map periodically.

9.4.15 Reclassifying rasters

• Click the menu item Raster → Raster calculator.

• Specify your Rasterprac directory as the location for the output layer.

• Ensure that the Add result to project box is selected.

In the Raster bands list on the left, you will see all the raster layers in your Layers list. If your
Slope layer is called slope, it will be listed as slope@1.

The slope needs to be between 15 and 60 degrees. Everything less than 15 or greater than 60
must therefore be excluded.

• Using the list items and buttons in the interface, build the following expression:

((slope@1 < 15) OR (slope@1 > 60)) = 0

• Set the Output layer field to an appropriate location and file name.

• Click OK.

Now find the correct aspect (east-facing: between 45 and 135 degrees) using the same ap-
proach.

• Build the following expression:

((aspect@1 < 45) OR (aspect@1 > 135)) = 0

• Find the correct rainfall (greater than 1200mm) the same way. Build the following ex-
pression:
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(rainfall@1 < 1200) = 0

Having reclassified all the rasters, you will now see them displayed as gray rectangles in your
map (assuming that they have been added to the map correctly). To properly display raster
data with only two classes (1 and 0, meaning true or false), you will need to change their
symbology.

9.4.16 Setting the style for the reclassified layers

• Open the Style tab in the layer’s Properties dialog as usual.

• Under the heading Load min / max values from band, select the Actual (slower) radio
button.

• Click the Load button.

The Custom min / max values fields should now populate with 0 and 1, respectively. (If they
do not, then there was a mistake with your reclassification of the data, and you will need to go
over that part again.)

• Under the heading Contrast enhancement, set the Current dropdown list to Stretch To
MinMax.

• Click OK.

• Do this for all three reclassified rasters, and remember to save your work!

The only criterion that remains is that the area must be 250m away from urban areas. We will
satisfy this requirement by ensuring that the areas we compute are 250m or more from the edge
of a rural area. Hence, we need to find all rural areas first.

9.4.17 Finding rural areas

• Hide all layers in the Layers list.

• Unhide the Zoning vector layer.

• Right-click on it and bring up the Query dialog.

• Build the following query:

"Gen_Zoning" = ’Rural’

See the earlier instructions for building the Streets query if you get stuck.

• When you’re done, close the Query dialog.

You should see a collection of polygons from the Zoning layer. You will need to save these to
a new layer file.

• On the right-click menu for Zoning, select Save as....

• Save your layer under the Zoning directory.
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• Name the output file rural.shp.

• Click OK.

• Add the layer to your map.

• Click the menu item Vector → Geoprocessing Tools → Dissolve.

• Select the rural layer as your input vector layer, while leaving the Use only selected
features box unchecked.

• Under Dissolve field, select — Dissolve all —.

• Save your layer under the Zoning directory.

• Click OK. A dialog will appear asking whether you want to add the new layer to the TOC
(“Table of Contents”, referring to the Layers list).

• Click Yes.

• Close the Dissolve dialog.

• Remove the rural and Zoning layers.

• Save the map.

Now you need to exclude the areas that are within 250m from the edge of the rural areas. Do
this by creating a negative buffer, as explained below.

9.4.18 Creating a negative buffer

• Click the menu item Vector → Geoprocessing Tools → Buffer(s).

• In the dialog that appears, select the rural_dissolve layer as your input vector layer (Use
only selected features should not be checked).

• Select the Buffer distance button and enter the value -250 into the associated field; the
negative value means that the buffer must be an internal buffer.

• Check the Dissolve buffer results box.

• Set the output file to the same directory as the other rural vector files.

• Name the output file rural_buffer.shp.

• Click Save.

• Click OK and wait for the processing to complete.

• Select Yes on the dialog that appears.

• Close the Buffer dialog.

• Remove the rural_dissolve layer.

• Save the map.
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In order to incorporate the rural zones into the same analysis with the three existing rasters, it
will need to be rasterized as well. But in order for the rasters to be compatible for analysis,
they will need to be the same size. Therefore, before you can rasterize, you’ll need to clip the
vector to the same area as the three rasters. A vector can only be clipped by another vector, so
you will first need to create a bounding box polygon the same size as the rasters.

9.4.19 Creating a bounding box vector

• Click on the menu item Layer –> New –> New Shapefile Layer....

• Under the Type heading, select the Polygon button.

• Click Specify CRS and set the coordinate reference system WGS 84 / UTM zone
33S : EPSG:32733.

• Click OK.

• Click OK on the New Vector Layer dialog as well.

• Save the vector in the Zoning directory.

• Name the output file bbox.shp.

• Hide all layers except the new bbox layer and one of the reclassified rasters.

• Ensure that the bbox layer is highlighted in the Layers list.

• Navigate to the View > Toolbars menu item and ensure that Digitizing is selected. You
should then see a toolbar icon with a pencil or koki on it. This is the Toggle editing
button.

• Click the Toggle editing button to enter edit mode. This allows you to edit a vector layer.

• Click the Add feature button, which should be nearby the Toggle editing button. It may be
hidden behind a double arrow button; if so, click the double arrows to show the Digitizing
toolbar’s hidden buttons.

• With the Add feature tool activated, left-click on the corners of the raster. You may need
to zoom in with the mouse wheel to ensure that it is accurate. To pan across the map in
this mode, click and drag in the map with the middle mouse button or mouse wheel.

• For the fourth and final point, right-click to finalize the shape.

• Enter any arbitrary number for the shape ID.

• Click OK.

• Click the Save edits button.

• Click the Toggle editing button to stop your editing session.

• Save the map.

Now that you have a bounding box, you can use it to clip the rural buffer layer.
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9.4.20 Clipping a vector layer

• Ensure that only the bbox and rural_buffer layers are visible, with the latter on top.

• Click the menu item Vector > Geoprocessing Tools > Clip.

• In the dialog that appears, set the input vector layer to rural_buffer and the clip layer to
bbox, with both Use only selected features boxes unchecked.

• Put the output file under the Zoning directory.

• Name the output file rural_clipped.

• Click OK.

• When prompted to add the layer to the TOC, click Yes.

• Close the dialog.

• Compare the three vectors and see the results for yourself.

• Remove the bbox and rural_buffer layers, then save your map.

Now it’s ready to be rasterized.

9.4.21 Rasterizing a vector layer

You’ll need to specify a pixel size for a new raster that you create, so first you’ll need to know
the size of one of your existing rasters.

• Open the Properties dialog of any of the three existing rasters.

• Switch to the Metadata tab.

• Make a note of the X and Y values under the heading Dimensions in the Metadata table.

• Close the Properties dialog.

• Click on the Raster → Conversion → Rasterize menu item. You may receive a warning
about a dataset being unsupported. Click it away and ignore it.

• Select rural_clipped as your input layer.

• Set an output file location inside the Zoning directory.

• Name the output file rural_raster.tif.

• Check the New size box and enter the X and Y values you made a note of earlier.

• Check the Load into canvas box.

• Click the pencil icon next to the text field which shows the command that will be run.
At the end of the existing text, add a space and then the text -burn 1. This tells the
Rasterize function to “burn” the existing vector into the new raster and give the areas
covered by the vector the new value of 1 (as opposed to the rest of the image, which will
automatically be 0).

• Click OK.
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• The new raster should show up in your map once it has been computed.

• The new raster will look like a grey rectangle – you may change the display style as you
did for the reclassified rasters.

• Save your map.

Now that you have all four criteria each in a separate raster, you need to combine them to see
which areas satisfy all the criteria. To do so, the rasters will be multiplied with each other.
When this happens, all overlapping pixels with a value of 1 will retain the value of 1, but if a
pixel has the value of 0 in any of the four rasters, then it will be 0 in the result. In this way, the
result will contain only the overlapping areas.

9.4.22 Combining rasters

• Click the Raster → Raster calculator menu item.

• Build the following expression (with the appropriate names for your layers, depending
on what you called them):

[Rural raster] * [Reclassified aspect] * [Reclassified slope] *
[Reclassified rainfall]

• Set the output location to the Rasterprac directory.

• Name the output raster cross_product.tif.

• Ensure that the Add result to project box is checked.

• Click OK.

• Change the symbology of the new raster in the same way as you set the style for the other
reclassified rasters. The new raster now properly displays the areas where all the criteria
are satisfied.

To get the final result, you need to select the areas that are greater than 6000m^2. How-
ever, computing these areas accurately is only possible for a vector layer, so you will need to
vectorize the raster.

9.4.23 Vectorizing the raster

• Click on the menu item Raster → Conversion → Polygonize.

• Select the cross_product raster.

• Set the output location to Rasterprac.

• Name the file candidate_areas.shp.

• Ensure that Load into canvas when finished is checked.

• Click OK.

• Close the dialog when processing is complete.
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All areas of the raster have been vectorized, so you need to select only the areas that have a
value of 1.

• Open the Query dialog for the new vector.

• Build this query:

"DN" = 1

• Click OK.

• Create a new vector file from the results by saving the candidate_areas vector after the
query is complete (and only the areas with a value of 1 are visible). Use the Save as...
function in the layer’s right-click menu for this.

• Save the file in the Rasterprac directory.

• Name the file candidate_areas_only.shp.

• Save your map.

9.4.24 Calculating the area for each polygon

• Open the new vector layer’s right-click menu.

• Select Open attribute table.

• Click the Toggle editing mode button along the bottom of the table, or press Ctrl+E.

• Click the Open field calculator button along the bottom of the table, or press Ctrl+I.

• Under the New field heading in the dialog that appears, enter the field name area. The
output field type should be an integer, and the field width should be 10.

• In Field calculator expresion, type:

$area

This means that the field calculator will calculate the area of each polygon in the vector
layer and will then populate a new integer column (called area) with the computed value.

• Click OK.

• Do the same thing for another new field called id. In Field calculator expresion, type:

$id

This ensures that each polygon has a unique ID for identification purposes.

• Click Toggle editing mode again, and save your edits if prompted to do so.

9.4.25 Selecting areas of a given size

Now that the areas are known:

9.4. Lesson: Supplementary Exercise 257



Quantum GIS Training Manual, Release 1.0

• Build a query (as usual) to select only the polygons larger than 6000m^2. The query is:

"area" > 6000

• Save the selection as a new vector layer called solution.shp.

You now have your solution areas, from which you will pick the one nearest to your house.

9.4.26 Digitize your house

• Create a new vector layer as before, but this time, select the Type value as being a Point.

• Ensure that it is in the correct CRS!

• Name the new layer house.shp.

• Finish creating the new layer.

• Enter edit mode (while the new layer is selected).

• Click the point where your house or other current place of residence is, using the streets
as a guide. You might have to open other layers to help you find your house. If you
don’t live anywhere nearby, just click somewhere among the streets where a house could
conceivably be.

• Enter any arbitrary number for the shape ID.

• Click OK.

• Save your edits and exit edit mode.

• Save the map.

You will need to find the centroids (“centers of mass”) for the solution area polygons in order
to decide which is closest to your house.

9.4.27 Calculate polygon centroids

• Click on the Vector → Geometry Tools → Polygon centroids menu item.

• Specify the input layer as solution.shp.

• Provide the output location as Rasterprac.

• Call the destination file solution_centroids.shp.

• Click OK and add the result to the TOC (Layers list), then close the dialog.

• Drag the new layer to the top of the layer order so that you can see it.

9.4.28 Calculate which centroid is closest to your house

• Click on the menu item Vector –> Analysis Tools –> Distance matrix.
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• The input layer should be your house, and the target layer solution_centroids. Both of
these should use the id field as their unique ID field.

• The output matrix type should be linear.

• Set an appropriate output location and name.

• Click OK.

• Open the file in a text editor (or import it into a spreadsheet). Note which target ID is
associated with the shortest Distance. There may be more than one at the same distance.

• Build a query in QGIS to select only the solution areas closest to your house (selecting it
using the id field).

This is the final answer to the research question.

For your submission, include the semi-transparent hillshade layer over an appealing raster of
your choice (such as the DEM or the slope raster, for example). Also include the polygon of
the closest solution area(s), as well as your house. Follow all the best practices for cartography
in creating your output map.
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CHAPTER 10

Module: Plugins

Plugins allow you to extend the functionality QGIS offers. In this module, you’ll be shown
how to activate and use plugins.

10.1 Lesson: Installing and Managing Plugins

To begin using plugins, you need to know how to download, install and activate them. To do
this, you will learn how to use the Plugin Installer and Plugin Manager.

The goal for this lesson: To understand and use QGIS’ plugin system.

10.1.1 Follow along: Managing Plugins

• To open the Plugin Manager, click on the menu item Plugins → Manage Plugins.

• In the dialog that opens, find the GdalTools plugin:
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• Click in the box next to this plugin and uncheck it.

• Click OK.

• Look under the Raster menu. You will see that many of the functions you have been
using before have disappeared! This is because they are part of the GdalTools plugin,
which needs to be activated for you to use them.

• Open the Plugin Manager again and reactivate the GdalTools plugin by clicking in the
checkbox next to it.

• If you open the Raster menu again, you’ll see that the tools have reappeared.

Importantly, however, the list of plugins that you can activate and deactivate only draws from
the plugins that you currently have installed. To install new plugins, you need to use the Plugin
Installer.

10.1.2 Follow along: Installing New Plugins

• To start the Plugin Installer, click on the menu item Plugins → Fetch Python Plugins.

A dialog will appear. The amount of plugins that you see here will differ, depending on your
setup.

The plugins that are available to you for installation depend on which repositories you are
checking.
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QGIS plugins are stored online in repositories. By default, only the official repositories are
active, meaning that you can only access official plugins. These are usually the first plugins
you want, because they have been tested thoroughly and are often included in QGIS by default.

It is possible, however, to try out more plugins than the default ones. First, you want to check
in all available repositories. To do this:

• Open the Repositories tab on the Plugin Installer dialog:

• Click the Add 3rd party repositories button. A disclaimer will appear.

• Click OK to find and add these extra repositories:

10.1. Lesson: Installing and Managing Plugins 263



Quantum GIS Training Manual, Release 1.0

However, even with these extra repositories enabled, you won’t see the plugins that they con-
tain, unless you allow these plugins to be displayed.

• Open the Options tab:

• Select the option Show all plugins except those marked as experimental.

• If you now switch back to the Plugins tab, you will see that many more plugins are now
available for installation.

• To install a plugin, simply click on it in the list and then click the Install plugin button.

10.1.3 In conclusion

Installing plugins in QGIS is simple and effective!

10.1.4 What’s next?

Next we’ll introduce you to some useful plugins as examples.

10.2 Lesson: Useful QGIS Plugins

Now you can install, enable and disable plugins. Let’s see how this can help you in practice by
looking at some examples of useful plugins.

The goal for this lesson: To familiarize yourself with the plugin interface and get acquainted
with some useful plugins.
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10.2.1 Follow along: The Raster Terrain Analysis Plugin

• Start a new map with only the srtm_41_19.tif raster dataset in it (look in
exercise_data/raster/SRTM).

From the lesson on raster analysis, you’re already familiar with raster analysis functions. You
used GDAL tools (accessible via Raster –> Analysis) for this. However, you should also know
about the Raster Terrain Analysis plugin. This ships standard with newer versions of QGIS,
and so you don’t need to install it separately.

• Open the Plugin Manager and check that the Raster Terrain Analysis plugin is enabled:

• Open the Raster menu. You should see a Terrain analysis submenu.

• Click on Terrain analysis → Relief to open this dialog:
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• Save the new file under exercise_data/plugins/relief.tif (create a new
folder if necessary).

• Leave the Output format and Z factor unchanged.

• Check the box Add result to project.

• Click the Create automatically button. The list below will be populated:

These are the colors that the plugin will use to create the relief.

• If you like, you can change these colors now. For example:
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• Click OK and the relief will be created:

This achieves a similar effect to when you used the semi-transparent hillshade as an overlay
over another raster layer. The advantage of this plugin is that it creates this effect using only
one layer.

10.2.2 Follow along: The Google Layers Plugin

• Start a new map with only the streets layer in it.

• Zoom in over the Swellendam area.
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• Using the Plugin Installer, find the plugin by entering the word Google in the Filter
field.

• Select the Google Layers plugin from the filtered list:

• Click the Install plugin button to install.

• When it’s done, close the Plugin Installer.

• Open the Plugin Manager.

• Enable the new plugin:
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• Check the box beside it.

• Now click OK to enable the plugin.

Before using it, make sure that both your map and the plugin are configured properly:

• Open the plugin’s settings by clicking on Plugins → Google Layers → Settings.

• Use the dialog to choose a map type you want. In this example, we’ll use the “Hybrid”
type map, but you can choose any others if you want.

• Enable “on the fly” projection and use the Google Mercator projection:

• Now use the plugin to give you a Google map of the area! You can click on Plugins →
Google Layers → Google Layers to run it. Or, if you have the Plugins toolbar enabled,
you can click on its icon:
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This will load a new raster image in from Google that you can use as a backdrop, or to help
you find out where you are on the map. Here is such a layer, with our own vector road layer as
overlay:

10.2.3 Follow along: The OpenStreetMap Plugin

Since we’re using OpenStreetMap (OSM) data in our examples, it would be instructive to know
where it comes from. QGIS has a plugin that allows you to download and edit this kind of data
easily.

• First, ensure that you have the plugin installed by opening the Plugin Installer and filter-
ing on the word street:
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• The OpenStreetMap plugin should be installed by default, but if it isn’t, you can get it by
clicking the Install plugin button.

• Once it’s installed, activate it via the Plugin Manager.

• A new panel and new buttons will be added to your interface:

10.2. Lesson: Useful QGIS Plugins 271



Quantum GIS Training Manual, Release 1.0

Let’s download data for Swellendam. The plugin will download data for the area currently on
your map.

• Zoom in to the Swellendam area.

• To add data, click on the Download OSM data button:

Note: You may see a message stating that the latitude, longitude, or both extents are too large.
This is because the OSM server doesn’t have the capacity to continually give people data about
the whole world. To prevent people trying to download too much data, there’s a limit to the
size of the area for which you can download data. If you get one of these error messages, zoom
in to a smaller area on the map.

• If you have an acceptable area, you can leave the other options as default and click the
Download button.

• After a while, the data will be downloaded, and will be shown in your map automatically.
Here’s an example:

(The labels are added from our local data for identification purposes.)
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With any of the OSM layers selected in your Layers list, the buttons in the plugin’s dock panel
will become active:

• Using the plugin’s own Identify feature tool (at the far left of the above buttons), click
on any feature in the OSM layers to retrieve its data and see it displayed in the plugin
interface. For example, clicking on the river that runs through town gives you this:

• You can create new features (point, lines, polygons) as well as edit a feature that you
have identified. For example, using the plugin’s Identify feature tool as before, you can
click on this street:
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Looking at its attributes, it doesn’t have a name:

• Double-click in the <new tag here> field.

• Select a new tag (attribute) from a list. Let’s choose name:
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• Double-click in the Value field:

You can save your changes to the original source data, too. This makes the changes available
internationally on the OSM server.

• Click the Upload OSM data button:

This gives you a dialog, which you can fill in as needed.

• If you have a user account at OSM, you can enter your credentials in the spaces provided
and click the Upload button to save those changes.

Note that the plugin has many other functions: for example, you can also save OSM layers to a
local directory, load data from saved OSM layers, and export OSM data as shapefiles.

OSM’s data comes from, and is maintained by, the efforts of their users. Contributing data
using this plugin allows you to help improve the quality of the OSM data you depend on.

10.2.4 In conclusion

There are many useful plugins available for QGIS. Using the built-in tools for installing and
managing these plugins, you can find new plugins and make optimum use of them.
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10.2.5 What’s next?

Next we’ll look at how to use layers that are hosted on remote servers in real time.
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CHAPTER 11

Module: Online Resources

When considering data sources for a map, there is no need to be restricted by data you need
to download onto the computer you’re working on. There are online data sources that you can
load data from as long as you are connected to the Internet.

In this module, we’ll cover two kinds of web-based GIS services: Web Mapping Services
(WMS) and Web Feature Services (WFS).

11.1 Lesson: Web Mapping Services

A Web Mapping Service (WMS) is a service hosted on a remote server. Similar to a website,
you can access it as long as you have a connection to the server. Using QGIS, you can load a
WMS directly into your existing map.

From the lesson on plugins, you will remember that it’s possible to load a new raster image from
Google, for example. However, this is a once-off transaction: once you have downloaded the
image, it doesn’t change. A WMS is different, in that it’s a live service that will automatically
refresh its view if you pan or zoom on the map.

The goal for this lesson: To use a WMS and understand its limitations.

11.1.1 Follow along: Loading a WMS Layer

For this exercise, you can either use the basic map you made at the start of the course, or just
start a new map and load some existing layers into it. For this example, we used the places,
new_solution and important_roads layers:
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• Load these layers into a new map, or use your original map with only these layers visible.

• Before starting to add the WMS layer, first deactivate “on the fly” projection. This may
cause the layers to no longer overlap properly, but don’t worry: we’ll fix that later.

• To add WMS layers, click on the Add WMS Layer button:

Remember how you connected to a SpatiaLite database at the beginning of the course. The
rural, urban, and water layers are in that database. To use those layers, you first needed to
connect to the database. Using a WMS is similar, with the exception (of course) that the layers
are on a remote server.

• To create a new connection to a WMS, click on the New button.

You’ll need a WMS address to continue. There are several free WMS servers available on the
Internet. One of these is GIS-LAB.info1, which makes use of the OpenStreetMap2 dataset.

• To make use of this WMS, set it up in your current dialog, like this:

1http://irs.gis-lab.info/
2http://wiki.openstreetmap.org/wiki/Main_Page
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• The value of the Name field should be gis-lab.

• The value of the URL field should be http://irs.gis-lab.info/.

• Click OK. You should see the new WMS server listed:

• Click Connect. In the list below, you should now see these new entries loading:
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These are all the layers hosted by this WMS server.

• Click once on the osm layer (it stands for OpenStreetMap, which is the data we want). It
will display its Coordinate Reference System:

Since we’re not using WGS 84 for our map, let’s see all the CRSs we have to choose from.

• Click the Change button. You will see a standard Coordinate Reference System Selector
dialog.

• We want a projected CRS, so let’s choose WGS 84 / World Mercator.

• Click OK.

• Click Add and the new layer will appear in your map as osm.

• In the Layers list, click and drag it to the bottom of the list.

You will notice that your layers aren’t located correctly. (For example, the places layer puts
Bonnievale in the Gulf of Guinea.) This is obviously because “on the fly” projection is disabled.
Let’s enable it again, but using the same projection as the osm layer, which is WGS 84 / World
Mercator.

• Enable “on the fly” projection.

• In the CRS tab (Project Properties dialog), enter the value world in the Filter field:
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• Choose WGS 84 / World Mercator from the list.

• Click OK.

• Now right-click on one of your own layers in the Layers list and click Zoom to layer
extent. You should see the Swellendam area:
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Note how the WMS layer’s streets and our own streets overlap. That’s a good sign!

The nature and limitations of WMS

By now you may have noticed that this WMS layer actually has many layers in it. It has streets,
rivers, nature reserves, and so on. What’s more, even though it looks like it’s made up of
vectors, it seems to be a raster. But you can’t even change its symbology! Why is that?

This is how a WMS works: it’s a map, similar to a normal map on paper, that you receive as an
image. What usually happens is that you have vector layers, which QGIS renders as a map. But
using a WMS, those vector layers are on the WMS server, which renders it as a map and sends
that map to you as an image. QGIS can display this image, but can’t change its symbology,
because all that is handled on the server.

This has several advantages, because you don’t need to worry about the symbology. It’s already
worked out, and should be nice to look at on any competently designed WMS.

On the other hand, you can’t change the symbology if you don’t like it, and if things change on
the WMS server, then they’ll change on your map as well. This is why you sometimes want to
use a Web Feature Service (WFS) instead, which gives you vector layers separately, and not as
part of a WMS-style map.

This will be covered in the next lesson, however. First, let’s add another WMS layer from the
gis-lab WMS server.
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11.1.2 Try yourself...

• Hide the osm layer in the Layers list.

• Load the landsat layer into the map (use the Add WMS Layer button as before). Remem-
ber to check that it’s in the same WGS 84 / World Mercator projection as the rest of your
map!

• You might want to set its Encoding to JPEG and its Tile size option to 200 by 200, so
that it loads faster:

Check your results

11.1.3 Try yourself...

• Hide all other WMS layers to prevent them rendering unnecessarily in the background.

• Add the “ICEDS” WMS server at this URL: http://iceds.ge.ucl.ac.uk/cgi-bin/icedswms

• Add the bluemarble layer.

Check your results

11.1.4 Try yourself...

Part of the difficulty of using WMS is finding a good (free) server.

• Find a new WMS at MapMatters.org3 (or elsewhere online). It must not have associated
fees or restrictions, and must have coverage over the Swellendam study area.

Remember that what you need in order to use a WMS is only its URL (and preferably
some sort of description).

Check your results

3http://www.mapmatters.org/
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11.1.5 In conclusion

Using a WMS, you can add inactive maps as backdrops for your existing map data.

11.1.6 Further reading

• MapMatters.org4

• Geopole.org5

• OpenStreetMap.org list of WMS servers6

11.1.7 What’s next?

Now that you’ve added an inactive map as a backdrop, you’ll be glad to know that it’s also
possible to add features (such as the other vector layers you added before). Adding features
from remote servers is possible by using a Web Feature Service (WFS). That’s the topic of the
next lesson.

11.2 Lesson: Web Feature Services

A Web Feature Service (WFS) provides its users with GIS data in formats that can be loaded
directly in QGIS. Unlike a WMS, which provides you only with a map which you can’t edit, a
WFS gives you access to the features themselves.

The goal for this lesson: To use a WFS and understand how it differs from a WMS.

11.2.1 Follow along: Loading a WFS Layer

• Start a new map. This is for demo purposes and won’t be saved.

• Ensure that “on the fly” reprojection is switched off.

• Click the Add WFS Layer button:

• Click the New button.

• In the dialog that appears, enter the Name as nsidc.org and the URL as
http://nsidc.org/cgi-bin/atlas_south?version=1.1.0.

4http://www.mapmatters.org/
5http://geopole.org/
6http://wiki.openstreetmap.org/wiki/WMS
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• Click OK, and the new connection will appear in your Server connections.

• Click the Connect. A list of the available layers will appear:

• Find the layer south_poles_wfs.

• Click on the layer to select it:
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• Click Apply.

It may take a while to load the layer. When it has loaded, it will appear in the map. Here it
is over the outlines of Antarctica (available on the same server, and by the name of antarc-
tica_country_border):
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How is this different from having a WMS layer? That will become obvious when you see the
layers’ attributes.

• Open the south_poles_wfs layer’s attribute table. You should see this:

Since the points have attributes, doesn’t that mean we can label them? Yes we can, as well as
changing their symbology. Here’s an example:
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• Add labels to your layer to take advantage of the attribute data in this layer.

Differences from WMS layers

A Web Feature Service returns the layer itself, not just a map rendered from it. This gives
you direct access to the data, meaning that you can change ts symbology and run analysis
functions on it. However, this is at the cost of much more data being transmitted. This will be
especially obvious if the layers you’re loading have complicated shapes, a lot of attributes, or
many features; or even if you’re just loading a lot of layers. WFS layers typically take a very
long time to load because of this.

11.2.2 Follow along: Querying a WFS Layer

Although it is, of course, possible to query a WFS layer after having loaded it, it’s often more
efficient to query it before you load it. That way, you’re only requesting the features you want,
meaning that you use far less bandwidth.
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For example, on the WFS server we’re currently using, there is a layer called countries (ex-
cluding Antarctica). Let’s say that we want to know where South Africa is relative to the
south_poles_wfs layer (and perhaps also the antarctica_country_border layer) that’s already
been loaded.

There are two ways to do this. You can load the whole countries ... layer, and then build a query
as usual once it’s loaded. However, transmitting the data for all the countries in the world and
then only using the data for South Africa seems a bit wasteful of bandwidth. Depending on
your connection, this dataset can take several minutes to load.

The alternative is to build the query as a filter before even loading the layer from the server.

• In the Add WFS Layer ... dialog, connect to the server we used before and you should
see the list of available layers.

• Double-click next to the countries ... layer in the Filter field:

• In the dialog that appears, build the query "Countryeng" = ’South Africa’:
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• It will appear as the Filter value:
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• Click Apply with the countries layer selected as above. Only the country with the
Countryeng value of South Africa will load from that layer:

You don’t have to, but if you tried both methods, you’ll notice that this is a lot faster than
loading all the countries before filtering them!
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Notes on WFS availability

It is rare to find a WFS hosting features you need, if your needs are very specific. The reason
why Web Feature Services are relatively rare is because of the large amounts of data that must
be transmitted to describe a whole feature. It is therefore not very cost-effective to host a WFS
rather than a WMS, which sends only images.

The most common type of WFS you’ll encounter will therefore probably be on a local network
or even on your own computer, rather than on the Internet.

11.2.3 In conclusion

WFS layers are preferable over WMS layers if you need direct access to the attributes and
geometries of the layers. However, considering the amount of data that needs to be downloaded
(which leads to speed problems and also a lack of easily available public WFS servers) it’s not
always possible to use a WFS instead of a WMS.

11.2.4 What’s next?

Next, you’ll see how to use QGIS as a frontend for the famous GRASS GIS.
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CHAPTER 12

Module: GRASS

GRASS (Geographic Resources Analysis Support System) is a well-known open source GIS
with a wide array of useful GIS functions. It was first released in 1984, and has seen much
improvement and additional functionality since then. QGIS allows you to make use of GRASS’
powerful GIS tools directly.

12.1 Lesson: GRASS Setup

Using GRASS in QGIS requires you to think of the interface in a slightly different way. Re-
member that you’re not working in QGIS directly, but working in GRASS via QGIS.

The goal for this lesson: To begin a GRASS project in QGIS.

12.1.1 Follow along: Start a New GRASS Project

To launch GRASS from within QGIS, you need to activate it as with any other plugin.

• In the Plugin Manager, enable GRASS in the list:
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The GRASS toolbar will appear:

Before you can use GRASS, you need to create a mapset. GRASS always works in a database
environment, which means that you need to import all the data you want to use into a GRASS
database.

• Click on the New mapset button:

You’ll see a dialog explaining the structure of a GRASS mapset.

• Create a new directory called grass_db in exercise_data.

• Set it as the directory that will be used by GRASS to set up its database:
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GRASS needs to create a “location”, which describes the maximum extents of the geographic
area you’ll be working in.

• Call the new location South_Africa:
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• We’ll be working with WGS 84, so search for and select this CRS:
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• Now select the region South Africa, which is already defined in GRASS:
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• Create a mapset, which is the map file that you’ll be working with.
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Once you’re done, you’ll see a dialog asking you to confirm that the settings it displays are
correct.

• Click Finish.

• Click OK on the success dialog.

12.1.2 Follow along: Loading Vector Data into GRASS

You’ll now have a blank map. To load data into GRASS, you need to follow a two-step process.

• Load data into QGIS as usual. Use the streets.shp dataset (found under
exercise_data/) for now.

• As soon as it’s loaded, click on the GRASS Tools button:

• Find the vector import tool by entering the term v.in.ogr.qgis in the Filter field of
the dialog that has appeared.

The v stands for “vector”, in means its a function to import data into the GRASS database,
ogr is the software library used to read vector data, and qgis means that the tool will look
for a vector from among the vectors already loaded into QGIS.

• Once you’ve found this tool, click on it to bring up the tool itself:
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• Set the loaded layer to streets and its GRASS version’s name to g_streets to prevent
confusion.
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Note: Note the extra import options provided under Advanced Options. These include
the ability to add a WHERE clause for the SQL query used for importing the data.

• Click Run to begin the import.

• When it’s done, click the View output button to see the newly imported GRASS layer in
the map.

• Close first the import tool itself (click the Close button to the immediate right of View
output), then close the GDAL Tools window.

• Remove the original roads_33S layer.

Now you are left with only the imported GRASS layer as displayed in your QGIS map.

12.1.3 Follow along: Loading Raster Data into GRASS

Recall that our DEM is in the Projected CRS UTM 33S / WGS 84, but our GRASS project
is in the Geographic CRS WGS 84. So let’s reproject the DEM first.
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• Load the srtm_41_19.tif dataset (found under
exercise_data/raster/SRTM/) into the QGIS map as usual, using QGIS’
Add Raster Layer tool.

• Reproject it using GDAL Warp tool (Raster → Projections → Warp (Reproject)), setting
it up as shown:

• Save the raster under the same folder as the original, but with the file name
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DEM_WGS84.tif. Once it appears in your map, remove the srtm_41_19.tif
dataset from your Layers list.

Now that it’s reprojected, you can load it into your GRASS database.

• Open the GRASS Tools dialog again.

• Click on the Modules List tab.

• Search for r.in.gdal.qgis:

Which gives you this tool:
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• Set it up as shown (input layer is DEM_WGS84, output is g_dem).

• Click Run.

• When the process is done, click View output.

• Close the current tab, and then Close the whole dialog.

304 Chapter 12. Module: GRASS



Quantum GIS Training Manual, Release 1.0

• You may now remove the original DEM_WGS84 layer.

12.1.4 In conclusion

The GRASS workflow for ingesting data is somewhat different from the QGIS method, because
GRASS loads its data into a spatial database structure. However, by using QGIS as a frontend,
you can make the setup of a GRASS mapset easier by using existing layers in QGIS as data
sources for GRASS.

12.1.5 What’s next?

Now that the data is imported into GRASS, we can look at the advanced analysis operations
that GRASS offers.

12.2 Lesson: GRASS Tools

In this lesson we will present a selection of tools to give you an idea of the capabilities of
GRASS.

12.2.1 Follow along: Set Raster Colors

• Open the GRASS Tools dialog.

• Look for the r.colors.table module by searching for it in the Filter field of the
Modules List tab.

• Open the tool and set it up like this:

When you run the tool, it will recolor your raster:
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12.2.2 Follow along: Visualize Data in 3D

GRASS allows you to use a DEM to visualize your data in three dimensions. The tool you’ll
use for this operates on the GRASS Region, which at the moment is set to the whole extent of
South Africa, as you set it up before.

• To redefine the extent to cover only our raster dataset, click this button:

When this tool is activated, your cursor will turn into a cross whe over the QGIS map canvas.

• Using this tool, click and drag a rectangle around the edges of the GRASS raster.

• Click OK in the GRASS Region Settings dialog when done.

• Search for the nviz tool:
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• Set it up as shown:

• Remember to enable both Use region of this map buttons to the right of the two raster
selection dropdown menus. This will allow NVIZ to correctly assess the resolution of
the rasters.

• Click the Run button.

NVIZ will set up a 3D environment using the raster and vector selected. This may take some
time, depending on your hardware. When it’s done, you will see the map rendered in 3D in a
new window:
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Experiment with the height, z-exag, and View method settings to change your view of the data.
The navigation methods may take some getting used to.

12.2.3 Follow along: The Mapcalc Tool

• Open the GRASS Tools dialog’s Modules List tab and search for calc.

• From the list of modules, select r.mapcalc (not r.mapcalculator, which is more basic).

• Start the tool.

The Mapcalc dialog allows you to construct a sequence of analyses to be performed on a raster,
or collection of rasters. You will use these tools to do so:

In order, they are:

• Add map: Add a raster file from your current GRASS mapset.

• Add constant value: Add a constant value to be used in functions.

• Add operator or function: Add an operator or function to be connected to in-
puts and outputs.

• Add connection: Connect elements. Using this tool, click and drag from the red
dot on one item to the red dot on another item. Dots that are correctly connected to a
connector line will turn gray. If the line or dot is red, it is not properly connected!
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• Select item: Select an item and move selected items.

• Delete selected item: Removes the selected item from the current mapcalc
sheet, but not from the mapset (if it is an existing raster).

Using these tools:

• Construct the following algorithm:

• When you click Run, your output should look like this:

• Click View output to see the output displayed in your map:
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This shows all the areas where the terrain is lower than 500 meters or higher than 1000 meters.

12.2.4 In conclusion

In this lesson, we have covered only a few of the many tools GRASS offers. To explore the
capabilities of GRASS for yourself, open the GRASS Tools dialog and scroll down the Modules
List. Or for a more structured approach, look under the Modules Tree tab, which organizes
tools by type.
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CHAPTER 13

Module: Assessment

Use your own data for this section. You will need:

• a point vector dataset of points of interest, with point names and multiple categories

• a line vector dataset of roads

• a polygon vector dataset of land use (using property boundaries)

• a visual-spectrum image (such as an aerial photograph)

• a DEM (downloadable from this URL1 if you don’t have your own)

13.1 Create a base map

Before doing any data analysis, you will need a base map, which will provide your analysis
result with context.

13.1.1 Add the point layer

• Add in the point layer. Based on the level that you’re doing the course at, do only what
is listed in the appropriate section below:

• Label the points according to a unique attribute, such as place names. Use a small font
and keep the labels inconspicuous. The information should be available, but shouldn’t be
a main feature of the map.

• Classify the points themselves into different colors based on a category. For example,
categories could include “tourist destination”, “police station”, and “town center”.

1http://srtm.csi.cgiar.org/
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• Do the same as the section.

• Classify the point size by importance: the more significant a feature, the larger its point.
However, don’t exceed the point size of 2.00.

• For features that aren’t located at a single point (for example, provincial/regional names,
or town names at a large scale), don’t assign any point at all.

• Don’t use point symbols to symbolize the layer at all. Instead, use labels centered over
the points; the point symbols themselves should have no size.

• Use Data defined settings to style the labels into meaningful categories.

• Add appropriate columns to the attribute data if necessary. When doing so, don’t create
fictional data - rather, use the Field Calculator to populate the new columns, based on
appropriate existing values in the dataset.

13.1.2 Add the line layer

• Add the road layer and then change its symbology. Don’t label the roads.

• Change the road symbology to a light color with a broad line. Make it somewhat trans-
parent as well.

• Create a symbol with multiple symbol layers. The resulting symbol should look like
a real road. You can use a simple symbol for this; for example, a black line with a
thin white solid line running down the center. It can be more elaborate as well, but the
resulting map should not look too busy.

• If your dataset has a high density of roads at the scale you want to show the map at,
you should have two road layers: the elaborate road-like symbol, and a simpler symbol
at smaller scales. (Use scale-based visibility to make them switch out at appropriate
scales.)

• All symbols should have multiple symbol layers. Use symbols to make them display
correctly.
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• Do the same as in the section above.

• In addition, roads should be classified. When using realistic road-like symbols, each
type of road should have an appropriate symbol; for example, a highway should appear
to have two lanes in either direction.

13.1.3 Add the polygon layer

• Add the land use layer and change its symbology.

• Classify the layer according to land use. Use solid colors.

• Classify the layer according to land use. Where appropriate, incorporate symbol layers,
different symbol types, etc. Keep the results looking subdued and uniform, however.
Keep in mind that this will be part of a backdrop!

• Use rule-based classification to classify the land use into general categories, such as
“urban”, “rural”, “nature reserve”, etc.

13.1.4 Create the raster backdrop

• Create a hillshade from the DEM, and use it as an overlay for a classified version of the
DEM itself. You could also use the Relief plugin (as shown in the lesson on plugins).

13.1.5 Finalize the base map

• Using the resources you above, create a base map using some or all of the layers. This
map should include all the basic information needed to orient the user, as well as being
visually unified / “simple”.
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13.2 Analyze the data

• You are looking for a property that satisfies certain criteria.

• You can decide on your own criteria, which you must document.

• There are some guidelines for these criteria:

– the target property should be of (a) certain type(s) of land use

– it should be within a given distance from roads, or be crossed by a road

– it should be within a given distance from some category of points, like a hospital
for example

13.2.1 /

• Include raster analysis in your results. Consider at least one derived property of the raster,
such as its aspect or slope.

13.3 Final Map

• Use the Map Composer to create a final map, which incorporates your analysis results.

• Include this map in a document along with your documented criteria. If the map has
become too vsually busy due to the added layer(s), deselect the layers which you feel are
the least necessary.

• Your map must include a title and a legend.
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CHAPTER 14

Module: PostgreSQL

PostgreSQL is a Database Management System (DBMS). In this module, you’ll be shown how
to use PostgreSQL to create a new database, as well as accessing other typical DBMS functions.

14.1 Lesson: Introduction to Databases

Before using PostgreSQL, let’s make sure of our ground by covering general database theory.
You will not need to enter any of the example code; it’s only there for illustration purposes.

The goal for this lesson: To understand fundamental database concepts.

14.1.1 What is a Database?

A database consists of an organized collection of data for one or more uses, typi-
cally in digital form. - Wikipedia

A database management system (DBMS) consists of software that operates
databases, providing storage, access, security, backup and other facilities. -
Wikipedia

14.1.2 Tables

In relational databases and flat file databases, a table is a set of data elements (val-
ues) that is organized using a model of vertical columns (which are identified by
their name) and horizontal rows. A table has a specified number of columns, but
can have any number of rows. Each row is identified by the values appearing in a
particular column subset which has been identified as a candidate key. - Wikipedia

id | name | age
----+-------+-----

1 | Tim | 20
2 | Horst | 88

(2 rows)
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In SQL databases a table is also known as a relation.

14.1.3 Columns / Fields

A column is a set of data values of a particular simple type, one for each row
of the table. The columns provide the structure according to which the rows are
composed. The term field is often used interchangeably with column, although
many consider it more correct to use field (or field value) to refer specifically to
the single item that exists at the intersection between one row and one column. -
Wikipedia

A column:

| name |
+-------+
| Tim |
| Horst |

A field:

| Horst |

14.1.4 Records

A record is the information stored in a table row. Each record will have a field for each of the
columns in the table.

2 | Horst | 88 <-- one record

14.1.5 Datatypes

Datatypes restrict the kind of information that can be stored in a column. - Tim and
Horst

There are many kinds of datatypes. Let’s focus on the most common:

• String - to store free-form text data

• Integer - to store whole numbers

• Real - to store decimal numbers

• Date - to store Horst’s birthday so no one forgets

• Boolean - to store simple true/false values

You can tell the database to allow you to also store nothing in a field. If there is nothing in a
field, then the field content is referred to as a ‘null’ value.
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insert into person (age) values (40);

INSERT 0 1
test=# select * from person;

id | name | age
----+-------+-----
1 | Tim | 20
2 | Horst | 88
4 | | 40 <-- null for name

(3 rows)

There are many more datatypes you can use - check the PostgreSQL manual!1

14.1.6 Modelling an Address Database

Let’s use a simple case study to see how a database is constructed. We want to create an address
database. What kind of information should we store?

Write some address properties in the space provided:

1http://www.postgresql.org/docs/current/static/datatype.html
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The properties that describe an address are the columns. The type of information stored in each
column is its datatype. In the next section we will analyse our conceptual address table to see
how we can make it better!

14.1.7 Database Theory

The process of creating a database involves creating a model of the real world; taking real world
concepts and representing them in the database as entities.

14.1.8 Normalisation

One of the main ideas in a database is to avoid data duplication / redundancy. The process of
removing redundancy from a database is called Normalisation.

Normalization is a systematic way of ensuring that a database structure is suitable
for general-purpose querying and free of certain undesirable characteristics - inser-
tion, update, and deletion anomalies - that could lead to a loss of data integrity. -
Wikipedia

There are different kinds of normalisation ‘forms’.

Let’s take a look at a simple example:

Table "public.people"
Column | Type | Modifiers

----------+------------------------+-----------------------------------------
id | integer | not null default

| | nextval(’people_id_seq’::regclass)
| |

name | character varying(50) |
address | character varying(200) | not null
phone_no | character varying |
Indexes:
"people_pkey" PRIMARY KEY, btree (id)
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select * from people;
id | name | address | phone_no
--+---------------+-----------------------------+-------------
1 | Tim Sutton | 3 Buirski Plein, Swellendam | 071 123 123
2 | Horst Duester | 4 Avenue du Roix, Geneva | 072 121 122
(2 rows)

Imagine you have many friends with the same street name or city. Every time this data is
duplicated, it consumes space. Worse still, if a city name changes, you have to do a lot of work
to update your database.

Try to redesign our people table to reduce duplication:
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You can read more about database normalisation here2

14.1.9 Indexes

A database index is a data structure that improves the speed of data retrieval oper-
ations on a database table. - Wikipedia

Imagine you are reading a textbook and looking for the explanation of a concept - and the
textbook has no index! You will have to start reading at one cover and work your way through
the entire book until you find the information you need. The index at the back of a book helps
you to jump quickly to the page with the relevant information.

create index person_name_idx on people (name);

Now searches on name will be faster:

Table "public.people"
Column | Type | Modifiers

----------+------------------------+-----------------------------------------
id | integer | not null default

| | nextval(’people_id_seq’::regclass)
| |

name | character varying(50) |
address | character varying(200) | not null
phone_no | character varying |
Indexes:
"people_pkey" PRIMARY KEY, btree (id)
"person_name_idx" btree (name)

14.1.10 Sequences

A sequence is a unique number generator. It is normally used to create a unique identifier for a
column in a table.

In this example, id is a sequence - the number is incremented each time a record is added to the
table:

id | name | address | phone_no
---+--------------+-----------------------------+-------------
1 | Tim Sutton | 3 Buirski Plein, Swellendam | 071 123 123
2 | Horst Duster | 4 Avenue du Roix, Geneva | 072 121 122

14.1.11 Entity Relationship Diagramming

In a normalised database, you typically have many relations (tables). The entity-relationship
diagram (ER Diagram) is used to design the logical dependencies between the relations. Re-
member our un-normalised people table?

2http://en.wikipedia.org/wiki/Database_normalization
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test=# select * from people;
id | name | address | phone_no
----+--------------+-----------------------------+-------------
1 | Tim Sutton | 3 Buirski Plein, Swellendam | 071 123 123
2 | Horst Duster | 4 Avenue du Roix, Geneva | 072 121 122
(2 rows)

With a little work we can split it into two tables, removing the need to repeat the street name
for individuals who live in the same street:

test=# select * from streets;
id | name
----+--------------
1 | Plein Street
(1 row)

and

test=# select * from people;
id | name | house_no | street_id | phone_no
----+--------------+----------+-----------+-------------
1 | Horst Duster | 4 | 1 | 072 121 122

(1 row)

We can then link the two tables using the ‘keys’ streets.id and people.streets_id.

If we draw an ER Diagram for these two tables it would look something like this:

The ER Diagram helps us to express ‘one to many’ relationships. In this case the arrow symbol
show that one street can have many people living on it.

Our people model still has some normalisation issues - try to see if you can normalise it further
and show your thoughts by means of an ER Diagram.
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14.1.12 Constraints, Primary Keys and Foreign Keys

A database constraint is used to ensure that data in a relation matches the modeller’s view of
how that data should be stored. For example a constraint on your postal code could ensure that
the number falls between 1000 and 9999.

A Primary key is one or more field values that make a record unique. Usually the primary key
is called id and is a sequence.

A Foreign key is used to refer to a unique record on another table (using that other table’s
primary key).

In ER Diagramming, the linkage between tables is normally based on Foreign keys linking to
Primary keys.

If we look at our people example, the table definition shows that the street column is a foreign
key that references the primary key on the streets table:

Table "public.people"
Column | Type | Modifiers

-----------+-----------------------+--------------------------------------
id | integer | not null default

| | nextval(’people_id_seq’::regclass)
name | character varying(50) |
house_no | integer | not null
street_id | integer | not null
phone_no | character varying |
Indexes:
"people_pkey" PRIMARY KEY, btree (id)
Foreign-key constraints:
"people_street_id_fkey" FOREIGN KEY (street_id) REFERENCES streets(id)
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14.1.13 Transactions

When adding, changing, or deleting data in a database, it is always important that the database is
left in a good state if something goes wrong. Most databases provide a feature called transaction
support. Transactions allow you to create a rollback position that you can return to if your
modifications to the database did not run as planned.

Take a scenario where you have an accounting system. You need to transfer funds from one
account and add them to another. The sequence of steps would go like this:

• remove R20 from Joe

• add R20 to Anne

If something goes wrong during the process (e.g. power failure), the transaction will be rolled
back.

14.1.14 In conclusion

Databases allow you to manage data in a structured way using simple code structures.

14.1.15 What’s next?

Now that we’ve looked at how databases work in theory, let’s create a new database to imple-
ment the theory we’ve covered.

14.2 Lesson: Implementing the Data Model

Now that we’ve covered all the theory, let’s create a new database. This database will be used
for our exercises for the lessons that will follow afterwards.

The goal for this lesson: To install the required software and use it to implement our example
database.

14.2.1 Install PostgreSQL

Under Ubuntu:

sudo apt-get install postgresql-9.1

You should get a message like this:

[sudo] password for timlinux:
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
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postgresql-client-9.1 postgresql-client-common postgresql-common
Suggested packages:
oidentd ident-server postgresql-doc-9.1
The following NEW packages will be installed:
postgresql-9.1 postgresql-client-9.1 postgresql-client-common postgresql-common
0 upgraded, 4 newly installed, 0 to remove and 5 not upgraded.
Need to get 5,012kB of archives.
After this operation, 19.0MB of additional disk space will be used.
Do you want to continue [Y/n]?

Press Y and Enter and wait for the download and installation to finish.

14.2.2 Help

PostgreSQL has very good online3 documentation.

14.2.3 Create a database user

Under Ubuntu:

After the installation is complete, run this command to become the postgres user and then create
a new database user:

sudo su - postgres

Type in your normal log in password when prompted (you need to have sudo rights).

Now, at the postgres user’s bash prompt, create the database user. Make sure the user name
matches your unix login name: it will make your life much easier, as postgres will automatically
authenticate you when you are logged in as that user.

createuser -d -E -i -l -P -r -s timlinux

Enter a password when prompted. I normally use a different password to my usual unix login.

What do those options mean?

-d, --createdb role can create new databases
-E, --encrypted encrypt stored password
-i, --inherit role inherits privileges of roles it is a member of (default)
-l, --login role can login (default)
-P, --pwprompt assign a password to new role
-r, --createrole role can create new roles
-s, --superuser role will be superuser

Now you should should leave the postgres user’s bash shell environment by typing:

exit

3http://www.postgresql.org/docs/9.1/static/index.html
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14.2.4 Verify the new account

psql -l

Should return something like this:

timlinux@linfiniti:~$ psql -l
List of databases
Name | Owner | Encoding | Collation | Ctype |
----------+----------+----------+------------+------------+
postgres | postgres | UTF8 | en_ZA.utf8 | en_ZA.utf8 |
template0 | postgres | UTF8 | en_ZA.utf8 | en_ZA.utf8 |
template1 | postgres | UTF8 | en_ZA.utf8 | en_ZA.utf8 |
(3 rows)

Type q to exit.

14.2.5 Create a database

The createdb command is used to create a new database. It should be run from the bash
shell prompt.

createdb address

You can verify the existence of your new database by using this command:

psql -l

Which should return something like this:

List of databases
Name | Owner | Encoding | Collation | Ctype | Access privileges
----------+----------+----------+------------+------------+-----------------------
address | timlinux | UTF8 | en_ZA.utf8 | en_ZA.utf8 |
postgres | postgres | UTF8 | en_ZA.utf8 | en_ZA.utf8 |
template0 | postgres | UTF8 | en_ZA.utf8 | en_ZA.utf8 | =c/postgres: postgres=CTc/postgres
template1 | postgres | UTF8 | en_ZA.utf8 | en_ZA.utf8 | =c/postgres: postgres=CTc/postgres
(4 rows)

Type q to exit.

14.2.6 Starting a database shell session

You can connect to your database easily like this:

psql address

To exit out of the psql database shell, type:

\q
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For help in using the shell, type:

\?

For help in using sql commands, type:

\help

To get help on a specific command, type (for example):

\help create table

See also the Psql cheat sheet - available online here4.

14.2.7 Make Tables in SQL

Let’s start making some tables! We will use our ER Diagram as a guide. First, let’s create a
streets table:

create table streets (id serial not null primary key, name varchar(50));

serial and varchar are data types. serial tells PostgreSQL to start an integer sequence
(autonumber) to populate the id automatically for every new record. varchar(50) tells
PostgreSQL to create a character field of 50 characters in length.

You will notice that the command ends with a ; - all SQL commands should be terminated this
way. When you press enter, psql will report something like this:

NOTICE: CREATE TABLE will create implicit sequence "streets_id_seq" for
serial column "streets.id"

NOTICE: CREATE TABLE / PRIMARY KEY will create implicit index "streets_pkey"
for table "streets"

CREATE TABLE

That means your table was created successfully, with a primary key streets_pkey using
streets.id.

Note: If you hit return without entering a ;, then you will get a prompt like this: address-#.
This is because PG is expecting you to enter more. Enter ; to run your command.

To view your table schema, you can do this:

\d streets

Which should show something like this:

Table "public.streets"
Column | Type | Modifiers
--------+-----------------------+--------------------------------------
id | integer | not null default

| | nextval(’streets_id_seq’::regclass)
name | character varying(50) |

4http://www.postgresonline.com/special_feature.php?sf_name=postgresql83_psql_cheatsheet&outputformat=html
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Indexes:
"streets_pkey" PRIMARY KEY, btree (id)

To view your table contents, you can do this:

select * from streets;

Which should show something like this:

id | name
---+------
(0 rows)

As you can see, our table is empty!

Use the approach shown above to make a table called people: Add fields such as phone number,
home address, name, etc. (these aren’t all valid names: change them to make them valid).

Write the SQL you create here:
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Solution:

create table people (id serial not null primary key,
name varchar(50),
house_no int not null,
street_id int not null,
phone_no varchar null );

The schema for the table (enter \d people) looks like this:

Table "public.people"
Column | Type | Modifiers
-----------+-----------------------+-------------------------------------
id | integer | not null default

| | nextval(’people_id_seq’::regclass)
name | character varying(50) |
house_no | integer | not null
street_id | integer | not null
phone_no | character varying |
Indexes:

"people_pkey" PRIMARY KEY, btree (id)

Note: For illustration purposes, we have purposely omitted the fkey constraint.

14.2.8 Create Keys in SQL

The problem with our solution above is that the database doesn’t know that people and streets
have a logical relationship. To express this relationship, we have to define a foreign key that
points to the primary key of the streets table.
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There are two ways to do this:

• adding the key after the table has been created

• defining the key at time of table creation

Our table has already been created, so let’s do it the first way:

alter table people
add constraint people_streets_fk foreign key (street_id) references streets(id);

That tells the people table that its street_id fields must match a valid street id from the
streets table.

The more usual way to create a constraint is to do it when you create the table:

create table people (id serial not null primary key,
name varchar(50),
house_no int not null,
street_id int references streets(id) not null,
phone_no varchar null);

After adding the constraint, our table schema looks like this now:

\d people
Table "public.people"

Column | Type | Modifiers
-----------+-----------------------+---------------------------------
id | integer | not null default

| | nextval(’people_id_seq’::regclass)
name | character varying(50) |
house_no | integer | not null
street_id | integer | not null
phone_no | character varying |
Indexes:

"people_pkey" PRIMARY KEY, btree (id)
Foreign-key constraints:

"people_streets_fk" FOREIGN KEY (id) REFERENCES streets(id)

14.2.9 Create Indexes in SQL

We want lightning fast searches on peoples names. To provide for this, we can create an index
on the name column of our people table:

create index people_name_idx on people(name);
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address=# \d people
Table "public.people"

Column | Type | Modifiers
-----------+-----------------------+-----------------------------------
id | integer | not null default nextval

| | (’people_id_seq’::regclass)
name | character varying(50) |
house_no | integer | not null
street_id | integer | not null
phone_no | character varying |
Indexes:
"people_pkey" PRIMARY KEY, btree (id)
"people_name_idx" btree (name) <-- new index added!
Foreign-key constraints:
"people_streets_fk" FOREIGN KEY (id) REFERENCES streets(id)

14.2.10 Dropping Tables in SQL

If you want to get rid of a table you can use the drop command:

drop table streets;

In our example, this would not work - why?

Some deep and inspired thoughts as to why...

Sometimes you just can’t stand having a table any more. Maybe you are sick of all your friends.
How can you get rid of them all in one easy step? Drop the table of course! Of course, right
now too much hard work has gone into our table to get rid of it on a whim, but if you really
hate your friends that much, nothing’s stopping you from ridding yourself of them forever:
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drop table people;

This time it works fine! Why? Are people less important than streets?

Some thoughts on why you could drop people:

Note: If you actually did enter that command and dropped the people table, now would be
a good time to rebuild it, as you will need it in the next exercises.

14.2.11 A word on PG Admin III

We are showing you the SQL commands from the psql prompt because it’s a very useful way
to learn about databases. However, there are quicker and easier ways to do a lot of what we are
showing you. Install PGAdminIII and you can create, drop, alter etc tables using ‘point and
click’ operations in a GUI.

Under Ubuntu, you can install it like this:

sudo apt-get install pgadmin3

14.2.12 In conclusion

You have now seen how to create a brand new database, starting completely from scratch.

14.2.13 What’s next?

Next you’ll learn how to use the DBMS to add new data.
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14.3 Lesson: Adding Data to the Model

The models we’ve created will now need to be populated with the data they’re intended to
contain.

The goal for this lesson: To learn how to insert new data into the database models.

14.3.1 Insert statement

How do you add data to a table? The sql INSERT statement provides the functionality for this:

insert into streets (name) values (’High street’);

A couple of things to note:

• after the table name (streets), you list the column names that you will be populating
(in this case only the name column).

• after the values keyword, place the list of field values.

• strings should be quoted using single quotes.

• you will note that I did not insert a value for the id column - that is because it is a
sequence and will be autogenerated.

• if you do manually set the id, you may cause serious problems with the integrity of your
database.

You should see INSERT 0 1 if it is successful.

You can see the result of your insert action by selecting all the data in the table:

select * from streets;

result:

select * from streets;
id | name
----+-------------

1 | High street
(1 row)

Now you try:

Use the INSERT command to add a new street to the streets table.

Write the sql you used here:
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14.3.2 Sequencing data addition according to constraints

Try to add a person to the people table with the following details:

Name: Joe Smith
House Number: 55
Street: Main Street
Phone: 072 882 33 21

Remember, we defined phone numbers as strings.

What problems did you encounter?

You should have an error report if you try to do this without first creating a record for Main
Street in the streets table.
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What error did you get?

You should have noticed that:

• You can’t add the street using its name

• You can’t add a street using a street id before first creating the street record on the
streets table

Remember that our two tables are linked via a Primary/Foreign Key pair. This means that no
valid person can be created without there also being a valid corresponding street record.

Here is how we made our friend:

insert into streets (name) values(’Main Street’);
insert into people (name,house_no, street_id, phone_no)

values (’Joe Smith’,55,2,’072 882 33 21’);

If you look at the streets table again (using a select statement as before), you’ll see that the
id for the Main Street entry is 2. That’s why we could merely enter the number 2 above.
Even though we’re not seeing Main Streetwritten out fully in the entry above, the database
will be able to associate that with the street_id value of 2.

14.3.3 Select data

We have already shown you the syntax for selecting records. Lets look at a few more examples:

select name from streets;

select * from streets;

select * from streets where name=’Main Street’;

In later sessions we will go into more detail on how to select and filter data.

14.3.4 Update data

What is you want to make a change to some existing data? For example a street name is
changed:

update streets set name=’New Main Street’ where name=’Main Street’;

Be very careful using such update statements - if more than one record matches your WHERE
clause, they will all be updated!

A better solution is to use the primary key of the table to reference the record to be changed:

update streets set name=’New Main Street’ where id=2;

It should return UPDATE 1.

Note: the WHERE statement criteria are case sensitive Main Street <> Main street
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14.3.5 Delete Data

Some times you fall out of friendship with people. Sounds like a job for the DELETE command!

delete from people where name = ’Joe Smith’;

Let’s look at our people table now:

address=# select * from people;
id | name | house_no | street_id | phone_no

----+------+----------+-----------+----------
(0 rows)

Exercise: Use the skills you learned earlier to add some new friends to your database:

name | house_no | street_id | phone_no
------------------+----------+-----------+---------------
Joe Bloggs | 3 | 2 | 072 887 23 45
IP Knightly | 55 | 3 | 072 837 33 35
Rusty Bedsprings | 33 | 1 | 072 832 31 38
QGIS Geek | 83 | 1 | 072 932 31 32

14.3.6 In conclusion

Now you know how to add new data to the existing models you created previously. Remember
that if you want to add new kinds of data, you may want to modify and/or create new models
to contain that data.

14.3.7 What’s next?

Now that you’ve added some data, you’ll learn how to use queries to access this data in various
ways.

14.4 Lesson: Queries

When you write a SELECT ... command it is commonly known as a query - you are inter-
rogating the database for information.

The goal of this lesson: To learn how to create queries that will return useful information.

14.4.1 Follow-up from previous lesson

Let’s check that you added a few people to the database successfully:
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insert into people (name,house_no, street_id, phone_no)
values (’Joe Bloggs’,3,1,’072 887 23 45’);

insert into people (name,house_no, street_id, phone_no)
values (’IP Knightly’,55,1,’072 837 33 35’);

insert into people (name,house_no, street_id, phone_no)
values (’Rusty Bedsprings’,33,1,’072 832 31 38’);

insert into people (name,house_no, street_id, phone_no)
values (’QGIS Geek’,83,1,’072 932 31 32’);

14.4.2 Ordering results

Let’s get a list of people ordered by their house numbers:

select name, house_no from people order by house_no;

Result:

name | house_no
------------------+----------
Joe Bloggs | 3
Rusty Bedsprings | 33
IP Knightly | 55
QGIS Geek | 83
(4 rows)

You can sort by more than one column:

select name, house_no from people order by name, house_no;

Result:

name | house_no
------------------+----------
IP Knightly | 55
Joe Bloggs | 3
QGIS Geek | 83
Rusty Bedsprings | 33
(4 rows)

14.4.3 Filtering

Often you won’t want to see every single record in the database - especially if there are thou-
sands of records and you are only interested in seeing one or two. Never fear, you can filter the
results!

Here is an example of a numerical filter:

address=# select name, house_no from people where house_no < 50;
name | house_no

------------------+----------
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Joe Bloggs | 3
Rusty Bedsprings | 33
(2 rows)

You can combine filters (defined using the WHERE clause) with sorting (defined using the
ORDER BY)

address=# select name, house_no from people where house_no < 50 order by
address-# house_no;

name | house_no
------------------+----------
Joe Bloggs | 3
Rusty Bedsprings | 33
(2 rows)

You can also filter based on text data:

address=# select name, house_no from people where name like ’%i%’;
name | house_no

------------------+----------
IP Knightly | 55
Rusty Bedsprings | 33
(2 rows)

Here we used the LIKE clause to find all names with an i in them. If you want to search for a
string of letters regardless of case, you can do a case insensitive search using the ILIKE clause:

address=# select name, house_no from people where name ilike ’%k%’;
name | house_no

-------------+----------
IP Knightly | 55
QGIS Geek | 83
(2 rows)

That found everyone with a k or K in their name. Using the normal ILIKE clause, you’d get:

address=# select name, house_no from people where name like ’%k%’;
name | house_no

-----------+----------
QGIS Geek | 83
(1 row)

14.4.4 Joins

What if you want to see the person’s details and their street name (not its id)? In order to do
that, you need to join the two tables together in a single query. Lets look at an example:

select people.name, house_no, streets.name
from people,streets
where people.street_id=streets.id;
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Note: With joins, you will always state the two tables the information is coming from, in this
case people and streets. You also need to specify which two keys must match (foreign key &
primary key). If you don’t specify that, you will get a list of all possible combinations of people
and streets, but no way to know who actually lives on which street!

Here is what the correct output will look like:

name | house_no | name
------------------+----------+-------------
Joe Bloggs | 3 | High street
IP Knightly | 55 | High street
Rusty Bedsprings | 33 | High street
QGIS Geek | 83 | High street
(4 rows)

We will revisit joins as we create more complex queries later. Just remember they provide a
simple way to combine the information from two or more tables.

14.4.5 Subselect

First, let’s do a little tweaking to our data:

insert into streets (name) values(’QGIS Road’);
insert into streets (name) values(’OGR Corner’);
insert into streets (name) values(’Goodle Square’);
update people set street_id = 2 where id=2;
update people set street_id = 3 where id=3;

Let’s take a quick look at our data after those changes - we reuse our query from the previous
section:

select people.name, house_no, streets.name
from people,streets
where people.street_id=streets.id;

Result:

name | house_no | name
------------------+----------+-----------------
Rusty Bedsprings | 33 | High street
QGIS Geek | 83 | High street
Joe Bloggs | 3 | New Main Street
IP Knightly | 55 | QGIS Road
(4 rows)

Now let’s show you a subselection on this data. We want to show only people who live in
street_id number 1.

select people.name
from people, (
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select *
from streets
where id=1

) as streets_subset
where people.street_id = streets_subset.id;

Result:

name
------------------
Rusty Bedsprings
QGIS Geek
(2 rows)

This is a contrived example and in the above situations it may have been overkill. However
when you have to filter based on a selection, subselects are really useful!

14.4.6 Aggregate Queries

One of the powerful features of a database is its ability to summarise the data in its tables.
These summaries are called aggregate queries. Here is a typical example:

select count(*) from people;

Result:

count
-------

4
(1 row)

If we want the counts summarised by street name we can do this:

select count(name), street_id
from people
group by street_id;

Result:

count | street_id
-------+-----------

1 | 2
1 | 3
2 | 1

(3 rows)

Note: Because there is no ORDER BY clause, on your computer these data may not be in the
same order as shown here.

Exercise:
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Summarise the people by street name and show the actual street names instead of
the street_id’s

Solution:

select count(people.name), streets.name
from people, streets
where people.street_id=streets.id
group by streets.name;

Result:

count | name
-------+-----------------

1 | New Main Street
2 | High street
1 | QGIS Road

(3 rows)

Note: You will notice that we have prefixed field names with table names (e.g. people.name
and streets.name). This needs to be done whenever the field name is ambiguous.

14.4.7 In conclusion

You’ve seen how to use queries to return the data in your database in a way that allows you to
extract useful information from it.
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14.4.8 What’s next?

Next you’ll see how to create views from the queries that you’ve written.

14.5 Lesson: Views

When you write a query, you need to spend a lot of time and effort formulating it. With views,
you can save the definition of a sql query in a reusable ‘virtual table’.

The goal for this lesson: To save a query as a view.

14.5.1 Creating a View

You can treat a view just like a table, but its data is sourced from a query. Let’s make a simple
view based on the above.

create view roads_count_v as
select count(people.name), streets.name
from people, streets where people.street_id=streets.id
group by people.street_id, streets.name;

As you can see the only change is the create view roads_count_v as part at the
beginning. The nice thing is that we can now select data from that view:

select * from roads_count_v;

Result:

count | name
-------+-----------------

1 | New Main Street
2 | High street
1 | QGIS Road

(3 rows)

14.5.2 Modifying a View

A view is not fixed, and it contains no ‘real data’. This means you can easily change it without
impacting on any data in your database.

CREATE OR REPLACE VIEW roads_count_v AS
SELECT count(people.name), streets.name
FROM people, streets WHERE people.street_id=streets.id
GROUP BY people.street_id, streets.name
ORDER BY streets.name;

(This example also shows the best practice convention of using UPPER CASE for all SQL
keywords.)
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You will see that we have added an ORDER BY clause so that our view rows are nicely sorted:

count | name
-------+-----------------

2 | High street
1 | New Main Street
1 | QGIS Road

(3 rows)

14.5.3 Dropping a View

If you no longer need a view, you can delete it like this:

drop view roads_count_v;

14.5.4 In conclusion

Using views, you can save a query and access its results as if it were a table.

14.5.5 What’s next?

Sometimes, when changing data, you want your changes to have effects elsewhere in the
database. The next lesson will show you how to do this.

14.6 Lesson: Rules

Rules allow the “query tree” of an incoming query to be rewritten. One common
usage is to implement views, including updatable view. - Wikipedia

The goal for this lesson: To learn how to create new rules for the database.

14.6.1 Materialised Views (Rule based views)

Say you want to log every change of phone_no in your people table in to a people_log table.
So you set up a new table

create table people_log (name text, time timestamp default NOW());

In the next step create a rule, that logs every change of a phone_no in the people table into the
people_log table:

create rule people_log as on update to people
where NEW.phone_no <> OLD.phone_no
do insert into people_log values (OLD.name);
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To test that the rule works, let’s modify a phone number:

update people set phone_no = ’082 555 1234’ where id = 2;

Check that the table was updated correctly:

id | name | house_no | street_id | phone_no
----+------------+----------+-----------+--------------

2 | Joe Bloggs | 3 | 2 | 082 555 1234
(1 row)

Now, thanks to the rule we created, the people_log table will look like this:

name | time
------------+----------------------------
Joe Bloggs | 2012-04-23 15:20:56.683382
(1 row)

Note: The value of the time field will depend on the current date and time.

14.6.2 In conclusion

Rules allow you to automatically add or change data in your database to reflect changes in other
parts of the database.

14.6.3 What’s next?

The next module will introduce you to PostGIS, which takes these database concepts and ap-
plies them to GIS data.
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CHAPTER 15

Module: PostGIS

PostGIS is an extension to PostgreSQL which allows it to handle and process geographic data.
In this module, we’ll learn how to set up and use the geographic functions that PostGIS offers.

While working through this section, you may want to keep a copy of the PostGIS cheat sheet
available at Boston GIS user group1. Another good friend is the online2 PostGIS documenta-
tion.

See also PostGIS online3.

15.1 Lesson: PostGIS Setup

Setting up PostGIS functions will allow you to access spatial functions from within Post-
greSQL.

The goal for this lesson: To install spatial functions and briefly demo their effects.

15.1.1 Installing under Ubuntu

Postgis is easily installed from apt.

sudo apt-get install postgis
sudo apt-get install postgresql-9.1-postgis

Really, it’s that easy...

15.1.2 Installing under Windows

Visit the download page4.

1http://www.bostongis.com/postgis_quickguide.bqg
2http://postgis.refractions.net/documentation/manual-1.5/
3http://postgisonline.org/
4http://www.postgresql.org/download/
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Now follow this guide5.

A little more complicated, but still not hard. Note that you need to be online to install the
postgis stack.

15.1.3 Install plpgsql

Note: You can ensure that any database created on your system automatically gets these
spatial extensions by running these commands (from this and the next two sections) on the
template1 system database before you create any of your own databases.

PostgreSQL can use various procedural languages. What is a procedural language? It is an ‘in
database’ language that can be used to extend the functionality of the database. For example
you can write database functions that are called when events happen - such as when a record is
inserted into the database. (Recall when this was done in the previous module.)

PostGIS requires the PLPGSQL procedural language to be installed. So do this:

createlang plpgsql address

Where the third argument is the name of the database that the procedural language should be
installed into.

Note: You will need administrative permissions for your database to be able to do this.

15.1.4 Install postgis.sql

PostGIS can be thought of as a collection of in database functions that extend the core capabili-
ties of PostgreSQL so that it can deal with spatial data. By ‘deal with’, we mean store, retrieve,
query and manipulate. In order to do this, a number of functions are installed into the database.
Do this:

psql address < /usr/share/postgresql/9.1/contrib/postgis-1.5/postgis.sql

or

psql address < /usr/share/postgresql/9.1/contrib/postgis-2.0/postgis.sql

depending on which PostGIS version you have installed. Now do:

psql address

and, once you’re in the psql prompt:

\df

We will discuss these functions in more detail as we proceed with this course.

5http://www.bostongis.com/PrinterFriendly.aspx?content_name=postgis_tut01
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15.1.5 Install spatial_refsys.sql

In addition to the PostGIS functions, a second helper SQL script needs to be run that will
load the database with a collection of spatial reference system (SRS) definitions as defined
by the European Petroleum Survey Group (EPSG). These are used during operations such as
coordinate reference system (CRS) conversions.

You can add more to the SRS list later if needed, but the list provided should cover just about
every SRS you will need (Google Mercator and lo are notable exceptions).

To load the SRS table, first ensure that you’re at a normal prompt (i.e., quit the database first
with q), then do this:

psql address < /usr/share/postgresql/9.1/contrib/postgis-1.5/spatial_ref_sys.sql

replacing 1.5 with 2.0 if necessary.

The above command adds a table to our database. We can see the schema of this table by
entering the following command in the psql prompt:

address=# \d spatial_ref_sys

The result should be this:

Table "public.spatial_ref_sys"
Column | Type | Modifiers

-----------+-------------------------+-----------
srid | integer | not null
auth_name | character varying(256) |
auth_srid | integer |
srtext | character varying(2048) |
proj4text | character varying(2048) |
Indexes:

"spatial_ref_sys_pkey" PRIMARY KEY, btree (srid)

You can use standard SQL queries (as we have learned from our introductory sections), to view
and manipulate this table - though we suggest you do not update or delete any records unless
you know what you are doing.

One SRID you may be interested in is EPSG:4326 - the geographic / lat lon reference system
using the WGS 84 ellipsoid. Let’s take a look at it:

select * from spatial_ref_sys where srid=4326;

Result

srid | 4326
auth_name | EPSG
auth_srid | 4326
srtext | GEOGCS["WGS 84",DATUM["WGS_1984",SPHEROID["WGS
84",6378137,298.257223563,AUTHORITY["EPSG","7030"]],TOWGS84[0,
0,0,0,0,0,0],AUTHORITY["EPSG","6326"]],PRIMEM["Greenwich",0,
AUTHORITY["EPSG","8901"]],UNIT["degree",0.01745329251994328,
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AUTHORITY["EPSG","9122"]],AUTHORITY["EPSG","4326"]]
proj4text | +proj=longlat +ellps=WGS84 +datum=WGS84 +no_defs

The srtext is the projection definition in well known text (you may recognise this from .prj files
in your shapefile collection).

15.1.6 Looking at the installed PostGIS functions

Good - our PostgreSQL database is now geospatially enabled, thanks to PostGIS. We are going
to delve a lot deeper into this in the coming days, but let’s give you a quick little taster. Let’s say
we want to create a point from text. First we use the psql command to find functions relating
to point:

\df *point*

Here is one that caught my eye: st_pointfromtext

So let’s give that a try:

address=# select st_pointfromtext(’POINT(1 1)’);

Result:

st_pointfromtext
--------------------------------------------
0101000000000000000000F03F000000000000F03F
(1 row)

So there are a couple of interesting things going on here:

• we defined a point at position 1,1 (EPSG:4326 is assumed) using POINT(1 1)

• we ran an sql statement, but not on any table, just on data entered from the SQL prompt

• the resulting row looks kinda strange

The resulting row is looking strange because its in the OGC format called ‘Well Known Binary’
(WKB) - more on that coming in the next section.

To get the results back as text, I do a quick scan through the function list for something that
returns text:

\df *text

One that catches my eye is st_astext. Let’s combine it with the previous query:

select st_astext(st_pointfromtext(’POINT(1 1)’));

Result:

st_astext
------------

POINT(1 1)
(1 row)
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So what’s happened here? We entered the string POINT(1,1), turned it into a point
using st_pointfromtext(), and turned it back into a human-readable form with
st_astext(), which gave us back our original string.

One last example before we really get into the detail of using PostGIS:

select st_astext(st_buffer(st_pointfromtext(’POINT(1 1)’),1.0));

What did that do? It created a buffer of 1 degree around our point, and returned it as text. Nifty
hey?

15.1.7 In conclusion

You now have PostGIS functions installed in your copy of PostgreSQL. With this you’ll be able
to make use of PostGIS’ extensive spatial functions.

15.1.8 What’s next?

Next you’ll learn how spatial features are represented in a database.

15.2 Lesson: Simple Feature Model

How can we store and represent geographic features in a database? In this lesson we’ll cover
one approach, the Simple Feature Model as defined by the OGC.

The goal for this lesson: To learn what the SFS Model is and how to use it.

15.2.1 What is OGC

The Open Geospatial Consortium (OGC), an international voluntary consensus
standards organization, originated in 1994. In the OGC, more than 370+ commer-
cial, governmental, nonprofit and research organizations worldwide collaborate in
an open consensus process encouraging development and implementation of stan-
dards for geospatial content and services, GIS data processing and data sharing. -
Wikipedia

15.2.2 What is the SFS Model

The Simple Feature for SQL (SFS) Model is a non-topological way to store geospatial data in
a database and defines functions for accessing, operating, and constructing these data.
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The model defines geospatial data from Point, Linestring, and Polygon types (and aggregations
of them to Multi objects).

For further information, have a look at the OGC Simple Feature for SQL6 standard.

15.2.3 Add a geometry field to table

Let’s add a point field to our people table:

alter table people add column the_geom geometry;

15.2.4 Add a constraint based on geometry type

You will notice that the geometry field type does not implicitly specify what type of geometry
for the field - for that we need a constraint.

alter table people
add constraint people_geom_point_chk

check(st_geometrytype(the_geom) = ’ST_Point’::text OR the_geom IS NULL);

What does that do? It adds a constraint to the table that prevents anything except a point
geometry or a null.

Now you try:

Create a new table called cities and give it some appropriate columns, including
a geometry field for storing polygons (the city boundaries). Make sure it has a
constraint enforcing geometries to be polygons.

6http://www.opengeospatial.org/standards/sfs
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Check your results

15.2.5 Populate geometry_columns table

At this point you should also add an entry into the geometry_columns table:

insert into geometry_columns values
(’’,’public’,’people’,’the_geom’,2,4326,’POINT’);

Why? geometry_columns is used by certain applications to be aware of which tables in
the database contain geometry data.

Note: If the above INSERT statement causes a complaint, run this query first:
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select * from geometry_columns;

If the column f_table_name contains the value people, then this table has already been
registered and you don’t need to do anything more.

The value 2 refers to the number of dimensions; in this case, two: x and y.

The value 4326 refers to the projection we are using; in this case, WGS 84, which is referred
to by the number 4326 (refer to the earlier discussion about the EPSG).

Add an appropriate geometry_columns entry for your new cities layer

Check your results

15.2.6 Add geometry record to table using SQL

Now that our tables are geo-enabled, we can store geometries in them!

insert into people (name,house_no, street_id, phone_no, the_geom)
values (’Fault Towers’,

34,
3,
’072 812 31 28’,
’SRID=4326;POINT(33 -33)’);
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Note: In the new entry above, you will need to specify which projection (SRID) you want
to use. This is because you entered the geometry of the new point using a plain string of text,
which does not automatically add the correct projection information. Obviously, the new point
needs to use the same SRID as the dataset it is being added to, so you need to specify it.

If at this point you were using a graphical interface, for example, specifying the projection for
each point would be automatic. In other words, you usually won’t need to worry about using
the correct projection for every point you want to add if you’ve already specified it for that
dataset, as we did earlier.

Now is probably a good time to fire up QGIS and try to view your people table. Also, we
should try editing / adding / deleting records and then performing select queries in the database
to see how the data has changed.

To load a PostGIS layer in QGIS, use the Layer → Add PostGIS Layers menu option or toolbar
button:

This will open the dialog:

Click on the New button to open this dialog:
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Then define a new connection, e.g.:

Name: myPG
Service:
Host: localhost
Port: 5432
Database: address
User:
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Password:

To see whether QGIS has found the address database and that your username and password
are correct, click Test Connect. If it works, check the boxes next to Save Username and Save
Password. Then click OK to create this connection.

Back in the Add PostGIS Layers dialog, click Connect and add layers to your project as usual.

Formulate a query that shows a person’s name, street name and position (from the
the_geom column) as plain text.

Check your results

15.2.7 In conclusion

You have seen how to add spatial objects to your database and view them in GIS software.

15.2.8 What’s next?

Next you’ll see how to import data into, and export data from, your database.
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15.3 Lesson: Import and Export

Of course, a database with no easy way to migrate data into it and out of it would be no fun.
Even more so for spatial data! Fortunately, there are a number of tools that will let you easily
move data into and out of PostGIS.

15.3.1 shp2pgsql

shp2pgsql is a commandline tool to import ESRI shapefiles to the database. Under Unix, you
can use the following command for importing a new PostGIS table:

shp2pgsql -s <SRID> -c -D -I <path to shapefile> <schema>.<table> | \
psql -d <databasename> -h <hostname> -U <username>

Under Windows, you have to perform the import process in two steps:

shp2pgsql -s <SRID> -c -D -I <path to shapefile> <schema>.<table> > import.sql
psql psql -d <databasename> -h <hostname> -U <username> -f import.sql

You may encounter this error:

ERROR: operator class "gist_geometry_ops" does not exist for access method
"gist"

This is a known issue regarding the creation in situ of a spatial index for the data you’re import-
ing. To avoid the error, exclude the -I parameter. This will mean that no spatial index is being
created directly, and you’ll need to create it in the database after the data have been imported.
(The creation of a spatial index will be covered in the next lesson.)

15.3.2 pgsql2shp

pgsql2shp is a commandline tool to export PostGIS Tables, Views or SQL select queries. To
do this under Unix:

pgsql2shp -f <path to new shapefile> -g <geometry column name> \
-h <hostname> -U <username> <databasename> <table | view>

To export the data using a query:

pgsql2shp -f <path to new shapefile> -g <geometry column name> \
-h <hostname> -U <username> "<query>"

15.3.3 ogr2ogr

ogr2ogr is a very powerful tool to convert data into and from postgis to many data formats.
ogr2ogr is part of the GDAL/OGR Software and has to be installed separately. To export a
table from PostGIS to GML, you can use this command:
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ogr2ogr -f GML export.gml PG:’dbname=<databasename> user=<username>
host=<hostname>’ <Name of PostGIS-Table>

15.3.4 SPIT

SPIT is a QGIS plugin which is delivered with QGIS. You can use SPIT for uploading ESRI
shapefiles to PostGIS.

Once you’ve added the SPIT plugin via the Plugin Manager, look for this button:

Clicking on it will give you the SPIT dialog:

You can add shapefiles to the database by clicking the Add button, which will give you a file
browser window.

15.3.5 In conclusion

Importing and exporting data to and from the database can be done in many various ways.
Especially when using disparate data sources, you will probably use these functions (or others
like them) on a regular basis.
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15.3.6 What’s next?

Next we’ll look at how to query the data we’ve created before.

15.4 Lesson: Spatial Queries

Spatial queries are no different from other database queries. You can use the geometry column
like any other database column. With the installation of PostGIS in our database, we have
additional functions to query our database.

The goal for this lesson: To see how spatial functions are implemented similarly to “normal”
non-spatial functions.

15.4.1 Spatial Operators

When you want to know which points are within a distance of 2 degrees to a point(X,Y) you
can do this with:

select *
from people
where st_distance(the_geom,’SRID=4326;POINT(33 -34)’) < 2;

Result:

id | name | house_no | street_id | phone_no | the_geom
----+--------------+----------+-----------+---------------+-----------------

6 | Fault Towers | 34 | 3 | 072 812 31 28 | 01010008040C0
(1 row)

Note: the_geom value above was truncated for space on this page. If you want to see the point
in human-readable coordinates, try something similar to what you did in the section “View a
point as WKT”, above.

How do we know that the query above returns all the points within 2 degrees? Why not 2
meters? Or any other unit, for that matter?

Check your results

15.4.2 Spatial Indexes

We also can define spatial indexes. A spatial index makes your spatial queries much faster. To
create a spatial index on the geometry column use:

CREATE INDEX people_geo_idx
ON people
USING gist
(the_geom);
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Result:

address=# \d people
Table "public.people"

Column | Type | Modifiers
-----------+-----------------------+----------------------------------------
id | integer | not null default

| | nextval(’people_id_seq’::regclass)
name | character varying(50) |
house_no | integer | not null
street_id | integer | not null
phone_no | character varying |
the_geom | geometry |

Indexes:
"people_pkey" PRIMARY KEY, btree (id)
"people_geo_idx" gist (the_geom) <-- new spatial key added
"people_name_idx" btree (name)

Check constraints:
"people_geom_point_chk" CHECK (st_geometrytype(the_geom) = ’ST_Point’::text
OR the_geom IS NULL)

Foreign-key constraints:
"people_street_id_fkey" FOREIGN KEY (street_id) REFERENCES streets(id)

Now you try - modify the cities table so its geometry column is spatially indexed.
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Check your results

15.4.3 PostGIS Spatial Functions Demo

In order to demo PostGIS spatial functions, we’ll create a new database containing some (fic-
tional) data.

To start, create a new database:

createdb postgis_demo

Remember to install PLPGSQL:

createlang plpgsql postgis_demo

Then install the PostGIS functions and the spatial reference system. For example, on Linux
with PostgreSQL 9.1 and PostGIS 1.5:

psql postgis_demo < /usr/share/postgresql/9.1/contrib/postgis-1.5/postgis.sql
psql postgis_demo < /usr/share/postgresql/9.1/contrib/postgis-1.5/spatial_ref_sys.sql

Next, import the data provided in the exercise_data/postgis/ directory. Refer back to
the previous lesson for instructions. You can import from the terminal or via SPIT. Import the
files into the following database tables:

• points.shp = building

• lines.shp = road

• polygons.shp = region

Load these three database layers into QGIS via the Add PostGIS Layers dialog, as usual. When
you open their attribute tables, you’ll note that they have both an id field and a gid field
created by the PostGIS import.

Now that the tables are imported, we can use PostGIS to query the data. Go back to your
terminal (command line) and enter the psql prompt by doing:

psql postgis_demo

We’ll demo some of these select statements by creating views from them, so that you can open
them in QGIS and see the results.
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Select by location

Get all the buildings in the KwaZulu region.

SELECT a.id, a.name, st_astext(a.the_geom) as point
FROM building a, region b

WHERE WITHIN(a.the_geom, b.the_geom)
AND b.name = ’KwaZulu’;

Result:

id | name | point
----+------+------------------------------------------
30 | York | POINT(1622345.23785063 6940490.65844485)
33 | York | POINT(1622495.65620524 6940403.87862489)
35 | York | POINT(1622403.09106394 6940212.96302097)
36 | York | POINT(1622287.38463732 6940357.59605424)
40 | York | POINT(1621888.19746548 6940508.01440885)
(5 rows)

Or, if we create a view from it:

CREATE VIEW vw_select_location AS
SELECT a.gid, a.name, a.the_geom

FROM building a, region b
WHERE WITHIN(a.the_geom, b.the_geom)
AND b.name = ’KwaZulu’;

And view it in QGIS:
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Select neighbors

Show a list of all the names of regions adjoining the Hokkaido region.

SELECT b.name
FROM region a, region b

WHERE TOUCHES(a.the_geom, b.the_geom)
AND a.name = ’Hokkaido’;

Result:

name
--------------
Missouri
Saskatchewan
Wales
(3 rows)

As a view:

CREATE VIEW vw_regions_adjoining_hokkaido AS
SELECT b.gid, b.name, b.the_geom

FROM region a, region b
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WHERE TOUCHES(a.the_geom, b.the_geom)
AND a.name = ’Hokkaido’;

In QGIS:

Note the missing region (Queensland). This may be due to a topology error. Artifacts such as
this can alert us to potential problems in the data. To solve this enigma without getting caught
up in the anomalies the data may have, we could use a buffer intersect instead:

CREATE VIEW vw_hokkaido_buffer AS
SELECT gid, ST_BUFFER(the_geom, 100) as the_geom

FROM region
WHERE name = ’Hokkaido’;

This creates a buffer of 100 meters around the region Hokkaido.

The darker area is the buffer:
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Select using the buffer:

CREATE VIEW vw_hokkaido_buffer_select AS
SELECT b.gid, b.name, b.the_geom

FROM
(

SELECT * FROM
vw_hokkaido_buffer

) a,
region b
WHERE ST_INTERSECTS(a.the_geom, b.the_geom)
AND b.name != ’Hokkaido’;

In this query, the original buffer view is used as any other table would be. It is given the alias a,
and its geometry field, a.the_geom, is used to select any polygon in the region table (alias
b) that intersects it. However, Hokkaido itself is excluded from this select statement, because
we don’t want it; we only want the regions adjoining it.

In QGIS:
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It is also possible to select all objects within a given distance, without the extra step of creating
a buffer:

CREATE VIEW vw_hokkaido_distance_select AS
SELECT b.gid, b.name, b.the_geom

FROM region a, region b
WHERE ST_DISTANCE (a.the_geom, b.the_geom) < 100
AND a.name = ’Hokkaido’
AND b.name != ’Hokkaido’;

This achieves the same result, without need for the interim buffer step:
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Select uniques

Show a list of unique town names for all buildings in the Queensland region.

SELECT DISTINCT a.name
FROM building a, region b

WHERE WITHIN (a.the_geom, b.the_geom)
AND b.name = ’Queensland’;

Result:

name
---------
Beijing
Berlin
Atlanta
(3 rows)

Further examples ...

CREATE VIEW vw_shortestline AS
SELECT b.gid AS gid, ST_ASTEXT(ST_SHORTESTLINE(a.the_geom, b.the_geom)) as

text, ST_SHORTESTLINE(a.the_geom, b.the_geom) AS the_geom
FROM road a, building b

WHERE a.id=5 AND b.id=22;

CREATE VIEW vw_longestline AS
SELECT b.gid AS gid, ST_ASTEXT(ST_LONGESTLINE(a.the_geom, b.the_geom)) as

text, ST_LONGESTLINE(a.the_geom, b.the_geom) AS the_geom
FROM road a, building b

WHERE a.id=5 AND b.id=22;
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CREATE VIEW vw_road_centroid AS
SELECT a.gid as gid, ST_CENTROID(a.the_geom) as the_geom

FROM road a
WHERE a.id = 1;

CREATE VIEW vw_region_centroid AS
SELECT a.gid as gid, ST_CENTROID(a.the_geom) as the_geom

FROM region a
WHERE a.name = ’Saskatchewan’;

SELECT ST_PERIMETER(a.the_geom)
FROM region a

WHERE a.name=’Queensland’;

SELECT ST_AREA(a.the_geom)
FROM region a

WHERE a.name=’Queensland’;

CREATE VIEW vw_simplify AS
SELECT gid, ST_Simplify(the_geom, 20) AS the_geom

FROM road;

CREATE VIEW vw_simplify_more AS
SELECT gid, ST_Simplify(the_geom, 50) AS the_geom

FROM road;

CREATE VIEW vw_convex_hull AS
SELECT

ROW_NUMBER() over (order by a.name) as id,
a.name as town,
ST_CONVEXHULL(ST_COLLECT(a.the_geom)) AS the_geom
FROM building a
GROUP BY a.name;

15.4.4 In conclusion

You have seen how to query spatial objects using the new database functions from PostGIS.

15.4.5 What’s next?

Next we’re going to investigate the structures of more complex geometries and how to create
them using PostGIS.
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15.5 Lesson: Geometry Construction

In this section we are going to delve a little deeper into how simple geometries are constructed
in SQL. In reality, you will probably use a GIS like QGIS to create complex geometries using
their digitising tools; however, understanding how they are formulated can be handy for writing
queries and understanding how the database is assembled.

The goal of this lesson: To better understand how to create spatial entities directly in Post-
greSQL/PostGIS.

15.5.1 Creating Linestrings

Before we start, let’s get our streets table matching the others; i.e., having a constraint on the
geometry, an index and an entry in the geometry_columns table.

Exercise:

• Modify the streets table so that it has a geometry column of type
ST_LineString.

• Don’t forget to do the accompanying update to the geometry columns table!

• Also add a constraint to prevent any geometries being added that are not
LINESTRINGS or null.

• Create a spatial index on the new geometry column
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Check your results

Now let’s insert a linestring into our streets table. In this case I am going to update an existing
street record:

update streets set the_geom = ’SRID=4326;LINESTRING(20 -33, 21 -34, 24 -33)’
where streets.id=2;

Take a look at the results in QGIS. (You may need to right-click on the streets layer in the
‘Layers’ panel, and choose ‘Zoom to layer extent’.)

Now create some more streets entries - some in QGIS and some from the command line.

15.5.2 Creating Polygons

Creating polygons is just as easy. One thing to remember is that by definition, polygons have
at least four vertices, with the last and first being co-located.

insert into cities (name, the_geom)
values (’Tokyo’, ’SRID=4326;POLYGON((10 -10, 5 -32, 30 -27, 10 -10))’);

Note: A polygon requires double brackets around its coordinate list; this is to allow you to
add complex polygons with multiple unconnected areas. For instance:

insert into cities (name, the_geom)
values (’Tokyo Outer Wards’, ’SRID=4326;POLYGON((20 10, 20 20, 35 20, 20 10),

(-10 -30, -5 0, -15 -15, -10 -30))’);

If you followed this step, you can check what it did by loading the cities dataset into QGIS,
opening its attribute table, and selecting the new entry. Note how the two new polygons behave
like one polygon.

15.5.3 Exercise: Linking Cities to People

For this exercise you should do the following:

Delete all data from your people table. Add a foreign key column to people that
references the primary key of the cities table. Use QGIS to capture some cities.
Use SQL to insert some new people records, ensuring that each has an associated
street and city.

Your updated people schema should look something like this:
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\d people
Table "public.people"

Column | Type | Modifiers
-----------+-----------------------+--------------------------------------------
id | integer | not null

| | default nextval(’people_id_seq’::regclass)
name | character varying(50) |
house_no | integer | not null
street_id | integer | not null
phone_no | character varying |
the_geom | geometry |
city_id | integer | not null

Indexes:
"people_pkey" PRIMARY KEY, btree (id)
"people_name_idx" btree (name)

Check constraints:
"people_geom_point_chk" CHECK (st_geometrytype(the_geom) =

’ST_Point’::text OR the_geom IS NULL)
Foreign-key constraints:

"people_city_id_fkey" FOREIGN KEY (city_id) REFERENCES cities(id)
"people_street_id_fkey" FOREIGN KEY (street_id) REFERENCES streets(id)
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Check your results

15.5.4 Looking at our schema

By now our schema should be looking like this:

15.5.5 Access Subobjects

With the SFS-Model functions, you have a wide variety of options to access subobjects of SFS
Geometries. When you want to select the first vertex point of every polygon geometry in the
table myPolygonTable, you have to do this in this way:

• Transform the polygon boundary to a linestring:

select st_boundary(geometry) from myPolygonTable;

• select the first vertex point of the resultant linestring:

select st_startpoint(myGeometry)
from (

select st_boundary(geometry) as myGeometry
from myPolygonTable) as foo;
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15.5.6 Data Processing

PostGIS supports all OGC SFS/MM standard conform functions. All these functions start with
ST_.

15.5.7 Clipping

To clip a subpart of your data you can use the ST_INTERSECT() function. To avoid empty
geometries, use:

where not st_isempty(st_intersection(a.the_geom, b.the_geom))

select st_intersection(a.the_geom, b.the_geom), b.*
from clip as a, road_lines as b
where not st_isempty(st_intersection(st_setsrid(a.the_geom,32734),

b.the_geom));
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15.5.8 Building Geometries from Other Geometries

From a given point table, you want to generate a linestring. The order of the points is defined
by their id. Another ordering method could be a timestamp, such as the one you get when you
capture waypoints with a GPS receiver.
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To create a linestring from a new point layer called ‘points’, you can run the following com-
mand:

select ST_LineFromMultiPoint(st_collect(the_geom)), 1 as id
from (

select the_geom
from points
order by id

) as foo;

To see how it works without creating a new layer, you could also run this command on the
‘people’ layer, although of course it would make little real-world sense to do this.
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15.5.9 Geometry Cleaning

You can get more information for this topic in this blog entry7.

15.5.10 Differences between tables

To detect the difference between two tables with the same structure, you can use the Post-
greSQL keyword EXCEPT.

select * from table_a
except
select * from table_b;

As the result, you will get all records from table_a which are not stored in table_b.

7http://linfiniti.com/?s=cleangeometry
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15.5.11 Tablespaces

You can define where postgres should store its data on disk by creating tablespaces.

CREATE TABLESPACE homespace LOCATION ’/home/pg’;

When you create a database, you can then specify which tablespace to use e.g.:

createdb --tablespace=homespace t4a

15.5.12 In conclusion

You’ve learned how to create more complex geometries using PostGIS statements. Keep in
mind that this is mostly to improve your tacit knowledge when working with geo-enabled
databases through a GIS frontend. You usually won’t need to actually enter these statements
manually, but having a general idea of their structure will help you when using a GIS, especially
if you encounter errors that would otherwise seem cryptic.
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Appendix: Contributing To This Manual

To add materials to this course, you must follow the guidelines in this Appendix. You are not to
alter the conditions in this Appendix except for clarification. This is to ensure that the quality
and consistency of this manual can be maintained.

16.1 Downloading Resources

The source of this document is available at GitHub. Consult GitHub.com1 for instructions on
how to use the git version control system.

16.2 Manual Format

This manual is written using Sphinx2, a Python document generator using the reStructuredText3

markup language. Instructions on how to use these tools are available on their respective sites.

16.3 Adding a Module

• To add a new module, first create a new directory (directly under the top-level of the
qgis-training-manual directory) with the name of the new module.

• Under this new directory, create a file called index.rst. Leave this file blank for now.

• Open the index.rst file under the top-level directory. Its first lines are:

.. toctree::
:maxdepth: 2
:numbered:

1https://github.com/
2http://sphinx.pocoo.org/
3http://docutils.sourceforge.net/rst.html
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foreword/index
introduction/index

You will note that this is a list of directory names, followed by the name index. This directs
the top-level index file to the index files in each directory. The order in which they are listed
determines the order they will have in the document.

• Add the name of your new module (i.e., the name you gave the new directory), followed
by /index, to this list, wherever you want your module to appear.

• Remember to keep the order of the modules logical, such that later modules build on the
knowledge presented in earlier modules.

• Open your new module’s own index file ([module name]/index.rst).

• Along the top of the page, write a line of 80 asterisks (*). This represents a module
heading.

• Follow this with a line containing the markup phrase |MOD| (which stands for “mod-
ule”), followed by the name of your module.

• End this off with another line of 80 asterisks.

• Leave a line open beneath this.

• Write a short paragraph explaining the purpose and content of the module.

• Leave one line open, then add the following text:

.. toctree::
:maxdepth: 2
:numbered:

lesson1
lesson2

... where lesson1, lesson2, etc., are the names of your planned lessons.

The module-level index file will look like this:

*******************************************************************************
|MOD| Module Name

*******************************************************************************

Short paragraph describing the module.

.. toctree::
:maxdepth: 2
:numbered:

lesson1
lesson2
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16.4 Adding a Lesson

To add a lesson to a new or existing module:

• Open the module directory.

• Open the index.rst file (created above in the case of new modules).

• Ensure that the name of the planned lesson is listed underneath the toctree directive,
as shown above.

• Create a new file under the module directory.

• Name this file exactly the same as the name you provided in the module’s index.rst
file, and add the extension .rst.

Note: For editing purposes, a .rst file works exactly like a normal text file (.txt).

• To begin writing the lesson, write the markup phrase |LS|, followed by the lesson name.

• In the next line, write a line of 80 equal signs (=).

• Leave a line open after this.

• Write a short description of the lesson’s intended purpose.

• Include a general introduction to the subject matter. See the existing lessons in this
manual for examples.

• Beneath this, start a new paragraph, beginning with this phrase:

**The goal for this lesson:**

• Briefly explain the intended outcome of completing this lesson.

• If you can’t describe the goal of the lesson in one or two sentences, consider breaking the
subject matter up into multiple lessons.

Each lesson will be subdivided into multiple sections, which will be addressed next.

16.5 Adding a Section

There are two types of sections: “follow along” and “try yourself”.

• A “follow along” section is a detailed set of directions intended to teach the reader how
to use a given aspect of QGIS. This is typically done by giving click-by-click directions
as clearly as possible, interspersed with screenshots.

• A “try yourself” section gives the reader a short assignment to try by themselves. It is
usually associated with an entry in the answer sheet at the end of the documentation,
which will show or explain how to complete the assignment, and will show the expected
outcome if possible.
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Every section comes with a difficulty level. An easy section is denoted by |basic|, moderate
by |moderate|, and advanced by |hard|.

16.5.1 Adding a “follow along” section

• To start this section, write the markup phrase of the intended difficulty level (as shown
above).

• Leave a space and then write |FA| (for “follow along”).

• Leave another space and write the name of the section (use only an initial capital letter,
as well as capitals for proper nouns).

• In the next line, write a line of 80 minuses/dashes (-). Ensure that your text editor does
not replace the default minus/dash character with a long dash or other character.

• Write a short introduction to the section, explaining its purpose. Then give detailed
(click-by-click) instructions on the procedure to be demonstrated.

• In each section, include internal links, external links and screenshots as needed.

• Try to end each section with a short paragraph that concludes it and leads naturally to the
next section, if possible.

16.5.2 Adding a “try yourself” section

• To start this section, write the markup phrase of the intended difficulty level (as shown
above).

• Leave a space and then write |TY| (for “try yourself”).

• In the next line, write a line of 80 minuses/dashes (-). Ensure that your text editor does
not replace the default minus/dash character with a long dash or other character.

• Explain the exercise that you want the reader to complete. Refer to previous sections,
lessons or modules if necessary.

• Include screenshots to clarify the requirements if a plain textual description is not clear.

In most cases, you will want to provide an answer regarding how to complete the assignment
given in this section. To do so, you will need to add an entry in the answer sheet.

• First, decide on a unique name for the answer. Ideally, this name will include the name
of the lesson and an incrementing number.

• Create a link for this answer:

:ref:‘Check your results <answer-name>‘

• Open the answer sheet (answers/answers.rst).

• Create a link to the “try yourself” section by writing this line:
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.. _answer-name:

• Write the instructions on how to complete the assignment, using links and images where
needed.

• To end it off, include a link back to the “try yourself” section by writing this line:

:ref:‘Back to text <backlink-answer-name>‘

• To make this link work, add the following line above the heading to the “try yourself”
section:

.. _backlink-answer-name:

Remember that each of these lines shown above must have a blank line above and below it,
otherwise it could cause errors while creating the document.

16.6 Add a Conclusion

• To end a lesson, write the phrase |IC| for “in conclusion”, followed by a new line of 80
minuses/dashes (-). Write a conclusion for the lesson, explaining which concepts have
been covered in the lesson.

16.7 Add a Further Reading Section

• This section is optional.

• Write the phrase FR for “further reading”, followed by a new line of 80 minuses/dashes
(-).

• Include links to appropriate external websites.

16.8 Add a What’s Next Section

• Write the phrase |WN| for “what’s next”, followed by a new line of 80 minuses/dashes
(-).

• Explain how this lesson has prepared students for the next lesson or module.

• Remember to change the “what’s next” section of the previous lesson if necessary, so
that it refers to your new lesson. This will be necessary if you have inserted a new lesson
among existing lessons, or after an existing lesson.

16.9 Using Markup

To adhere to the standards of this document, you will need to add standard markup to your text.
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16.9.1 New concepts

• If you are explaining a new concept, you will need to write the new concept’s name in
italics by enclosing it in asterisks (*).

This sample text shows how to introduce a *new concept*.

16.9.2 Emphasis

• To emphasize a crucial term which is not a new concept, write the term in bold by en-
closing it in double asterisks (**).

• Use this sparingly! If used too much, it can seem to the reader that you are shouting or
being condescending.

This sample text shows how to use **emphasis** in a sentence. Include the
punctuation mark if it is followed by a **comma,** or at the **end of the
sentence.**

16.9.3 Images

• When adding an image, save it to the folder _static/lesson_name/.

• Include it in the document like this:

.. image:: ../_static/lesson_name/image_file.extension
:align: center

• Remember to leave a line open above and below the image markup.

16.9.4 Internal links

• To create an anchor for a link, write the following line above the place where you want
the link to point to:

.. _link-name:

• To create a link, add this line:

:ref:‘Descriptive link text <link-name>‘

• Remember to leave a line open above and below this line.

16.9.5 External links

• To create an external link, write it out like this:
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‘Descriptive link text <link-url>‘_

• Remember to leave a line open above and below this line.

16.9.6 Using monospaced text

• When you are writing text that the user needs to enter, a path name, or the name of a
database element such as a table or column name, you must write it in monospaced
text. For example:

Enter the following path in the text box: :kbd:‘path/to/file‘.

16.9.7 Labeling GUI items

• If you are referring to a GUI item, such as a button, you must write its name in the GUI
label format. For example:

To access this tool, click on the :guilabel:‘Tool Name‘ button.

• This also applies if you are mentioning the name of a tool without requiring the user to
click a button.

16.9.8 Menu selections

• If you are guiding a user through menus, you must use the menu → selection → format.
For example:

To use the :guilabel:‘Tool Name‘ tool, go to :menuselection:‘Plugins -->
Tool Type --> Tool Name‘.

16.9.9 Adding notes

• You might need to a note in the text, which explains extra details that can’t easily be
made part of the flow of the lesson. This is the markup:

[Normal paragraph.]

.. note:: Note text.
New line within note.

New paragraph within note.

[Unindented text resumes normal paragraph.]
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16.9.10 Adding a sponsorship/authorship note

If you are writing a new module, lesson or section on behalf of a sponsor, you must include
a short sponsor message of their choice. This must notify the reader of the name of the spon-
sor and must appear below the heading of the module, lesson or section that they sponsored.
However, it may not be an advertisement for their company.

If you have volunteered to write a module, lesson or section in your own capacity,
and not on behalf of a sponsor, you may include an authorship note below the head-
ing of the module, lesson or section that you authored. This must take the form This
[module/lesson/section] contributed by [author name]. Do not add
further text, contact details, etc. Such details are to be added in the “Contributors” section
of the Foreword, along with the name(s) of the part(s) you added. If you only made enhance-
ments, corrections and/or additions, list yourself as an editor.

16.10 Thank You!

Thank you for contributing to this project! By so doing, you are making QGIS more accessible
to users and adding value to the QGIS project as a whole.
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CHAPTER 17

Answer Sheet

17.1 Results for Adding Your First Layer

17.1.1 Preparation

You should see a lot of lines, symbolizing roads. All these lines are in the vector layer that you
just loaded to create a basic map.

Back to text

17.2 Results for An Overview of the Interface

17.2.1 Overview (Part 1)

Refer back to the image showing the interface layout and check that you remember the names
and functions of the screen elements.

Back to text

17.2.2 Overview (Part 2)

1. Save as

2. Zoom to layer

3. Help

4. Rendering on/off

5. Measure line

Back to text
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17.3 Results for Working with Vector Data

17.3.1 Shapefiles

There should be two layers on your map:

• places and

• streets.

Back to text

17.3.2 Databases

All the vector layers should be loaded into the map. It probably won’t look nice yet:

(We’ll fix the ugly colors later.)
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Back to text

17.4 Results for Symbology

17.4.1 Colors

• Verify that the colors are changing as you expect them to change.

• It is enough to change only the rural layer for now. An example is below, but may look
different depending on the color you chose.

Note: If you want to work on only one layer at a time and don’t want the other layers to
distract you, you can hide a layer by clicking in the check box next to its name in the Layers
list. If the box is blank, then the layer is hidden.

Back to text
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17.4.2 Symbol Structure

Seen together, your rural and urban layers should look more or less like this:

If you are a Beginner-level user, you may stop here.

• Use the method above to change the colors and styles for all the remaining layers.

• Try using natural colors for the objects. For example, a road should not be red or blue,
but can be gray or black.

• Also feel free to experiment with different Fill Style and Border Style settings for the
polygons.

Back to text

17.4.3 Symbol Layers

• Customize your layers as you like, but remember that it has to be easy to tell different
layers apart on the map.

Here’s an example:
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Back to text

17.4.4 Symbol Levels

To make the required symbol, you need at least three symbol layers:
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The lowest symbol layer is a broad, solid yellow line. On top of it there is a slightly thinner
solid dark gray or black line. The symbol layer on top is a thin white dashed line.

• If your symbol layers resemble the above but you’re not getting the result you want,
check that your symbol levels look something like this:
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• Now your symbol should look like this:
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• Which, on the map, gives you this kind of effect:
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Back to text

17.4.5 Symbol Levels

• Adjust your symbol levels to these values:
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• Experiment with different values to get different results.

• Open your original map again before continuing with the next exercise.

Back to text

17.5 Results for Attribute Data

17.5.1 Attribute Data

The NAME field is the most useful to show as labels. This is because all its values are unique
for every object, and it contains no “null” values (i.e., fields with no value).

Back to text
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17.6 Results for The Label Tool

17.6.1 Label Customization (Part 1)

Your map should look like this:

Back to text

17.6.2 Label Customization (Part 2)

One possible solution has this final product:
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To arrive at this result:

• Use the font type Arial of size 10 and a Label distance of 1,5 mm.

• In addition, this example uses the Wrap label on character option:
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• Enter a space in this field and click Apply to achieve the same effect.

Back to text

17.6.3 Using Data Defined Settings

• Still in edit mode, set the FONT_SIZE values to whatever you prefer. The example uses
12 for towns, 10 for suburbs and villages, and 8 for the null entries.

• Remember to save changes and exit edit mode.

• In Data defined settings, do this:
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Your results, if using the above values, should be this:

Back to text
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17.7 Results for Classification

17.7.1 Refine the Classification

• Use the same method as in the first exercise of the lesson to get rid of the lines:

The settings you used might not be the same, but with the values Classes = 7 and Mode =
Natural Breaks (Jenks) (and using the same colors, of course), the map will look like this:
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Back to text

17.8 Results for Creating a New Vector Dataset

17.8.1 Digitizing

The symbology doesn’t matter, but the results should look more or less like this:
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Back to text

17.8.2 Topology: Avoid Intersections

Your map should look like this:
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Back to text

17.8.3 Topology: Add Ring Tool

The exact shape doesn’t matter, but you should be getting a hole in your feature, like this one:
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• Undo your edit before continuing with the exercise for the next tool.

Back to text

17.8.4 Topology: Add Part Tool

The exact shape and location doesn’t matter, but you should be getting an extra part on your
feature, like this one:
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• Note that you first need to select the farm with the selection tool ...

... so that QGIS knows which feature to add the new part to.

• Undo your edit before continuing with the exercise for the next tool.

Back to text
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17.8.5 Merge Features

• Use the feature with the id of 1237 as the source of your attributes (click on its entry in
the dialog, then click the Take attributes from selected feature button):

• Using Merge Selected Features will merge the attributes as well as the geometries:

Whereas Merge Attributes of Selected Features will keep the geometries distinct, but give
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them the same attributes.

Back to text

17.8.6 Forms

For the TYPE, there is obviously a limited amount of types that a road can be, and if you check
the attribute table for this layer, you’ll see that they are predefined.

• Set the widget to Unique values and leave Editable as False:

• A road is either a one-way or it isn’t, so ONEWAY should be a Checkbox.

Looking at the attribute table for streets, the value for when it’s not a one-way seems to be
NULL, and when it is, it’s yes.

• Set those values:
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• If you use the Identify tool on a street now while edit mode is active, the dialog you get
should look like this:

17.8. Results for Creating a New Vector Dataset 407



Quantum GIS Training Manual, Release 1.0

Back to text

17.9 Results for Vector Analysis

17.9.1 Find Important Roads

Your layer should now have these roads:

• Save this new layer (the same way you did before) un-
der exercise_data/residential_development/, as
important_roads.shp.

• Once the new layer has been added to your map, remove the old layer.

• If for some reason it gives you an error message saying that it can’t add the layer to the
map (this can happen), remember that you can add the layer yourself by using the Add
Vector Layer button as you did before.

Back to text
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17.9.2 Distance from High Schools

• Your buffer dialog should look like this:

The Buffer distance is 10000 meters (i.e., 10 kilometers).

• The Segments to approximate value is set to 20. This is optional, but it’s recommended,
because it makes the output buffers look smoother. Compare this:
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To this:
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The red circle is the buffer with Segments to approximate set to 20; the gray circle on
top of it is the buffer with Segments to approximate set to 5.

Back to text

17.10 Results for Raster Analysis

17.10.1 Calculate Aspect

• Set your DEM (Terrain analysis) dialog up like this:
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Your result:
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Back to text

17.10.2 Calculate Slope (less than 2 and 5 degrees)

• Set your Raster calculator dialog up like this:

17.10. Results for Raster Analysis 413



Quantum GIS Training Manual, Release 1.0

• For the 5 degree version, replace the 2 in the expression and file name with 5.

Your results:

• 2 degrees:
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• 5 degrees:
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Back to text

17.11 Results for Completing the Analysis

17.11.1 Raster to Vector

• Open the Query dialog by right-clicking on the all_terrain layer in the Layers list.

• Then build the query "suitable" = 1.

• Click OK to filter out all the polygons where this condition isn’t met.

When viewed over the original raster, the areas should overlap perfectly:
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• You can save this layer by right-clicking on the all_terrain layer in the Layers list and
choosing Save As..., then continue as per the instructions.

Back to text

17.11.2 Inspecting the Results

In this map, farms that are definitely not suitable are orange; farms that may still be suitable are
blue:
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The orange farms have almost no suitable terrain within them, and so can’t be used for the
intended purpose.

Back to text

17.11.3 Refining the Analysis

At the moment, your analysis should look like this (ignore the symbology):
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Consider a circular area, continuous for 350 meters in all directions.

If it is greater than 350 meters in radius, then subtracting 350 meters from its size (from all
directions) will result in a part of it being left in the middle.
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Therefore, you can run an interior buffer of 350 meters on your existing suitable_terrain vector
layer. In the output of the buffer function, whatever remains of the original layer will represent
areas where there is suitable terrain for 350 meters beyond.

To demonstrate:

• Go to Vector → Geoprocessing Tools → Buffer(s) to open the Buffer(s) dialog.

• Set it up like this:
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• Use the suitable_terrain layer with 10 segments and a buffer distance of -350. (The
distance is automatically in meters because your map is using a projected CRS.)

• Save the output in exercise_data/residential_development/ as
suitable_terrain_continuous350m.shp.

Your results will look like this:
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• Now use the Select by Location tool (Vector → Research Tools → Select by location).

• Set up like this:

• Select features in new_solution that intersect features in suit-
able_terrain_continuous350m.shp.

This is the result:
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The yellow farms are selected.

• Save the selection under exercise_data/residential_development/ as
final_answer.shp.

The farms that meet the revised criteria are here:
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Back to text

17.12 Results for WMS

17.12.1 Adding Another WMS Layer

Your map should look like this:
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Back to text

17.12.2 Adding a New WMS Server

• Use the same approach as before to add the new server and the appropriate layer as hosted
on that server:
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• If you zoom into the Swellendam area, you’ll notice that this dataset has a low resolution:

Therefore, it’s better not to use this data for the current map. The Blue Marble data is more
suitable at global or national scales.

Back to text

17.12.3 Finding a WMS Server

You may notice that many WMS servers are not always available. Sometimes
this is temporary, sometimes it is permanent. An example of a WMS server
that worked at the time of writing is the World Mineral Deposits WMS at
http://apps1.gdr.nrcan.gc.ca/cgi-bin/worldmin_en-ca_ows. It does not
require fees or have access constraints, and it is global. Therefore, it does satisfy the require-
ments. Keep in mind, however, that this is merely an example. There are many other WMS
servers to choose from.

Back to text
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17.13 Results for Spatial Queries

17.13.1 The Units Used in Spatial Queries

The units being used by the example query are degrees, because the CRS that the layer is using
is WGS 84. This is a Geographic CRS, which means that its units are in degrees. A Projected
CRS, like the UTM projections, is in meters.

Remember that when you write a query, you need to know which units the layer’s CRS is in.
This will allow you to write a query that will return the results that you expect.

Back to text

17.13.2 Creating a Spatial Index

CREATE INDEX cities_geo_idx
ON cities
USING gist (the_geom);

Back to text

17.14 Results for Geometry Construction

17.14.1 Creating Linestrings

alter table streets add column the_geom geometry;
alter table streets add constraint streets_geom_point_chk check

(st_geometrytype(the_geom) = ’ST_LineString’::text OR the_geom IS NULL);
insert into geometry_columns values (’’,’public’,’streets’,’the_geom’,2,4326,

’LINESTRING’);
create index streets_geo_idx

on streets
using gist
(the_geom);

Back to text

17.14.2 Linking Tables

delete from people;
alter table people add column city_id int not null references cities(id);

(capture cities in QGIS)
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insert into people (name,house_no, street_id, phone_no, city_id, the_geom)
values (’Faulty Towers’,

34,
3,
’072 812 31 28’,
1,
’SRID=4326;POINT(33 33)’);

insert into people (name,house_no, street_id, phone_no, city_id, the_geom)
values (’IP Knightly’,

32,
1,
’071 812 31 28’,
1,
’SRID=4326;POINT(32 -34)’);

insert into people (name,house_no, street_id, phone_no, city_id, the_geom)
values (’Rusty Bedsprings’,

39,
1,
’071 822 31 28’,
1,
’SRID=4326;POINT(34 -34)’);

If you’re getting the following error message:

ERROR: insert or update on table "people" violates foreign key constraint
"people_city_id_fkey"

DETAIL: Key (city_id)=(1) is not present in table "cities".

then it means that while experimenting with creating polygons for the cities table, you must
have deleted some of them and started over. Just check the entries in your cities table and use
any id which exists.

Back to text

17.15 Results for Simple Feature Model

17.15.1 Populating Tables

create table cities (id serial not null primary key,
name varchar(50),
the_geom geometry not null);

alter table cities
add constraint cities_geom_point_chk
check (st_geometrytype(the_geom) = ’ST_Polygon’::text );

Back to text
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17.15.2 Populate the Geometry_Columns Table

insert into geometry_columns values
(’’,’public’,’cities’,’the_geom’,2,4326,’POLYGON’);

Back to text

17.15.3 Adding Geometry

select people.name,
streets.name as street_name,
st_astext(people.the_geom) as geometry

from streets, people
where people.street_id=streets.id;

Result:

name | street_name | geometry
------------------+-----------------+---------------
Rusty Bedsprings | High street |
QGIS Geek | High street |
Joe Bloggs | New Main Street |
IP Knightly | QGIS Road |
Fault Towers | QGIS Road | POINT(33 -33)
(5 rows)

As you can see, our constraint allows nulls to be added into the database.

Back to text
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Indices and tables

• genindex

• modindex

• search
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